summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-18 14:16:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-18 14:16:32 +0000
commitc908cb85e31838090f9fd91c121ed7fce62495db (patch)
treec355ff4978c0d6606ac5d470ab214d27a47be109 /sys-fs
parentStable on alpha, bug #505378 (diff)
downloadgentoo-2-c908cb85e31838090f9fd91c121ed7fce62495db.tar.gz
gentoo-2-c908cb85e31838090f9fd91c121ed7fce62495db.tar.bz2
gentoo-2-c908cb85e31838090f9fd91c121ed7fce62495db.zip
Punt the badly broken versions to prevent anyone from mistakenly stabilizing them.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mdadm/ChangeLog6
-rw-r--r--sys-fs/mdadm/files/mdadm.service-r110
-rw-r--r--sys-fs/mdadm/mdadm-3.3-r4.ebuild87
-rw-r--r--sys-fs/mdadm/mdadm-3.3.1-r1.ebuild83
4 files changed, 5 insertions, 181 deletions
diff --git a/sys-fs/mdadm/ChangeLog b/sys-fs/mdadm/ChangeLog
index 763e6b7008a6..d87edb17c078 100644
--- a/sys-fs/mdadm/ChangeLog
+++ b/sys-fs/mdadm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/mdadm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/ChangeLog,v 1.183 2014/07/18 14:12:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/ChangeLog,v 1.184 2014/07/18 14:16:32 ssuominen Exp $
+
+ 18 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> -mdadm-3.3-r4.ebuild,
+ -mdadm-3.3.1-r1.ebuild, -files/mdadm.service-r1:
+ old
*mdadm-3.3.1-r2 (18 Jul 2014)
diff --git a/sys-fs/mdadm/files/mdadm.service-r1 b/sys-fs/mdadm/files/mdadm.service-r1
deleted file mode 100644
index f8877cb83563..000000000000
--- a/sys-fs/mdadm/files/mdadm.service-r1
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Software RAID monitoring and management
-ConditionPathExists=/etc/mdadm.conf
-
-[Service]
-ExecStart=/sbin/mdadm --monitor --scan
-
-[Install]
-WantedBy=multi-user.target
-
diff --git a/sys-fs/mdadm/mdadm-3.3-r4.ebuild b/sys-fs/mdadm/mdadm-3.3-r4.ebuild
deleted file mode 100644
index 6da084cf654f..000000000000
--- a/sys-fs/mdadm/mdadm-3.3-r4.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-3.3-r4.ebuild,v 1.2 2014/07/17 07:55:29 ssuominen Exp $
-
-EAPI="4"
-inherit multilib flag-o-matic systemd toolchain-funcs
-
-DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
-HOMEPAGE="http://neil.brown.name/blog/mdadm"
-DEB_PR=2
-SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.xz
- mirror://debian/pool/main/m/mdadm/${PN}_${PV}-${DEB_PR}.debian.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="static"
-
-DEPEND="virtual/pkgconfig
- app-arch/xz-utils"
-RDEPEND=">=sys-apps/util-linux-2.16"
-
-# The tests edit values in /proc and run tests on software raid devices.
-# Thus, they shouldn't be run on systems with active software RAID devices.
-RESTRICT="test"
-
-mdadm_emake() {
- emake \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CC="$(tc-getCC)" \
- CWFLAGS="-Wall" \
- CXFLAGS="${CFLAGS}" \
- MAP_DIR=/run/mdadm \
- "$@"
-}
-
-src_compile() {
- use static && append-ldflags -static
- mdadm_emake all mdassemble
-}
-
-src_test() {
- mdadm_emake test
-
- sh ./test || die
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- SYSTEMD_DIR=$(systemd_get_unitdir) \
- install
- emake \
- DESTDIR="${D}" \
- SYSTEMD_DIR=$(systemd_get_unitdir) \
- install-systemd
- into /
- dosbin mdassemble
- dodoc ChangeLog INSTALL TODO README* ANNOUNCE-${PV}
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm
- newconfd "${FILESDIR}"/mdadm.confd mdadm
- newinitd "${FILESDIR}"/mdraid.rc mdraid
- newconfd "${FILESDIR}"/mdraid.confd mdraid
- systemd_newunit "${FILESDIR}"/mdadm.service-r1 mdadm.service
-
- # From the Debian patchset
- into /usr
- dodoc "${WORKDIR}/debian/README.checkarray"
- dosbin "${WORKDIR}/debian/checkarray"
-
- insinto /etc/cron.weekly
- newins "${FILESDIR}"/mdadm.weekly mdadm
-}
-
-pkg_postinst() {
- if ! systemd_is_booted; then
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- # Only inform people the first time they install.
- elog "If you're not relying on kernel auto-detect of your RAID"
- elog "devices, you need to add 'mdraid' to your 'boot' runlevel:"
- elog " rc-update add mdraid boot"
- fi
- fi
-}
diff --git a/sys-fs/mdadm/mdadm-3.3.1-r1.ebuild b/sys-fs/mdadm/mdadm-3.3.1-r1.ebuild
deleted file mode 100644
index 59a4d83df4c4..000000000000
--- a/sys-fs/mdadm/mdadm-3.3.1-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-3.3.1-r1.ebuild,v 1.1 2014/07/17 07:03:55 ssuominen Exp $
-
-EAPI="4"
-inherit multilib flag-o-matic systemd toolchain-funcs udev
-
-DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
-HOMEPAGE="http://neil.brown.name/blog/mdadm"
-DEB_PR=2
-SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.xz
- mirror://debian/pool/main/m/mdadm/${PN}_3.3-${DEB_PR}.debian.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="static"
-
-DEPEND="virtual/pkgconfig
- app-arch/xz-utils"
-RDEPEND=">=sys-apps/util-linux-2.16"
-
-# The tests edit values in /proc and run tests on software raid devices.
-# Thus, they shouldn't be run on systems with active software RAID devices.
-RESTRICT="test"
-
-mdadm_emake() {
- emake \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CC="$(tc-getCC)" \
- CWFLAGS="-Wall" \
- CXFLAGS="${CFLAGS}" \
- MAP_DIR=/run/mdadm \
- UDEVDIR="$(get_udevdir)" \
- SYSTEMD_DIR="$(systemd_get_unitdir)" \
- "$@"
-}
-
-src_compile() {
- use static && append-ldflags -static
- mdadm_emake all mdassemble
-}
-
-src_test() {
- mdadm_emake test
-
- sh ./test || die
-}
-
-src_install() {
- # Use split lines because of bug #517218
- mdadm_emake DESTDIR="${D}" install
- mdadm_emake DESTDIR="${D}" install-systemd
- into /
- dosbin mdassemble
- dodoc ChangeLog INSTALL TODO README* ANNOUNCE-${PV}
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm
- newconfd "${FILESDIR}"/mdadm.confd mdadm
- newinitd "${FILESDIR}"/mdraid.rc mdraid
- newconfd "${FILESDIR}"/mdraid.confd mdraid
-
- # From the Debian patchset
- into /usr
- dodoc "${WORKDIR}"/debian/README.checkarray
- dosbin "${WORKDIR}"/debian/checkarray
-
- insinto /etc/cron.weekly
- newins "${FILESDIR}"/mdadm.weekly mdadm
-}
-
-pkg_postinst() {
- if ! systemd_is_booted; then
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- # Only inform people the first time they install.
- elog "If you're not relying on kernel auto-detect of your RAID"
- elog "devices, you need to add 'mdraid' to your 'boot' runlevel:"
- elog " rc-update add mdraid boot"
- fi
- fi
-}