summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-11-29 22:35:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-11-29 22:35:00 +0000
commitc8a3944b4ba3a8ae69c88f137c99ff99213d7a34 (patch)
treeccfc29b88a479774555066148b906ca8702db3f4 /sys-fs
parentredigest due to eclass change (diff)
downloadgentoo-2-c8a3944b4ba3a8ae69c88f137c99ff99213d7a34.tar.gz
gentoo-2-c8a3944b4ba3a8ae69c88f137c99ff99213d7a34.tar.bz2
gentoo-2-c8a3944b4ba3a8ae69c88f137c99ff99213d7a34.zip
Bug #293272: Parallel compile fix for case where no LVM/DM was already present on the system. Thanks to Stephan Hartmann <stha09@googlemail.com> for the fix.
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lvm2/ChangeLog8
-rw-r--r--sys-fs/lvm2/lvm2-2.02.51-r1.ebuild7
-rw-r--r--sys-fs/lvm2/lvm2-2.02.51-r2.ebuild7
3 files changed, 19 insertions, 3 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index 97aa5b1e7d66..ee077ec71d75 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/lvm2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.183 2009/11/29 22:07:49 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.184 2009/11/29 22:35:00 robbat2 Exp $
+
+ 29 Nov 2009; Robin H. Johnson <robbat2@gentoo.org> lvm2-2.02.51-r1.ebuild,
+ lvm2-2.02.51-r2.ebuild:
+ Bug #293272: Parallel compile fix for case where no LVM/DM was already
+ present on the system. Thanks to Stephan Hartmann <stha09@googlemail.com>
+ for the fix.
29 Nov 2009; Joseph Jezak <josejx@gentoo.org> lvm2-2.02.51-r1.ebuild:
Marked ppc/ppc64 for bug #287658.
diff --git a/sys-fs/lvm2/lvm2-2.02.51-r1.ebuild b/sys-fs/lvm2/lvm2-2.02.51-r1.ebuild
index b909935e4d83..cafeb7e27802 100644
--- a/sys-fs/lvm2/lvm2-2.02.51-r1.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.51-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.51-r1.ebuild,v 1.10 2009/11/29 22:07:49 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.51-r1.ebuild,v 1.11 2009/11/29 22:35:00 robbat2 Exp $
EAPI=2
inherit eutils multilib toolchain-funcs autotools
@@ -140,6 +140,11 @@ src_compile() {
emake || die "failed to build lib"
popd
+ einfo "Doing dmeventd"
+ pushd daemons/dmeventd
+ emake device-mapper || die "failed to build lib"
+ popd
+
einfo "Doing main build"
emake || die "compile problem"
}
diff --git a/sys-fs/lvm2/lvm2-2.02.51-r2.ebuild b/sys-fs/lvm2/lvm2-2.02.51-r2.ebuild
index 03fac1503ad0..28146c69c0c5 100644
--- a/sys-fs/lvm2/lvm2-2.02.51-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.51-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.51-r2.ebuild,v 1.3 2009/11/09 21:44:13 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.51-r2.ebuild,v 1.4 2009/11/29 22:35:00 robbat2 Exp $
EAPI=2
inherit eutils multilib toolchain-funcs autotools
@@ -140,6 +140,11 @@ src_compile() {
emake || die "failed to build lib"
popd
+ einfo "Doing dmeventd"
+ pushd daemons/dmeventd
+ emake device-mapper || die "failed to build lib"
+ popd
+
einfo "Doing main build"
emake || die "compile problem"
}