summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-12-17 22:37:22 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-12-17 22:37:22 +0000
commitc28e8a6b6ee54bae94bf83a4808ac8172f3520b6 (patch)
treeccbd456526777fc648c40ed7da92f74334ba60fd /sys-fs
parentfix /-prefix install (diff)
downloadgentoo-2-c28e8a6b6ee54bae94bf83a4808ac8172f3520b6.tar.gz
gentoo-2-c28e8a6b6ee54bae94bf83a4808ac8172f3520b6.tar.bz2
gentoo-2-c28e8a6b6ee54bae94bf83a4808ac8172f3520b6.zip
version bump
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog7
-rw-r--r--sys-fs/fuse/files/digest-fuse-2.7.23
-rw-r--r--sys-fs/fuse/fuse-2.7.2.ebuild85
3 files changed, 94 insertions, 1 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index f8c20e30f4cd..0c4c29484116 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.108 2007/10/18 16:03:21 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.109 2007/12/17 22:37:21 genstef Exp $
+
+*fuse-2.7.2 (17 Dec 2007)
+
+ 17 Dec 2007; Stefan Schweizer <genstef@gentoo.org> +fuse-2.7.2.ebuild:
+ version bump
*fuse-2.7.1 (18 Oct 2007)
diff --git a/sys-fs/fuse/files/digest-fuse-2.7.2 b/sys-fs/fuse/files/digest-fuse-2.7.2
new file mode 100644
index 000000000000..2e443eca891f
--- /dev/null
+++ b/sys-fs/fuse/files/digest-fuse-2.7.2
@@ -0,0 +1,3 @@
+MD5 813782a4f23211386c1ea91dc0ac7ded fuse-2.7.2.tar.gz 505855
+RMD160 bb07e9720131043fe2f5d68869d3aace124e2169 fuse-2.7.2.tar.gz 505855
+SHA256 fb390948aa27628e4fb48aa6658a20ad8c1ee304fe76bb60ac29b81c63d3baff fuse-2.7.2.tar.gz 505855
diff --git a/sys-fs/fuse/fuse-2.7.2.ebuild b/sys-fs/fuse/fuse-2.7.2.ebuild
new file mode 100644
index 000000000000..a64070c2a6fd
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.7.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.2.ebuild,v 1.1 2007/12/17 22:37:21 genstef Exp $
+
+inherit linux-mod eutils libtool
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace."
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_linux kernel_FreeBSD"
+S=${WORKDIR}/${MY_P}
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+
+pkg_setup() {
+ if use kernel_linux ; then
+ if kernel_is ge 2 6 25; then
+ CONFIG_CHECK="FUSE_FS"
+ FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
+ else
+ MODULE_NAMES="fuse(fs:${S}/kernel)"
+ CONFIG_CHECK="@FUSE_FS:fuse"
+ FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+ We will continue, but we wont build the module this time."
+
+ fi
+ linux-mod_pkg_setup
+ kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
+ older version from viewcvs"
+
+ BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+ BUILD_TARGETS="all"
+ ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --disable-kernel-module \
+ --disable-example \
+ || die "econf failed for fuse userland"
+ emake || die "emake failed"
+
+ if use kernel_linux ; then
+ cd "${S}"
+ sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
+ convert_to_m kernel/Makefile.in
+ linux-mod_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog Filesystems README \
+ README.NFS NEWS doc/how-fuse-works \
+ doc/kernel.txt FAQ
+ docinto example
+ dodoc example/*
+
+ if use kernel_linux ; then
+ linux-mod_src_install
+ newinitd ${FILESDIR}/fuse.init fuse
+ else
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ newinitd ${FILESDIR}/fuse-fbsd.init fuse
+ fi
+
+ rm -rf "${D}/dev"
+}
+
+pkg_postinst() {
+ use kernel_linux && linux-mod_pkg_postinst
+}