summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-04 07:55:13 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-04 07:55:13 +0000
commitc136873da63a15a716b49319a2f00b8d71796f42 (patch)
tree4658d7ee39cefcfbb7c2e2a9790c3c1751d3d101 /sys-fs
parentver bump (diff)
downloadgentoo-2-c136873da63a15a716b49319a2f00b8d71796f42.tar.gz
gentoo-2-c136873da63a15a716b49319a2f00b8d71796f42.tar.bz2
gentoo-2-c136873da63a15a716b49319a2f00b8d71796f42.zip
gcc-2.x compat patch
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog5
-rw-r--r--sys-fs/udev/files/udev-012-udev_c-gcc295-compat.patch13
-rw-r--r--sys-fs/udev/udev-012.ebuild5
3 files changed, 21 insertions, 2 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 9267f2aa2801..454824a600b3 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for sys-fs/udev
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.16 2004/01/01 03:41:24 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.17 2004/01/04 07:55:12 vapier Exp $
*udev-012 (01 Jan 2004)
+ 04 Jan 2004; Mike Frysinger <vapier@gentoo.org> udev-012-udev_c-gcc295-compat.patch :
+ Another gcc-2.x compatible patch. I thought these guys wrote C, not C++ :).
+
01 Jan 2004; Martin Schlemmer <azarah@gentoo.org> udev-012.ebuild,
files/udev.permissions:
Update version. Update udev.permissions (According to changes to Debian config
diff --git a/sys-fs/udev/files/udev-012-udev_c-gcc295-compat.patch b/sys-fs/udev/files/udev-012-udev_c-gcc295-compat.patch
new file mode 100644
index 000000000000..bd36747625b6
--- /dev/null
+++ b/sys-fs/udev/files/udev-012-udev_c-gcc295-compat.patch
@@ -0,0 +1,13 @@
+--- udev.c.orig 2004-01-04 02:50:40.000000000 -0500
++++ udev.c 2004-01-04 02:50:47.000000000 -0500
+@@ -214,9 +214,9 @@
+
+ int main(int argc, char **argv, char **envp)
+ {
++ int retval;
+ main_argv = argv;
+ main_envp = envp;
+- int retval;
+
+ dbg("version %s", UDEV_VERSION);
+
diff --git a/sys-fs/udev/udev-012.ebuild b/sys-fs/udev/udev-012.ebuild
index 55e10db7d80a..48406b1987cc 100644
--- a/sys-fs/udev/udev-012.ebuild
+++ b/sys-fs/udev/udev-012.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-012.ebuild,v 1.1 2004/01/01 03:41:24 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-012.ebuild,v 1.2 2004/01/04 07:55:13 vapier Exp $
# Note: Cannot use external libsysfs with klibc ..
USE_KLIBC="no"
@@ -65,6 +65,9 @@ src_unpack() {
# Do not sleep if UDEV_NO_SLEEP is set
epatch ${FILESDIR}/${PN}-011-no-wait-for-sleep.patch
+
+ # Fix gcc-2.95.3 compat
+ epatch ${FILESDIR}/${P}-udev_c-gcc295-compat.patch
}
src_compile() {