summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-07-22 00:40:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-07-22 00:40:49 +0000
commitade1e1dc18dc3e66ac0fc21d98f3c44ffbf99035 (patch)
tree7495ff1bc001283e3c60ee19ce7e5a4b5a313c03 /sys-fs
parentFixed tests. Closes bug #276299 (diff)
downloadgentoo-2-ade1e1dc18dc3e66ac0fc21d98f3c44ffbf99035.tar.gz
gentoo-2-ade1e1dc18dc3e66ac0fc21d98f3c44ffbf99035.tar.bz2
gentoo-2-ade1e1dc18dc3e66ac0fc21d98f3c44ffbf99035.zip
Bug #270350: implement pkgconfig for lvm2. Also bump to EAPI=2. Include new spin of as-needed patch, tested by Calchan.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lvm2/ChangeLog10
-rw-r--r--sys-fs/lvm2/files/lvm2-2.02.48-as-needed.patch14
-rw-r--r--sys-fs/lvm2/files/lvm2-2.02.48-fix-pkgconfig.patch45
-rw-r--r--sys-fs/lvm2/lvm2-2.02.48-r2.ebuild215
4 files changed, 276 insertions, 8 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index ee118026a4a0..bb127dabb5e5 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/lvm2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.162 2009/07/19 18:09:35 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.163 2009/07/22 00:40:49 robbat2 Exp $
+
+*lvm2-2.02.48-r2 (22 Jul 2009)
+
+ 22 Jul 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +lvm2-2.02.48-r2.ebuild, files/lvm2-2.02.48-as-needed.patch,
+ +files/lvm2-2.02.48-fix-pkgconfig.patch:
+ Bug #270350: implement pkgconfig for lvm2. Also bump to EAPI=2. Include
+ new spin of as-needed patch, tested by Calchan.
19 Jul 2009; Christian Ruppert <idl0r@gentoo.org>
files/lvm2-2.02.48-as-needed.patch:
diff --git a/sys-fs/lvm2/files/lvm2-2.02.48-as-needed.patch b/sys-fs/lvm2/files/lvm2-2.02.48-as-needed.patch
index 1f241e5f386e..2089beb72da8 100644
--- a/sys-fs/lvm2/files/lvm2-2.02.48-as-needed.patch
+++ b/sys-fs/lvm2/files/lvm2-2.02.48-as-needed.patch
@@ -145,9 +145,9 @@ diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/test/api/Make
+ $(CC) $(CFLAGS) $(LDFLAGS) -o test $(OBJECTS) $(LVMLIBS) $(LIBS)
diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/tools/Makefile.in LVM2.2.02.48/tools/Makefile.in
---- LVM2.2.02.48.orig/tools/Makefile.in 2009-05-21 04:11:29.000000000 -0700
-+++ LVM2.2.02.48/tools/Makefile.in 2009-07-05 14:38:36.536891908 -0700
-@@ -106,24 +106,30 @@ include $(top_srcdir)/make.tmpl
+--- LVM2.2.02.48.orig/tools/Makefile.in 2009-07-17 11:16:40.579301663 +0200
++++ LVM2.2.02.48/tools/Makefile.in 2009-07-21 19:27:05.526972872 +0200
+@@ -106,24 +106,29 @@ include $(top_srcdir)/make.tmpl
device-mapper: $(TARGETS_DM)
dmsetup: dmsetup.o $(top_srcdir)/libdm/libdevmapper.$(LIB_SUFFIX)
@@ -156,16 +156,16 @@ diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/tools/Makefil
+ $(CC) $(CFLAGS) $(LDFLAGS) \
+ -L$(top_srcdir)/libdm \
+ -o $@ dmsetup.o \
-+ -ldevmapper $(LIBS)
++ -ldevmapper $(LIB_PTHREAD)
dmsetup.static: dmsetup.o $(interfacedir)/libdevmapper.a
- $(CC) -o $@ dmsetup.o $(CFLAGS) $(LDFLAGS) -static \
- -L$(interfacedir) -ldevmapper $(LIBS) \
+- $(LIB_PTHREAD)
+ $(CC) $(CFLAGS) $(LDFLAGS) -static \
+ -L$(interfacedir) \
+ -o $@ dmsetup.o \
-+ -ldevmapper $(LIBS) \
- $(LIB_PTHREAD)
++ -ldevmapper $(LIB_PTHREAD)
all: device-mapper
@@ -185,4 +185,4 @@ diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/tools/Makefil
+ $(LVMLIBS) $(LIBS) $(LIB_PTHREAD) -rdynamic
liblvm2cmd.a: $(top_srcdir)/lib/liblvm-internal.a $(OBJECTS) lvmcmdlib.o lvm2cmd.o
- cat $(top_srcdir)/lib/liblvm-internal.a > $@
+ cat $(top_srcdir)/lib/liblvm-internal.a > $@ \ No newline at end of file
diff --git a/sys-fs/lvm2/files/lvm2-2.02.48-fix-pkgconfig.patch b/sys-fs/lvm2/files/lvm2-2.02.48-fix-pkgconfig.patch
new file mode 100644
index 000000000000..10d923b835b9
--- /dev/null
+++ b/sys-fs/lvm2/files/lvm2-2.02.48-fix-pkgconfig.patch
@@ -0,0 +1,45 @@
+libdevmapper.so doesn't link to SELinux libraries unless SELinux is enabled.
+Adding those libraries to Libs.private unconditionally is wrong.
+
+See bug 270350
+---
+--- LVM2.2.02.48/configure.in
++++ LVM2.2.02.48/configure.in
+@@ -558,18 +558,19 @@
+ if test x$HAVE_SEPOL = xyes; then
+ AC_DEFINE([HAVE_SEPOL], 1,
+ [Define to 1 if sepol_check_context is available.])
+- LIBS="-lsepol $LIBS"
++ SELINUX_LIBS="-lsepol $SELINUX_LIBS"
+ fi
+
+ AC_CHECK_LIB(selinux, is_selinux_enabled, HAVE_SELINUX=yes, HAVE_SELINUX=no)
+
+ if test x$HAVE_SELINUX = xyes; then
+ AC_DEFINE([HAVE_SELINUX], 1, [Define to 1 to include support for selinux.])
+- LIBS="-lselinux $LIBS"
++ SELINUX_LIBS="-lselinux $SELINUX_LIBS"
+ else
+ AC_MSG_WARN(Disabling selinux)
+ fi
+
++ LIBS="$SELINUX_LIBS $LIBS"
+ # With --enable-static_link and selinux enabled, linking
+ # fails on at least Debian unstable due to unsatisfied references
+ # to pthread_mutex_lock and _unlock. See if we need -lpthread.
+@@ -813,6 +814,7 @@
+ AC_SUBST(POOL)
+ AC_SUBST(QUORUM_CFLAGS)
+ AC_SUBST(QUORUM_LIBS)
++AC_SUBST(SELINUX_LIBS)
+ AC_SUBST(SNAPSHOTS)
+ AC_SUBST(STATICDIR)
+ AC_SUBST(STATIC_LINK)
+--- LVM2.2.02.48/libdm/libdevmapper.pc.in
++++ LVM2.2.02.48/libdm/libdevmapper.pc.in
+@@ -8,4 +8,4 @@
+ Version: @DM_LIB_PATCHLEVEL@
+ Cflags: -I${includedir}
+ Libs: -L${libdir} -ldevmapper
+-Libs.private: -lselinux -lsepol
++Libs.private: @SELINUX_LIBS@
diff --git a/sys-fs/lvm2/lvm2-2.02.48-r2.ebuild b/sys-fs/lvm2/lvm2-2.02.48-r2.ebuild
new file mode 100644
index 000000000000..e95641f5aace
--- /dev/null
+++ b/sys-fs/lvm2/lvm2-2.02.48-r2.ebuild
@@ -0,0 +1,215 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.48-r2.ebuild,v 1.1 2009/07/22 00:40:49 robbat2 Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs autotools
+
+DESCRIPTION="User-land utilities for LVM2 (device-mapper) software."
+HOMEPAGE="http://sources.redhat.com/lvm2/"
+SRC_URI="ftp://sources.redhat.com/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz
+ ftp://sources.redhat.com/pub/lvm2/old/${PN/lvm/LVM}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="readline static clvm cman lvm1 selinux"
+
+DEPEND="!sys-fs/device-mapper
+ clvm? ( =sys-cluster/dlm-2*
+ cman? ( =sys-cluster/cman-2* ) )"
+
+RDEPEND="${DEPEND}
+ !sys-fs/lvm-user
+ !sys-fs/clvm"
+
+S="${WORKDIR}/${PN/lvm/LVM}.${PV}"
+
+pkg_setup() {
+ # 1. Genkernel no longer copies /sbin/lvm blindly.
+ # 2. There are no longer any linking deps in /usr.
+ if use static; then
+ elog "Warning, we no longer overwrite /sbin/lvm and /sbin/dmsetup with"
+ elog "their static versions. If you need the static binaries,"
+ elog "you must append .static the filename!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.02.45-dmeventd.patch
+ epatch "${FILESDIR}"/lvm.conf-2.02.45.patch
+ epatch "${FILESDIR}"/${PN}-2.02.48-device-mapper-export-format.patch
+ epatch "${FILESDIR}"/${PN}-2.02.48-as-needed.patch
+ epatch "${FILESDIR}"/${PN}-2.02.48-fix-pkgconfig.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ local buildmode
+
+ myconf="${myconf} --enable-dmeventd"
+ myconf="${myconf} --enable-cmdlib"
+ myconf="${myconf} --enable-applib"
+ myconf="${myconf} --enable-fsadm"
+
+ # Most of this package does weird stuff.
+ # The build options are tristate, and --without is NOT supported
+ # options: 'none', 'internal', 'shared'
+ if use static ; then
+ einfo "Building static LVM, for usage inside genkernel"
+ buildmode="internal"
+ # This only causes the .static versions to become available
+ # For recent systems, there are no linkages against anything in /usr anyway.
+ # We explicitly provide the .static versions so that they can be included in
+ # initramfs environments.
+ myconf="${myconf} --enable-static_link"
+ else
+ ewarn "Building shared LVM, it will not work inside genkernel!"
+ buildmode="shared"
+ fi
+
+ # dmeventd requires mirrors to be internal, and snapshot available
+ # so we cannot disable them
+ myconf="${myconf} --with-mirrors=internal"
+ myconf="${myconf} --with-snapshots=internal"
+
+ if use lvm1 ; then
+ myconf="${myconf} --with-lvm1=${buildmode}"
+ else
+ myconf="${myconf} --with-lvm1=none"
+ fi
+
+ # disable O_DIRECT support on hppa, breaks pv detection (#99532)
+ use hppa && myconf="${myconf} --disable-o_direct"
+
+ if use clvm; then
+ myconf="${myconf} --with-cluster=${buildmode}"
+ # 4-state! Make sure we get it right, per bug 210879
+ # Valid options are: none, cman, gulm, all
+ #
+ # 2009/02:
+ # gulm is removed now, now dual-state:
+ # cman, none
+ # all still exists, but is not needed
+ #
+ # 2009/07:
+ # TODO: add corosync and re-enable ALL
+ local clvmd=""
+ use cman && clvmd="cman"
+ #clvmd="${clvmd/cmangulm/all}"
+ [ -z "${clvmd}" ] && clvmd="none"
+ myconf="${myconf} --with-clvmd=${clvmd}"
+ myconf="${myconf} --with-pool=${buildmode}"
+ else
+ myconf="${myconf} --with-clvmd=none --with-cluster=none"
+ fi
+
+ myconf="${myconf} --sbindir=/sbin --with-staticdir=/sbin"
+ econf $(use_enable readline) \
+ $(use_enable selinux) \
+ --enable-pkgconfig \
+ --libdir=/usr/$(get_libdir) \
+ ${myconf} \
+ CLDFLAGS="${LDFLAGS}" || die
+}
+
+src_compile() {
+ einfo "Doing symlinks"
+ pushd include
+ emake || die "Failed to prepare symlinks"
+ popd
+
+ einfo "Doing device-mapper"
+ pushd libdm
+ emake || die "failed to build libdm"
+ #emake ioctl/libdevmapper.a || die "failed to build libdm/ioctl/libdevmapper.a"
+ popd
+
+ einfo "Doing lib"
+ pushd lib
+ emake || die "failed to build lib"
+ popd
+
+ einfo "Doing main build"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodir /$(get_libdir)
+ # Put these in root so we can reach before /usr is up
+ for i in \
+ libdevmapper-event{,-lvm2{mirror,snapshot}} \
+ libdevmapper \
+ liblvm2{format1,snapshot,cmd} \
+ ; do
+ b="${D}"/usr/$(get_libdir)/${i}
+ if [ -f "${b}".so ]; then
+ mv -f "${b}".so* "${D}"/$(get_libdir) || die
+ gen_usr_ldscript ${i}.so || die
+ fi
+ done
+
+ dodoc README VERSION WHATS_NEW doc/*.{conf,c,txt}
+ insinto /$(get_libdir)/rcscripts/addons
+ newins "${FILESDIR}"/lvm2-start.sh-2.02.28-r2 lvm-start.sh || die
+ newins "${FILESDIR}"/lvm2-stop.sh-2.02.37 lvm-stop.sh || die
+ newinitd "${FILESDIR}"/lvm.rc-2.02.28-r2 lvm || die
+ newconfd "${FILESDIR}"/lvm.confd-2.02.28-r2 lvm || die
+ if use clvm; then
+ newinitd "${FILESDIR}"/clvmd.rc-2.02.39 clvmd || die
+ newconfd "${FILESDIR}"/clvmd.confd-2.02.39 clvmd || die
+ fi
+
+ # move shared libs to /lib(64)
+ if use static; then
+ dolib.a libdm/ioctl/libdevmapper.a || die "dolib.a libdevmapper.a"
+ fi
+ #gen_usr_ldscript libdevmapper.so
+
+ insinto /etc
+ doins "${FILESDIR}"/dmtab
+ insinto /$(get_libdir)/rcscripts/addons
+ doins "${FILESDIR}"/dm-start.sh
+
+ # Device mapper stuff
+ newinitd "${FILESDIR}"/device-mapper.rc-1.02.22-r3 device-mapper || die
+ newconfd "${FILESDIR}"/device-mapper.conf-1.02.22-r3 device-mapper || die
+
+ newinitd "${FILESDIR}"/1.02.22-dmeventd.initd dmeventd || die
+ if use static; then
+ dolib.a daemons/dmeventd/libdevmapper-event.a \
+ || die "dolib.a libdevmapper-event.a"
+ fi
+ #gen_usr_ldscript libdevmapper-event.so
+
+ insinto /etc/udev/rules.d/
+ newins "${FILESDIR}"/64-device-mapper.rules-1.02.22-r5 64-device-mapper.rules || die
+
+ elog "USE flag nocman is deprecated and replaced"
+ elog "with the cman USE flag."
+ elog ""
+ elog "USE flags clvm and cman are masked"
+ elog "by default and need to be unmasked to use them"
+ elog ""
+ elog "Rebuild your genkernel initramfs if you are using lvm"
+}
+
+pkg_postinst() {
+ elog "lvm volumes are no longer automatically created for"
+ elog "baselayout-2 users. If you are using baselayout-2, be sure to"
+ elog "run: # rc-update add lvm boot"
+ elog "Do NOT add it if you are using baselayout-1 still."
+}
+
+src_test() {
+ einfo "Testcases disabled because of device-node mucking"
+ einfo "If you want them, compile the package and see ${S}/tests"
+}