summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-30 08:26:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-30 08:26:18 +0000
commitabdf6f7bee038ca5d5c7c8b16349976665454147 (patch)
tree133415f9f76edc7bd5869203eb0edb49354a5af0 /sys-fs
parentRDEPEND on opengl stuff shouldn't be needed, but add it anyway until bug #410... (diff)
downloadgentoo-2-abdf6f7bee038ca5d5c7c8b16349976665454147.tar.gz
gentoo-2-abdf6f7bee038ca5d5c7c8b16349976665454147.tar.bz2
gentoo-2-abdf6f7bee038ca5d5c7c8b16349976665454147.zip
Missing dependency for dev-libs/libgcrypt wrt #410215 by Richard Scott
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog6
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild21
2 files changed, 17 insertions, 10 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 47bd13c69927..b11912f70b7c 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.129 2012/03/25 18:42:41 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.130 2012/03/30 08:26:18 ssuominen Exp $
+
+ 30 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
+ ntfs3g-2012.1.15-r1.ebuild:
+ Missing dependency for dev-libs/libgcrypt wrt #410215 by Richard Scott
25 Mar 2012; Brent Baude <ranger@gentoo.org> ntfs3g-2012.1.15-r1.ebuild:
Marking ntfs3g-2012.1.15-r1 ppc64 for bug 409273
diff --git a/sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild b/sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild
index eb6be1c10a8f..ded3ba3f1e0c 100644
--- a/sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild,v 1.8 2012/03/25 18:42:41 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild,v 1.9 2012/03/30 08:26:18 ssuominen Exp $
EAPI=4
inherit linux-info
@@ -15,11 +15,14 @@ SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ppc ppc64 ~sparc x86"
-IUSE="acl crypt debug extras +ntfsprogs suid static-libs xattr +udev +external-fuse"
+IUSE="acl crypt debug +external-fuse extras +ntfsprogs static-libs suid +udev xattr"
-RDEPEND="external-fuse? ( >=sys-fs/fuse-2.8.0 )
- crypt? ( net-libs/gnutls )
- !sys-fs/ntfsprogs"
+RDEPEND="!sys-fs/ntfsprogs
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.2
+ >=net-libs/gnutls-1.4.4
+ )
+ external-fuse? ( >=sys-fs/fuse-2.8.0 )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
sys-apps/attr"
@@ -43,16 +46,16 @@ src_configure() {
econf \
--exec-prefix=/usr \
--docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
--enable-ldscript \
--disable-ldconfig \
- --with-fuse=$(use external-fuse && echo external || echo internal) \
$(use_enable acl posix-acls) \
+ $(use_enable xattr xattr-mappings) \
$(use_enable crypt crypto) \
- $(use_enable extras) \
$(use_enable ntfsprogs) \
+ $(use_enable extras) \
$(use_enable static-libs static) \
- $(use_enable xattr xattr-mappings) \
- $(use_enable debug)
+ --with-fuse=$(use external-fuse && echo external || echo internal)
}
src_install() {