summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-08-10 17:29:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-08-10 17:29:28 +0000
commita115b3718e1cd1d929912a012f328b52bec38b61 (patch)
tree53d7cbc7c5716c118b5c77a6b6b7f347031ad060 /sys-fs
parentQuery correct udevdir from udev.pc pkg-config file. (diff)
downloadgentoo-2-a115b3718e1cd1d929912a012f328b52bec38b61.tar.gz
gentoo-2-a115b3718e1cd1d929912a012f328b52bec38b61.tar.bz2
gentoo-2-a115b3718e1cd1d929912a012f328b52bec38b61.zip
Query correct udevdir from udev.pc pkg-config file. Remove pointless USE="udev" since it has been a policy for a while to install minimalistic files.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog10
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2012.1.15-r2.ebuild80
2 files changed, 89 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index d4f280cb3420..ed47c6e0ab93 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.134 2012/05/04 19:09:18 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.135 2012/08/10 17:29:28 ssuominen Exp $
+
+*ntfs3g-2012.1.15-r2 (10 Aug 2012)
+
+ 10 Aug 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +ntfs3g-2012.1.15-r2.ebuild:
+ Query correct udevdir from udev.pc pkg-config file. Remove pointless
+ USE="udev" since it has been a policy for a while to install minimalistic
+ files.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> ntfs3g-2012.1.15-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/sys-fs/ntfs3g/ntfs3g-2012.1.15-r2.ebuild b/sys-fs/ntfs3g/ntfs3g-2012.1.15-r2.ebuild
new file mode 100644
index 000000000000..f8dbfdb3462d
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-2012.1.15-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2012.1.15-r2.ebuild,v 1.1 2012/08/10 17:29:28 ssuominen Exp $
+
+EAPI=4
+inherit linux-info toolchain-funcs
+
+MY_PN=${PN/3g/-3g}
+MY_P=${MY_PN}_ntfsprogs-${PV}
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
+SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl crypt debug +external-fuse extras +ntfsprogs static-libs suid xattr"
+
+RDEPEND="!<sys-apps/util-linux-2.19
+ !sys-fs/ntfsprogs
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.2
+ >=net-libs/gnutls-1.4.4
+ )
+ external-fuse? ( >=sys-fs/fuse-2.8.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-apps/attr"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS ChangeLog CREDITS README"
+
+pkg_setup() {
+ if use external-fuse && use kernel_linux; then
+ if kernel_is lt 2 6 9; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use ntfs-3g"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ --exec-prefix="${EPREFIX}/usr" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable debug) \
+ --enable-ldscript \
+ --disable-ldconfig \
+ $(use_enable acl posix-acls) \
+ $(use_enable xattr xattr-mappings) \
+ $(use_enable crypt crypto) \
+ $(use_enable ntfsprogs) \
+ $(use_enable extras) \
+ $(use_enable static-libs static) \
+ --with-fuse=$(use external-fuse && echo external || echo internal)
+}
+
+src_install() {
+ default
+
+ use suid && fperms u+s /usr/bin/${MY_PN}
+
+ local udevdir=/lib/udev
+ has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ insinto "${udevdir}"/rules.d
+ doins "${FILESDIR}"/99-ntfs3g.rules
+
+ prune_libtool_files
+
+ # http://bugs.gentoo.org/398069
+ dodir /usr/sbin
+ mv -vf "${D}"/sbin/* "${ED}"/usr/sbin || die
+ rm -rf "${D}"/sbin
+
+ dosym mount.ntfs-3g /usr/sbin/mount.ntfs #374197
+}