summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-31 05:21:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-31 05:21:16 +0000
commit9ca1709c76032039e58763f50ee3a4e4623bbcb1 (patch)
tree05cf97b47f31342219896eecae4cc920250c3490 /sys-fs
parentVersion bump wrt #518594 by Yevgeny Filatov (diff)
downloadgentoo-2-9ca1709c76032039e58763f50ee3a4e4623bbcb1.tar.gz
gentoo-2-9ca1709c76032039e58763f50ee3a4e4623bbcb1.tar.bz2
gentoo-2-9ca1709c76032039e58763f50ee3a4e4623bbcb1.zip
Version bump wrt #518594 by Yevgeny Filatov
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/reiser4progs/ChangeLog8
-rw-r--r--sys-fs/reiser4progs/reiser4progs-1.0.9.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/sys-fs/reiser4progs/ChangeLog b/sys-fs/reiser4progs/ChangeLog
index 9b0bfcce6f75..fb49d2c609c8 100644
--- a/sys-fs/reiser4progs/ChangeLog
+++ b/sys-fs/reiser4progs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/reiser4progs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/ChangeLog,v 1.44 2014/03/13 22:38:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/ChangeLog,v 1.45 2014/07/31 05:21:16 ssuominen Exp $
+
+*reiser4progs-1.0.9 (31 Jul 2014)
+
+ 31 Jul 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +reiser4progs-1.0.9.ebuild:
+ Version bump wrt #518594 by Yevgeny Filatov
*reiser4progs-1.0.8 (13 Mar 2014)
diff --git a/sys-fs/reiser4progs/reiser4progs-1.0.9.ebuild b/sys-fs/reiser4progs/reiser4progs-1.0.9.ebuild
new file mode 100644
index 000000000000..db6dd4f09884
--- /dev/null
+++ b/sys-fs/reiser4progs/reiser4progs-1.0.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/reiser4progs-1.0.9.ebuild,v 1.1 2014/07/31 05:21:16 ssuominen Exp $
+
+EAPI="4"
+
+inherit multilib eutils toolchain-funcs
+
+DESCRIPTION="reiser4progs: mkfs, fsck, etc..."
+HOMEPAGE="https://sourceforge.net/projects/reiser4/"
+SRC_URI="mirror://sourceforge/reiser4/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 -sparc ~x86"
+IUSE="debug readline static static-libs"
+
+LIB_DEPEND="~sys-libs/libaal-1.0.6[static-libs(+)]
+ readline? ( sys-libs/readline[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ static-libs? ( ~sys-libs/libaal-1.0.6[static-libs(+)] )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+ printf '#!/bin/sh\ntrue\n' > run-ldconfig
+ # Delete hardcoded link/compile flags.
+ sed -i -r \
+ -e '/CFLAGS=/s: -static":":' \
+ -e '/CFLAGS/s: (-O[123s]|-g)\>::g' \
+ configure || die
+ epatch "${FILESDIR}"/${PN}-1.0.7-readline-6.3.patch #504472
+}
+
+src_configure() {
+ econf \
+ $(use_enable static full-static) \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(use_with readline) \
+ --disable-Werror \
+ --enable-libminimal \
+ --sbindir=/sbin
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a reiser4{,-minimal} repair
+}