summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-09-04 02:17:02 +0000
committerTim Harder <radhermit@gentoo.org>2013-09-04 02:17:02 +0000
commit9b3bd55fb4b389a650d1ba3fbcace81984edf8a7 (patch)
treec050c343b27796e1ddfb4b026bb5293d5aca6100 /sys-fs
parentStable channel bump. (diff)
downloadgentoo-2-9b3bd55fb4b389a650d1ba3fbcace81984edf8a7.tar.gz
gentoo-2-9b3bd55fb4b389a650d1ba3fbcace81984edf8a7.tar.bz2
gentoo-2-9b3bd55fb4b389a650d1ba3fbcace81984edf8a7.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mdadm/ChangeLog7
-rw-r--r--sys-fs/mdadm/mdadm-3.3.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/sys-fs/mdadm/ChangeLog b/sys-fs/mdadm/ChangeLog
index e4c1f237f7fc..1ba9b8c8c97c 100644
--- a/sys-fs/mdadm/ChangeLog
+++ b/sys-fs/mdadm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/mdadm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/ChangeLog,v 1.162 2013/07/06 06:35:06 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/ChangeLog,v 1.163 2013/09/04 02:17:02 radhermit Exp $
+
+*mdadm-3.3 (04 Sep 2013)
+
+ 04 Sep 2013; Tim Harder <radhermit@gentoo.org> +mdadm-3.3.ebuild:
+ Version bump.
06 Jul 2013; Pacho Ramos <pacho@gentoo.org> +files/mdadm.service,
+files/mdadm.tmpfiles.conf, mdadm-3.2.6-r1.ebuild:
diff --git a/sys-fs/mdadm/mdadm-3.3.ebuild b/sys-fs/mdadm/mdadm-3.3.ebuild
new file mode 100644
index 000000000000..82be64776663
--- /dev/null
+++ b/sys-fs/mdadm/mdadm-3.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-3.3.ebuild,v 1.1 2013/09/04 02:17:02 radhermit Exp $
+
+EAPI="4"
+inherit multilib flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
+HOMEPAGE="http://neil.brown.name/blog/mdadm"
+SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="virtual/pkgconfig
+ app-arch/xz-utils"
+RDEPEND=">=sys-apps/util-linux-2.16"
+
+# The tests edit values in /proc and run tests on software raid devices.
+# Thus, they shouldn't be run on systems with active software RAID devices.
+RESTRICT="test"
+
+mdadm_emake() {
+ emake \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ CC="$(tc-getCC)" \
+ CWFLAGS="-Wall" \
+ CXFLAGS="${CFLAGS}" \
+ MAP_DIR=/run/mdadm \
+ "$@"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ mdadm_emake all mdassemble
+}
+
+src_test() {
+ mdadm_emake test
+
+ sh ./test || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ into /
+ dosbin mdassemble
+ dodoc ChangeLog INSTALL TODO README* ANNOUNCE-${PV}
+
+ insinto /etc
+ newins mdadm.conf-example mdadm.conf
+ newinitd "${FILESDIR}"/mdadm.rc mdadm
+ newconfd "${FILESDIR}"/mdadm.confd mdadm
+ newinitd "${FILESDIR}"/mdraid.rc mdraid
+ newconfd "${FILESDIR}"/mdraid.confd mdraid
+ systemd_dounit "${FILESDIR}"/mdadm.service
+ systemd_newtmpfilesd "${FILESDIR}"/mdadm.tmpfiles.conf mdadm.conf
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ # Only inform people the first time they install.
+ elog "If you're not relying on kernel auto-detect of your RAID"
+ elog "devices, you need to add 'mdraid' to your 'boot' runlevel:"
+ elog " rc-update add mdraid boot"
+ fi
+}