summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2004-12-02 19:46:38 +0000
committerStefan Schweizer <genstef@gentoo.org>2004-12-02 19:46:38 +0000
commit8de570094b98c802e9f0f61970766470ee0ba9ec (patch)
treecc98db4bf479eb1c2717ce35bd36567660261dd0 /sys-fs
parentAdding gnome-vfs-httpcaptive for captive, thanks to various people from bug 3... (diff)
downloadgentoo-2-8de570094b98c802e9f0f61970766470ee0ba9ec.tar.gz
gentoo-2-8de570094b98c802e9f0f61970766470ee0ba9ec.tar.bz2
gentoo-2-8de570094b98c802e9f0f61970766470ee0ba9ec.zip
Adding captive thanks to various people from bug 32929
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/captive/ChangeLog10
-rw-r--r--sys-fs/captive/Manifest4
-rw-r--r--sys-fs/captive/captive-1.1.5.ebuild106
-rw-r--r--sys-fs/captive/files/digest-captive-1.1.51
-rw-r--r--sys-fs/captive/metadata.xml9
5 files changed, 130 insertions, 0 deletions
diff --git a/sys-fs/captive/ChangeLog b/sys-fs/captive/ChangeLog
new file mode 100644
index 000000000000..80d89b42e0ea
--- /dev/null
+++ b/sys-fs/captive/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-fs/captive
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/ChangeLog,v 1.1 2004/12/02 19:46:38 genstef Exp $
+
+*captive-1.1.5 (02 Dec 2004)
+
+ 02 Dec 2004; Stefan Schweizer <genstef@gentoo.org> +metadata.xml,
+ +captive-1.1.5.ebuild:
+ Adding captive thanks to various people from bug 32929
+
diff --git a/sys-fs/captive/Manifest b/sys-fs/captive/Manifest
new file mode 100644
index 000000000000..9b1c18af397e
--- /dev/null
+++ b/sys-fs/captive/Manifest
@@ -0,0 +1,4 @@
+MD5 19407d6ae6b4dfc7f2dd3badfb27517e captive-1.1.5.ebuild 3034
+MD5 fb673ad1a05ac57517e7923e86dd5f76 ChangeLog 296
+MD5 6e89ba8198764bfd079a0cfa18dca593 metadata.xml 264
+MD5 8b3b77e73595843b6cf711b0355a8b07 files/digest-captive-1.1.5 66
diff --git a/sys-fs/captive/captive-1.1.5.ebuild b/sys-fs/captive/captive-1.1.5.ebuild
new file mode 100644
index 000000000000..6bd69c495e21
--- /dev/null
+++ b/sys-fs/captive/captive-1.1.5.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/captive-1.1.5.ebuild,v 1.1 2004/12/02 19:46:38 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="Captive uses binary Windows drivers for full NTFS r/w access."
+HOMEPAGE="http://www.jankratochvil.net/project/captive/"
+SRC_URI="http://www.jankratochvil.net/project/captive/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="debug gtk static"
+
+ # sys-fs/lufis-0.2(fuse) or sys-fs/lufs not needed for compiling,
+ # but for luf(i)s mounting, gnomevfs works w/o it though..
+RDEPEND="sys-libs/readline
+ >=gnome-base/orbit-2.8.2
+ gnome-base/gnome-vfs
+ dev-libs/popt
+ dev-libs/glib
+ >=dev-libs/openssl-0.9.7c
+ >=dev-libs/libxml2-2.4.29
+ sys-fs/lufis
+ gtk? (
+ gnome-extra/gnome-vfs-httpcaptive
+ gnome-base/libbonobo
+ gnome-base/libgnomeui
+ )"
+
+DEPEND="${RDEPEND}
+ sys-fs/ntfsprogs"
+
+pkg_setup() {
+ einfo "Adding captive user and group"
+ enewgroup captive || die "enewgroup captive failed"
+ enewuser captive -1 /bin/false /dev/null captive \
+ || die "enewuser captive failed"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # This is needed because that scripts will cause an sandbox violation
+ # if Xvnc is installed and its not needed anyways
+ # if it breaks, use the virtualx eclass and Xeconf
+ cd ${S}
+ epatch ${FILESDIR}/do-not-check-for-lufsd.patch
+ cp -f configure configure.orig
+ grep -v 'sh ./macros/glade-w' configure.orig > configure
+}
+
+src_compile() {
+ # disable some tests to save time ;)
+ econf `use_enable debug bug-replay` \
+ `use_enable static` \
+ `use_enable gtk install-pkg` \
+ --with-readline \
+ --enable-lufs \
+ --enable-sandbox-setuid=captive \
+ --enable-sandbox-setgid=captive \
+ --enable-sandbox-chroot=/var/lib/captive \
+ --enable-man-pages \
+ --enable-sbin-mountdir=/sbin \
+ --enable-sbin-mount-fs=ntfs:fastfat:cdfs:ext2fsd \
+ --disable-gtk-doc \
+ --with-orbit-line=link \
+ --disable-glibtest --disable-orbittest \
+ --with-tmpdir=/tmp --localstatedir=/var || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodir /var/lib/captive
+ diropts -m1777
+ dodir /var/lib/captive/tmp
+ keepdir /var/lib/captive/tmp
+
+ dodoc AUTHORS COPYING* ChangeLog* NEWS README* TODO \
+ || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if use gtk; then
+ einfo "Use /usr/sbin/captive-install-acquire to search for and"
+ einfo "install the needed drivers for captive NTFS."
+ einfo ""
+ einfo "Use /usr/sbin/captive-install-fstab to install captive"
+ einfo "entries into your /etc/fstab."
+ fi
+ einfo "Please emerge lufis and use it to mount captive, e.g.:"
+ einfo 'lufis "fs=captivefs,dir_cache_entries=0,image=/dev/hda1,captive_options=--rw;--load-module=/var/lib/captive/ntoskrnl.exe;--filesystem=/var/lib/captive/ntfs.sys;--sandbox-server=/usr/sbin/captive-sandbox-server;" /mnt/ntfs -s'
+}
+
+pkg_postrm() {
+ #einfo Removing captive user
+ #userdel captive
+ #einfo Removing captive group
+ #groupdel captive
+ einfo ""
+ einfo "You will have to remove captive user and group manually"
+ einfo ""
+}
diff --git a/sys-fs/captive/files/digest-captive-1.1.5 b/sys-fs/captive/files/digest-captive-1.1.5
new file mode 100644
index 000000000000..a61cef8f5473
--- /dev/null
+++ b/sys-fs/captive/files/digest-captive-1.1.5
@@ -0,0 +1 @@
+MD5 dfb7ce617745695e7a908609b9370fd6 captive-1.1.5.tar.gz 2547676
diff --git a/sys-fs/captive/metadata.xml b/sys-fs/captive/metadata.xml
new file mode 100644
index 000000000000..c8f81b37cf66
--- /dev/null
+++ b/sys-fs/captive/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kernel</herd>
+ <maintainer>
+ <email>genstef@gentoo.org</email>
+ <name>Stefan Schweizer</name>
+ </maintainer>
+</pkgmetadata>