summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-19 18:56:35 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-19 18:56:35 +0000
commit8838b13c708f4798735d77caca9d2577a5ff7445 (patch)
treec528207b81701155af096a397d13aa1dfbc8b7be /sys-fs
parentamd64/x86 stable wrt #422433 (diff)
downloadgentoo-2-8838b13c708f4798735d77caca9d2577a5ff7445.tar.gz
gentoo-2-8838b13c708f4798735d77caca9d2577a5ff7445.tar.bz2
gentoo-2-8838b13c708f4798735d77caca9d2577a5ff7445.zip
sys-fs/aufs3: Version BUmp
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs3/ChangeLog8
-rw-r--r--sys-fs/aufs3/aufs3-3_p20120619.ebuild148
-rw-r--r--sys-fs/aufs3/files/aufs3-base-x-rcN.patch35
-rw-r--r--sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch91
4 files changed, 246 insertions, 36 deletions
diff --git a/sys-fs/aufs3/ChangeLog b/sys-fs/aufs3/ChangeLog
index beeb938607e6..e3acc09d2524 100644
--- a/sys-fs/aufs3/ChangeLog
+++ b/sys-fs/aufs3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/aufs3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.18 2012/05/31 16:13:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.19 2012/06/19 18:56:35 jlec Exp $
+
+*aufs3-3_p20120619 (19 Jun 2012)
+
+ 19 Jun 2012; Justin Lecher <jlec@gentoo.org> files/aufs3-base-x-rcN.patch,
+ files/aufs3-standalone-x-rcN.patch, +aufs3-3_p20120619.ebuild:
+ Version BUmp
*aufs3-3_p20120531 (31 May 2012)
diff --git a/sys-fs/aufs3/aufs3-3_p20120619.ebuild b/sys-fs/aufs3/aufs3-3_p20120619.ebuild
new file mode 100644
index 000000000000..83d05f0b7336
--- /dev/null
+++ b/sys-fs/aufs3/aufs3-3_p20120619.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20120619.ebuild,v 1.1 2012/06/19 18:56:35 jlec Exp $
+
+EAPI=4
+
+inherit linux-mod multilib toolchain-funcs eutils
+
+AUFS_VERSION="${PV%%_p*}"
+# highest branch version
+PATCH_MAX_VER=4
+# highest supported version
+KERN_MAX_VER=5
+# highest util branch version
+UTIL_MAX_VER=0
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc fuse pax_kernel hfs inotify kernel-patch nfs ramfs"
+
+DEPEND="dev-vcs/git"
+RDEPEND="
+ !sys-fs/aufs
+ !sys-fs/aufs2"
+
+S="${WORKDIR}"/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ CONFIG_CHECK="${CONFIG_CHECK} ~EXPERIMENTAL"
+ use inotify && CONFIG_CHECK="${CONFIG_CHECK} ~FSNOTIFY"
+ use nfs && CONFIG_CHECK="${CONFIG_CHECK} EXPORTFS"
+ use fuse && CONFIG_CHECK="${CONFIG_CHECK} ~FUSE_FS"
+ use hfs && CONFIG_CHECK="${CONFIG_CHECK} ~HFSPLUS_FS"
+
+ # this is needed so merging a binpkg ${PN} is possible w/out a kernel unpacked on the system
+ [ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return
+
+ get_version
+ kernel_is lt 3 0 0 && die "kernel too old, Please use sys-fs/aufs2"
+ kernel_is gt 3 ${KERN_MAX_VER} 99 && die "kernel too new"
+
+ linux-mod_pkg_setup
+
+ if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then
+ PATCH_BRANCH="x-rcN"
+ else
+ PATCH_BRANCH="${KV_MINOR}"
+ fi
+
+ if [[ "${PATCH_BRANCH}" == "x-rcN" ]]; then
+ UTIL_BRANCH="x-rcN"
+ elif [[ "${KV_MINOR}" -gt "${UTIL_MAX_VER}" ]]; then
+ UTIL_BRANCH="${UTIL_MAX_VER}"
+ else
+ UTIL_BRANCH="${KV_MINOR}"
+ fi
+
+ if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-standalone-${PATCH_BRANCH}.patch >/dev/null && \
+ patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-base-${PATCH_BRANCH}.patch >/dev/null ); then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-standalone-${PATCH_BRANCH}.patch >/dev/null
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-base-${PATCH_BRANCH}.patch >/dev/null
+ epatch "${FILESDIR}"/${PN}-{base,standalone}-${PATCH_BRANCH}.patch
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the ${PN} module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply ${FILESDIR}/${PN}-base-${PATCH_BRANCH}.patch and"
+ eerror "${FILESDIR}/${PN}-standalone-${PATCH_BRANCH}.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+ export PKG_SETUP_HAS_BEEN_RAN=1
+}
+
+set_config() {
+ for option in $*; do
+ grep -q "^CONFIG_AUFS_${option} =" config.mk || die "${option} is not a valid config option"
+ sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
+ done
+}
+
+src_prepare() {
+ local module_branch=origin/${PN}.${PATCH_BRANCH}
+ local util_branch=origin/${PN}.${UTIL_BRANCH}
+
+ einfo "Using for module creation branch ${module_branch}"
+ git checkout -q -b local-gentoo ${module_branch} || die
+
+ # All config options to off
+ sed "s:= y:=:g" -i config.mk || die
+
+ set_config RDU BRANCH_MAX_127 SBILIST
+
+ use debug && set_config DEBUG
+ use fuse && set_config BR_FUSE POLL
+ use hfs && set_config BR_HFSPLUS
+ use inotify && set_config HNOTIFY HFSNOTIFY
+ use nfs && set_config EXPORT
+ use nfs && use amd64 && set_config INO_T_64
+ use ramfs && set_config BR_RAMFS
+
+ use pax_kernel && epatch "${FILESDIR}"/pax.patch
+
+ sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
+ sed -i "s:__user::g" include/linux/aufs_type.h || die
+
+ cd "${WORKDIR}"/${PN/3}-util
+
+ einfo "Using for utils building branch ${util_branch}"
+ git checkout -b local-gentoo ${util_branch} || die
+ sed -i "/LDFLAGS += -static -s/d" Makefile || die
+ sed -i -e "s:m 644 -s:m 644:g" -e "s:/usr/lib:/usr/$(get_libdir):g" libau/Makefile || die
+}
+
+src_compile() {
+ local ARCH=x86
+
+ emake CC=$(tc-getCC) CONFIG_AUFS_FS=m KDIR=${KV_DIR}
+
+ cd "${WORKDIR}"/${PN/3}-util
+ emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_DIR} C_INCLUDE_PATH="${S}"/include
+}
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /usr/share/doc/${PF}
+
+ use doc && doins -r Documentation
+
+ dodoc Documentation/filesystems/aufs/README
+
+ cd "${WORKDIR}"/${PN/3}-util
+ emake DESTDIR="${D}" KDIR=${KV_DIR} install
+
+ newdoc README README-utils
+}
diff --git a/sys-fs/aufs3/files/aufs3-base-x-rcN.patch b/sys-fs/aufs3/files/aufs3-base-x-rcN.patch
index e7c07fd2b864..e360b173aeeb 100644
--- a/sys-fs/aufs3/files/aufs3-base-x-rcN.patch
+++ b/sys-fs/aufs3/files/aufs3-base-x-rcN.patch
@@ -1,10 +1,23 @@
aufs3.x-rcN base patch
+diff --git a/fs/inode.c b/fs/inode.c
+index c99163b..7f772fd 100644
+--- a/fs/inode.c
++++ b/fs/inode.c
+@@ -1491,7 +1491,7 @@ static int relatime_need_update(struct vfsmount *mnt, struct inode *inode,
+ * This does the actual work of updating an inodes time or version. Must have
+ * had called mnt_want_write() before calling this.
+ */
+-static int update_time(struct inode *inode, struct timespec *time, int flags)
++int update_time(struct inode *inode, struct timespec *time, int flags)
+ {
+ if (inode->i_op->update_time)
+ return inode->i_op->update_time(inode, time, flags);
diff --git a/fs/namei.c b/fs/namei.c
-index 0062dd1..80bb0b9 100644
+index 7d69419..18c9782 100644
--- a/fs/namei.c
+++ b/fs/namei.c
-@@ -1831,7 +1831,7 @@ int vfs_path_lookup(struct dentry *dentry, struct vfsmount *mnt,
+@@ -1864,7 +1864,7 @@ int vfs_path_lookup(struct dentry *dentry, struct vfsmount *mnt,
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/
@@ -14,10 +27,10 @@ index 0062dd1..80bb0b9 100644
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
diff --git a/fs/splice.c b/fs/splice.c
-index f847684..f871233 100644
+index c9f1318..490239f 100644
--- a/fs/splice.c
+++ b/fs/splice.c
-@@ -1084,8 +1084,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
+@@ -1086,8 +1086,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
/*
* Attempt to initiate a splice from pipe to file.
*/
@@ -28,7 +41,7 @@ index f847684..f871233 100644
{
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
loff_t *, size_t, unsigned int);
-@@ -1112,9 +1112,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+@@ -1114,9 +1114,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
/*
* Attempt to initiate a splice from a file to a pipe.
*/
@@ -41,6 +54,18 @@ index f847684..f871233 100644
{
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
+diff --git a/include/linux/fs.h b/include/linux/fs.h
+index 17fd887..9c75a47 100644
+--- a/include/linux/fs.h
++++ b/include/linux/fs.h
+@@ -2591,6 +2591,7 @@ extern int inode_change_ok(const struct inode *, struct iattr *);
+ extern int inode_newsize_ok(const struct inode *, loff_t offset);
+ extern void setattr_copy(struct inode *inode, const struct iattr *attr);
+
++extern int update_time(struct inode *, struct timespec *, int);
+ extern int file_update_time(struct file *file);
+
+ extern int generic_show_options(struct seq_file *m, struct dentry *root);
diff --git a/include/linux/namei.h b/include/linux/namei.h
index ffc0213..ef35a31 100644
--- a/include/linux/namei.h
diff --git a/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch b/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch
index 70ff1593bf37..0c59e88ed797 100644
--- a/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch
+++ b/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch
@@ -1,10 +1,18 @@
aufs3.x-rcN standalone patch
diff --git a/fs/file_table.c b/fs/file_table.c
-index 70f2a0f..146a3d7 100644
+index a305d9e..6a768be 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
-@@ -442,6 +442,8 @@ void file_sb_list_del(struct file *file)
+@@ -35,6 +35,7 @@ struct files_stat_struct files_stat = {
+ };
+
+ DEFINE_LGLOCK(files_lglock);
++EXPORT_SYMBOL(files_lglock);
+
+ /* SLAB cache for file structures */
+ static struct kmem_cache *filp_cachep __read_mostly;
+@@ -441,6 +442,8 @@ void file_sb_list_del(struct file *file)
}
}
@@ -14,7 +22,7 @@ index 70f2a0f..146a3d7 100644
/*
diff --git a/fs/inode.c b/fs/inode.c
-index 9f4f5fe..bb0f3ba 100644
+index 7f772fd..e789d2f 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -56,6 +56,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
@@ -25,11 +33,19 @@ index 9f4f5fe..bb0f3ba 100644
/*
* Empty aops. Can be used for the cases where the user does not
+@@ -1507,6 +1508,7 @@ int update_time(struct inode *inode, struct timespec *time, int flags)
+ mark_inode_dirty_sync(inode);
+ return 0;
+ }
++EXPORT_SYMBOL(update_time);
+
+ /**
+ * touch_atime - update the access time
diff --git a/fs/namei.c b/fs/namei.c
-index 80bb0b9..3430ad3 100644
+index 18c9782..f09edf3 100644
--- a/fs/namei.c
+++ b/fs/namei.c
-@@ -1835,6 +1835,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
+@@ -1868,6 +1868,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
@@ -38,10 +54,18 @@ index 80bb0b9..3430ad3 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
-index e608199..38fcc2e 100644
+index 1e4a5fe..06aa768 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
-@@ -1339,6 +1339,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
+@@ -50,6 +50,7 @@ EXPORT_SYMBOL_GPL(fs_kobj);
+ * tree or hash is modified or when a vfsmount structure is modified.
+ */
+ DEFINE_BRLOCK(vfsmount_lock);
++EXPORT_SYMBOL(vfsmount_lock);
+
+ static inline unsigned long hash(struct vfsmount *mnt, struct dentry *dentry)
+ {
+@@ -1341,6 +1342,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@@ -111,7 +135,7 @@ index f104d56..54f36db 100644
static int fsnotify_mark_destroy(void *ignored)
{
diff --git a/fs/open.c b/fs/open.c
-index 5720854..ec59242 100644
+index d6c79a0..9004a15 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -60,6 +60,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@@ -123,10 +147,10 @@ index 5720854..ec59242 100644
static long do_sys_truncate(const char __user *pathname, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
-index f871233..70f5481 100644
+index 490239f..701d34a 100644
--- a/fs/splice.c
+++ b/fs/splice.c
-@@ -1108,6 +1108,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+@@ -1110,6 +1110,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@@ -134,7 +158,7 @@ index f871233..70f5481 100644
/*
* Attempt to initiate a splice from a file to a pipe.
-@@ -1134,6 +1135,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
+@@ -1136,6 +1137,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}
@@ -143,16 +167,23 @@ index f871233..70f5481 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/security/commoncap.c b/security/commoncap.c
-index 71a166a..5d63aac 100644
+index 6dbae46..9f4f29a 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
-@@ -972,3 +972,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
+@@ -979,9 +979,11 @@ int cap_mmap_addr(unsigned long addr)
}
return ret;
}
-+EXPORT_SYMBOL(cap_file_mmap);
++EXPORT_SYMBOL(cap_mmap_addr);
+
+ int cap_mmap_file(struct file *file, unsigned long reqprot,
+ unsigned long prot, unsigned long flags)
+ {
+ return 0;
+ }
++EXPORT_SYMBOL(cap_mmap_file);
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
-index c43a332..0c37289 100644
+index 442204c..e644a1c 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -7,6 +7,7 @@
@@ -163,7 +194,7 @@ index c43a332..0c37289 100644
#include <linux/list.h>
#include <linux/uaccess.h>
#include <linux/seq_file.h>
-@@ -499,6 +500,7 @@ found:
+@@ -493,6 +494,7 @@ found:
return -EPERM;
}
@@ -172,10 +203,10 @@ index c43a332..0c37289 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
-index bf619ff..60b996a 100644
+index 3efc9b1..c7afd35 100644
--- a/security/security.c
+++ b/security/security.c
-@@ -380,6 +380,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
+@@ -383,6 +383,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
return 0;
return security_ops->path_rmdir(dir, dentry);
}
@@ -183,7 +214,7 @@ index bf619ff..60b996a 100644
int security_path_unlink(struct path *dir, struct dentry *dentry)
{
-@@ -396,6 +397,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
+@@ -399,6 +400,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
return 0;
return security_ops->path_symlink(dir, dentry, old_name);
}
@@ -191,7 +222,7 @@ index bf619ff..60b996a 100644
int security_path_link(struct dentry *old_dentry, struct path *new_dir,
struct dentry *new_dentry)
-@@ -404,6 +406,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+@@ -407,6 +409,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
return 0;
return security_ops->path_link(old_dentry, new_dir, new_dentry);
}
@@ -199,7 +230,7 @@ index bf619ff..60b996a 100644
int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
struct path *new_dir, struct dentry *new_dentry)
-@@ -422,6 +425,7 @@ int security_path_truncate(struct path *path)
+@@ -425,6 +428,7 @@ int security_path_truncate(struct path *path)
return 0;
return security_ops->path_truncate(path);
}
@@ -207,7 +238,7 @@ index bf619ff..60b996a 100644
int security_path_chmod(struct path *path, umode_t mode)
{
-@@ -429,6 +433,7 @@ int security_path_chmod(struct path *path, umode_t mode)
+@@ -432,6 +436,7 @@ int security_path_chmod(struct path *path, umode_t mode)
return 0;
return security_ops->path_chmod(path, mode);
}
@@ -215,7 +246,7 @@ index bf619ff..60b996a 100644
int security_path_chown(struct path *path, uid_t uid, gid_t gid)
{
-@@ -436,6 +441,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
+@@ -439,6 +444,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
return 0;
return security_ops->path_chown(path, uid, gid);
}
@@ -223,7 +254,7 @@ index bf619ff..60b996a 100644
int security_path_chroot(struct path *path)
{
-@@ -512,6 +518,7 @@ int security_inode_readlink(struct dentry *dentry)
+@@ -515,6 +521,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return security_ops->inode_readlink(dentry);
}
@@ -231,7 +262,7 @@ index bf619ff..60b996a 100644
int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
{
-@@ -526,6 +533,7 @@ int security_inode_permission(struct inode *inode, int mask)
+@@ -529,6 +536,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return security_ops->inode_permission(inode, mask);
}
@@ -239,7 +270,7 @@ index bf619ff..60b996a 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
-@@ -641,6 +649,7 @@ int security_file_permission(struct file *file, int mask)
+@@ -644,6 +652,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@@ -247,11 +278,11 @@ index bf619ff..60b996a 100644
int security_file_alloc(struct file *file)
{
-@@ -668,6 +677,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
+@@ -704,6 +713,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
return ret;
return ima_file_mmap(file, prot);
}
-+EXPORT_SYMBOL(security_file_mmap);
++EXPORT_SYMBOL(security_mmap_file);
- int security_file_mprotect(struct vm_area_struct *vma, unsigned long reqprot,
- unsigned long prot)
+ int security_mmap_addr(unsigned long addr)
+ {