summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-09-05 08:34:59 +0000
committerTim Harder <radhermit@gentoo.org>2013-09-05 08:34:59 +0000
commit8416143d5a54cc0d7ae87dd1d08390cbaa845f4e (patch)
treeaec4089280cc72ad1ebbd192c1bcf3befee02263 /sys-fs
parentVersion bump. (diff)
downloadgentoo-2-8416143d5a54cc0d7ae87dd1d08390cbaa845f4e.tar.gz
gentoo-2-8416143d5a54cc0d7ae87dd1d08390cbaa845f4e.tar.bz2
gentoo-2-8416143d5a54cc0d7ae87dd1d08390cbaa845f4e.zip
Version bump, install binaries into /usr/bin instead of /usr/sbin (bug #482234).
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dmg2img/ChangeLog10
-rw-r--r--sys-fs/dmg2img/dmg2img-1.6.5.ebuild36
2 files changed, 44 insertions, 2 deletions
diff --git a/sys-fs/dmg2img/ChangeLog b/sys-fs/dmg2img/ChangeLog
index 162eef96b27b..da4a64be4e41 100644
--- a/sys-fs/dmg2img/ChangeLog
+++ b/sys-fs/dmg2img/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/dmg2img
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmg2img/ChangeLog,v 1.7 2012/08/28 06:31:45 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmg2img/ChangeLog,v 1.8 2013/09/05 08:34:59 radhermit Exp $
+
+*dmg2img-1.6.5 (05 Sep 2013)
+
+ 05 Sep 2013; Tim Harder <radhermit@gentoo.org> +dmg2img-1.6.5.ebuild:
+ Version bump, install binaries into /usr/bin instead of /usr/sbin (bug
+ #482234).
*dmg2img-1.6.4 (28 Aug 2012)
diff --git a/sys-fs/dmg2img/dmg2img-1.6.5.ebuild b/sys-fs/dmg2img/dmg2img-1.6.5.ebuild
new file mode 100644
index 000000000000..f88f337fe545
--- /dev/null
+++ b/sys-fs/dmg2img/dmg2img-1.6.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmg2img/dmg2img-1.6.5.ebuild,v 1.1 2013/09/05 08:34:59 radhermit Exp $
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Converts Apple DMG files to standard HFS+ images"
+HOMEPAGE="http://vu1tur.eu.org/tools"
+SRC_URI="http://vu1tur.eu.org/tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+src_prepare() {
+ sed -i -e 's:-s:$(LDFLAGS):g' Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin dmg2img vfdecrypt
+ dodoc README
+ doman vfdecrypt.1
+}