summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-10-26 12:15:36 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-10-26 12:15:36 +0000
commit80816f2e28608cc5a716e9799272c3cd68250894 (patch)
treef3c9746b297ce8eb0f1178e3a769836e864dc951 /sys-fs
parentVersion bump with ruby19 fixes, even though we cannot enable ruby19 due to th... (diff)
downloadgentoo-2-80816f2e28608cc5a716e9799272c3cd68250894.tar.gz
gentoo-2-80816f2e28608cc5a716e9799272c3cd68250894.tar.bz2
gentoo-2-80816f2e28608cc5a716e9799272c3cd68250894.zip
EAPI4, respect AR, add ~amd64
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/archfs/ChangeLog6
-rw-r--r--sys-fs/archfs/archfs-0.5.6b.ebuild15
2 files changed, 12 insertions, 9 deletions
diff --git a/sys-fs/archfs/ChangeLog b/sys-fs/archfs/ChangeLog
index 79874cb7704c..0483f508b55a 100644
--- a/sys-fs/archfs/ChangeLog
+++ b/sys-fs/archfs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/archfs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/archfs/ChangeLog,v 1.5 2012/03/20 10:08:15 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/archfs/ChangeLog,v 1.6 2012/10/26 12:15:36 ago Exp $
+
+ 26 Oct 2012; Agostino Sarubbo <ago@gentoo.org> archfs-0.5.6b.ebuild:
+ EAPI4, respect AR, add ~amd64
20 Mar 2012; Pacho Ramos <pacho@gentoo.org> archfs-0.5.6b.ebuild:
Update homepage, bug #354089 by Jeroen Roovers.
@@ -22,4 +25,3 @@
19 Aug 2007; Markus Ullmann <jokey@gentoo.org> +metadata.xml,
+archfs-0.5.1.ebuild:
Initial import
-
diff --git a/sys-fs/archfs/archfs-0.5.6b.ebuild b/sys-fs/archfs/archfs-0.5.6b.ebuild
index e83ef31950ef..fdd4526fa90c 100644
--- a/sys-fs/archfs/archfs-0.5.6b.ebuild
+++ b/sys-fs/archfs/archfs-0.5.6b.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/archfs/archfs-0.5.6b.ebuild,v 1.2 2012/03/20 10:08:15 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/archfs/archfs-0.5.6b.ebuild,v 1.3 2012/10/26 12:15:36 ago Exp $
-EAPI="2"
+EAPI=4
-inherit autotools
+inherit autotools toolchain-funcs
DESCRIPTION="Filesystem for rdiff-backup'ed folders"
HOMEPAGE="http://code.google.com/p/rdiff-backup-fs/"
@@ -12,7 +12,7 @@ SRC_URI="http://archfs.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="sys-fs/fuse"
@@ -21,6 +21,8 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${P/b}"
+DOCS=( AUTHORS ChangeLog NEWS )
+
src_prepare() {
sed -i configure.ac \
-e 's|-Wall -O3|-Wall|g' \
@@ -31,7 +33,6 @@ src_prepare() {
eautoreconf
}
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS
+src_compile() {
+ emake AR="$(tc-getAR)"
}