summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-10-19 20:05:18 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-10-19 20:05:18 +0000
commit7fe47d4b30576de7ba57244def79320dc44afc7d (patch)
tree3ad9ffd6ce52a242f6fe1e3874be1919f6de3724 /sys-fs
parentAdd nautilus-python-1.1 with pygobject:3 compatibility. Fix pygobject depende... (diff)
downloadgentoo-2-7fe47d4b30576de7ba57244def79320dc44afc7d.tar.gz
gentoo-2-7fe47d4b30576de7ba57244def79320dc44afc7d.tar.bz2
gentoo-2-7fe47d4b30576de7ba57244def79320dc44afc7d.zip
Fix building with new gcc and libzip. Bug #364747. Thanks to Billy Holmes <billy@gonoph.net>
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse-zip/ChangeLog9
-rw-r--r--sys-fs/fuse-zip/files/libzip-fix-0.10.patch24
-rw-r--r--sys-fs/fuse-zip/fuse-zip-0.2.13.ebuild8
3 files changed, 36 insertions, 5 deletions
diff --git a/sys-fs/fuse-zip/ChangeLog b/sys-fs/fuse-zip/ChangeLog
index fb0f5bfa15c2..63126d7b017c 100644
--- a/sys-fs/fuse-zip/ChangeLog
+++ b/sys-fs/fuse-zip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse-zip
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-zip/ChangeLog,v 1.4 2010/12/07 18:39:30 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-zip/ChangeLog,v 1.5 2011/10/19 20:05:18 hwoarang Exp $
+
+ 19 Oct 2011; Markos Chandras <hwoarang@gentoo.org> fuse-zip-0.2.13.ebuild,
+ +files/libzip-fix-0.10.patch:
+ Fix building with new gcc and libzip. Bug #364747. Thanks to Billy Holmes
+ <billy@gonoph.net>
07 Dec 2010; Markos Chandras <hwoarang@gentoo.org> fuse-zip-0.2.13.ebuild:
Fix parallel build warnings. Thanks to Diego Elio Pettenò
diff --git a/sys-fs/fuse-zip/files/libzip-fix-0.10.patch b/sys-fs/fuse-zip/files/libzip-fix-0.10.patch
new file mode 100644
index 000000000000..f2348e5f1bab
--- /dev/null
+++ b/sys-fs/fuse-zip/files/libzip-fix-0.10.patch
@@ -0,0 +1,24 @@
+diff -ru fuse-zip-0.2.13/lib/bigBuffer.cpp fuse-zip-0.2.13.new//lib/bigBuffer.cpp
+--- fuse-zip-0.2.13/lib/bigBuffer.cpp 2010-12-06 12:34:32.000000000 -0500
++++ fuse-zip-0.2.13.new//lib/bigBuffer.cpp 2011-09-28 21:40:01.294946957 -0400
+@@ -236,7 +236,7 @@
+ len = offset;
+ }
+
+-ssize_t BigBuffer::zipUserFunctionCallback(void *state, void *data, size_t len, enum zip_source_cmd cmd) {
++zip_int64_t BigBuffer::zipUserFunctionCallback(void *state, void *data, zip_uint64_t len, enum zip_source_cmd cmd) {
+ CallBackStruct *b = (CallBackStruct*)state;
+ switch (cmd) {
+ case ZIP_SOURCE_OPEN: {
+diff -ru fuse-zip-0.2.13/lib/bigBuffer.h fuse-zip-0.2.13.new//lib/bigBuffer.h
+--- fuse-zip-0.2.13/lib/bigBuffer.h 2010-12-06 12:34:32.000000000 -0500
++++ fuse-zip-0.2.13.new//lib/bigBuffer.h 2011-09-28 21:40:23.203719133 -0400
+@@ -52,7 +52,7 @@
+ * never called because read() always successfull.
+ * See zip_source_function(3) for details.
+ */
+- static ssize_t zipUserFunctionCallback(void *state, void *data, size_t len, enum zip_source_cmd cmd);
++ static zip_int64_t zipUserFunctionCallback(void *state, void *data, zip_uint64_t len, enum zip_source_cmd cmd);
+
+ /**
+ * Return number of chunks needed to keep 'offset' bytes.
diff --git a/sys-fs/fuse-zip/fuse-zip-0.2.13.ebuild b/sys-fs/fuse-zip/fuse-zip-0.2.13.ebuild
index 1c272802ccc1..07ad3501b8a6 100644
--- a/sys-fs/fuse-zip/fuse-zip-0.2.13.ebuild
+++ b/sys-fs/fuse-zip/fuse-zip-0.2.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-zip/fuse-zip-0.2.13.ebuild,v 1.2 2010/12/07 18:39:30 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-zip/fuse-zip-0.2.13.ebuild,v 1.3 2011/10/19 20:05:18 hwoarang Exp $
EAPI=2
@@ -24,8 +24,10 @@ RESTRICT="test"
src_prepare() {
# Fix strip than installing fuse-zip
sed -i -e 's/install -m 755 -s/install -m 755/' Makefile || die "sed failed"
- # ix broken makefile
+ # fix broken makefile
epatch "${FILESDIR}"/"${P}"-as-needed.patch
+ # fix building with libzip-0.10
+ epatch "${FILESDIR}"/libzip-fix-0.10.patch
#enable parallel build
sed -i -e "s:make :\$\(MAKE\) :" Makefile || die "sed failed"
}