summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-09 21:01:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-09 21:01:49 +0000
commit79540d3ecc4569729f31ab9eb7af9740f5be2b8f (patch)
tree2ee9e3991c6e020f1a819a2f45066f4a05b184b4 /sys-fs
parentVersion bump. (diff)
downloadgentoo-2-79540d3ecc4569729f31ab9eb7af9740f5be2b8f.tar.gz
gentoo-2-79540d3ecc4569729f31ab9eb7af9740f5be2b8f.tar.bz2
gentoo-2-79540d3ecc4569729f31ab9eb7af9740f5be2b8f.zip
Initial commit of lessfs application. Fixes bug #312997
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lessfs/ChangeLog11
-rw-r--r--sys-fs/lessfs/lessfs-1.0.8.ebuild43
-rw-r--r--sys-fs/lessfs/metadata.xml13
3 files changed, 67 insertions, 0 deletions
diff --git a/sys-fs/lessfs/ChangeLog b/sys-fs/lessfs/ChangeLog
new file mode 100644
index 000000000000..ea793bc7cc39
--- /dev/null
+++ b/sys-fs/lessfs/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-fs/lessfs
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lessfs/ChangeLog,v 1.1 2010/06/09 21:01:49 hwoarang Exp $
+
+*lessfs-1.0.8 (09 Jun 2010)
+
+ 09 Jun 2010; Markos Chandras <hwoarang@gentoo.org> +lessfs-1.0.8.ebuild,
+ +metadata.xml:
+ Initial commit of lessfs application. Fixes bug #312997. Thanks to devsk
+ <funtoos@yahoo.com> for the initial ebuild
+
diff --git a/sys-fs/lessfs/lessfs-1.0.8.ebuild b/sys-fs/lessfs/lessfs-1.0.8.ebuild
new file mode 100644
index 000000000000..7f898417a255
--- /dev/null
+++ b/sys-fs/lessfs/lessfs-1.0.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lessfs/lessfs-1.0.8.ebuild,v 1.1 2010/06/09 21:01:49 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A high performance inline data deduplicating filesystem"
+HOMEPAGE="http://www.lessfs.com"
+SRC_URI="http://downloads.sourceforge.net/project/${PN}/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lzo crypt"
+
+DEPEND=">=dev-db/tokyocabinet-1.4.42
+ >=sys-fs/fuse-2.8.0
+ crypt? ( dev-libs/openssl )
+ lzo? ( dev-libs/lzo )"
+
+RDEPEND=""
+
+src_configure() {
+ use crypt && myconf="--with-crypto"
+ use lzo && myconf="${myconf} --with-lzo"
+ econf ${myconf}
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog NEWS README || die "dodpc failed"
+ insinto /etc
+ doins etc/lessfs.cfg
+
+}
+
+pkg_postinst() {
+ elog
+ elog "Default configuration file: /etc/${PN}.cfg"
+ elog
+}
diff --git a/sys-fs/lessfs/metadata.xml b/sys-fs/lessfs/metadata.xml
new file mode 100644
index 000000000000..dbc8e3e3c96f
--- /dev/null
+++ b/sys-fs/lessfs/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+Data deduplication (often called “intelligent compression” or “single-instance storage”) is a method of reducing storage needs by eliminating redundant data. Data deduplication is often used for backup purposes and for virtual machine image storage. lessfs can determine if data is redundant by calculating an unique (192 bit) tiger hash of each block of data that is written. When lessfs has determined that a block of data needs to be stored it first compresses the block with LZO or QUICKLZ compression. The combination of these two techniques results in a very high overall compression rate for many types of data. Multimedia files like mp3, avi or jpg files can not be compressed by lessfs when they are only stored once on the filesystem.
+</longdescription>
+</pkgmetadata>
+