summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-05-28 22:11:20 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-05-28 22:11:20 +0000
commit739d481390b98bee6901e77adfeb2d66e3cacf91 (patch)
treef846fcf9120af02c1ca872acd5193b5cc5762afe /sys-fs
parentVersion bump, bug #395199 (diff)
downloadgentoo-2-739d481390b98bee6901e77adfeb2d66e3cacf91.tar.gz
gentoo-2-739d481390b98bee6901e77adfeb2d66e3cacf91.tar.bz2
gentoo-2-739d481390b98bee6901e77adfeb2d66e3cacf91.zip
Bumped for a live ebuild for compatibility on kernel > 2.6.38. Setting myself as maintainer.
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/redirfs/ChangeLog12
-rw-r--r--sys-fs/redirfs/files/redirfs-0.2-truncate_inode_pages.patch22
-rw-r--r--sys-fs/redirfs/metadata.xml22
-rw-r--r--sys-fs/redirfs/redirfs-0.2-r1.ebuild42
-rw-r--r--sys-fs/redirfs/redirfs-0.6.ebuild33
-rw-r--r--sys-fs/redirfs/redirfs-0.8.ebuild6
-rw-r--r--sys-fs/redirfs/redirfs-9999.ebuild41
7 files changed, 72 insertions, 106 deletions
diff --git a/sys-fs/redirfs/ChangeLog b/sys-fs/redirfs/ChangeLog
index ca2ab2eef58d..d94f8695ef8b 100644
--- a/sys-fs/redirfs/ChangeLog
+++ b/sys-fs/redirfs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/redirfs
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/redirfs/ChangeLog,v 1.6 2010/01/19 11:26:21 cla Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/redirfs/ChangeLog,v 1.7 2012/05/28 22:11:20 bicatali Exp $
+
+*redirfs-9999 (28 May 2012)
+
+ 28 May 2012; Sébastien Fabbro <bicatali@gentoo.org> -redirfs-0.2-r1.ebuild,
+ -files/redirfs-0.2-truncate_inode_pages.patch, -redirfs-0.6.ebuild,
+ redirfs-0.8.ebuild, +redirfs-9999.ebuild, metadata.xml:
+ Bumped for a live ebuild for compatibility on kernel > 2.6.38. Setting myself
+ as maintainer.
*redirfs-0.8 (19 Jan 2010)
diff --git a/sys-fs/redirfs/files/redirfs-0.2-truncate_inode_pages.patch b/sys-fs/redirfs/files/redirfs-0.2-truncate_inode_pages.patch
deleted file mode 100644
index 47cae51596af..000000000000
--- a/sys-fs/redirfs/files/redirfs-0.2-truncate_inode_pages.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: redir.c
-===================================================================
---- redir.c (revision 366)
-+++ redir.c (working copy)
-@@ -103,6 +103,9 @@
-
- static inline void rfs_truncate_inode_pages(struct inode *inode)
- {
-+ return;
-+
-+ /*
- if (!inode)
- return;
-
-@@ -111,6 +114,7 @@
- truncate_inode_pages(&inode->i_data, 0);
- mutex_unlock(&inode->i_mutex);
- }
-+ */
- }
-
- int rfs_replace_ops(struct rpath *path_old, struct rpath *path_new, struct filter *flt)
diff --git a/sys-fs/redirfs/metadata.xml b/sys-fs/redirfs/metadata.xml
index 59e2b8f78cb5..32e583418aee 100644
--- a/sys-fs/redirfs/metadata.xml
+++ b/sys-fs/redirfs/metadata.xml
@@ -1,8 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>maintainer-needed@gentoo.org</email>
- <name>Default assignee for orphaned packages</name>
- </maintainer>
+<maintainer>
+ <email>bicatali@gentoo.org</email>
+</maintainer>
+<longdescription lang='en'>
+ The RedirFS or redirecting file system is a layer between
+ virtual file system switch (VFS) and file system drivers. It is
+ implemented as an out-of-kernel module for Linux and it provides
+ framework allowing modification of file system calls in the VFS
+ layer. The RedirFS by itself does not provide any additional
+ functionality and if it is loaded into the Linux kernel, it just
+ occupies some memory space and it does practically nothing. The
+ RedirFS is intended to be used by so-called filters. Filter is a
+ linux kernel module (LKM) that uses the RedirFS framework. Each
+ filter can add some useful functionality to the existing file
+ systems like transparent compression, transparent encryption,
+ merging contents of several directories into one, allowing writing
+ to a read-only media and others.
+</longdescription>
</pkgmetadata>
diff --git a/sys-fs/redirfs/redirfs-0.2-r1.ebuild b/sys-fs/redirfs/redirfs-0.2-r1.ebuild
deleted file mode 100644
index 5c3b97f7f99e..000000000000
--- a/sys-fs/redirfs/redirfs-0.2-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/redirfs/redirfs-0.2-r1.ebuild,v 1.2 2008/03/23 21:31:54 robbat2 Exp $
-
-inherit linux-mod eutils
-
-DESCRIPTION="Redirecting FileSystem"
-HOMEPAGE="http://www.redirfs.org"
-SRC_URI="http://www.redirfs.org/packages/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-pkg_setup() {
- linux-mod_pkg_setup
- MODULE_NAMES="redirfs(misc:)"
- BUILD_TARGETS="redirfs.ko"
- BUILD_PARAMS=" \
- KERN_SRC=\"${KERNEL_DIR}\" \
- KERN_VER=${KV_MAJOR}.${KV_MINOR}"
-
- eerror "This package is EXPERIMENTAL use it at your own risk"
- sleep 5
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-truncate_inode_pages.patch"
-}
-
-src_install() {
- dodoc CHANGELOG INSTALL README TODO
- linux-mod_src_install
- insinto /usr/include
- doins redirfs.h
-}
diff --git a/sys-fs/redirfs/redirfs-0.6.ebuild b/sys-fs/redirfs/redirfs-0.6.ebuild
deleted file mode 100644
index 6d0b6140bf01..000000000000
--- a/sys-fs/redirfs/redirfs-0.6.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/redirfs/redirfs-0.6.ebuild,v 1.1 2009/02/22 12:53:54 carlo Exp $
-
-inherit linux-mod
-
-DESCRIPTION="The RedirFS or redirecting file system is a new layer between virtual file system switch (VFS) and file system drivers."
-HOMEPAGE="http://www.redirfs.org"
-SRC_URI="http://www.redirfs.org/packages/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-pkg_setup() {
- linux-mod_pkg_setup
- MODULE_NAMES="redirfs(misc:)"
- BUILD_TARGETS="redirfs.ko"
- BUILD_PARAMS="-C ${KERNEL_DIR} M=${S} modules"
- ewarn "This package is EXPERIMENTAL use it at your own risk"
- sleep 5
-}
-
-src_install() {
- dodoc CHANGELOG INSTALL README TODO
- linux-mod_src_install
- insinto /usr/include
- doins redirfs.h
-}
diff --git a/sys-fs/redirfs/redirfs-0.8.ebuild b/sys-fs/redirfs/redirfs-0.8.ebuild
index cf02e7e2abf0..b7ed35a80d10 100644
--- a/sys-fs/redirfs/redirfs-0.8.ebuild
+++ b/sys-fs/redirfs/redirfs-0.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/redirfs/redirfs-0.8.ebuild,v 1.1 2010/01/19 11:26:21 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/redirfs/redirfs-0.8.ebuild,v 1.2 2012/05/28 22:11:20 bicatali Exp $
inherit linux-mod
-DESCRIPTION="The RedirFS or redirecting file system is a new layer between virtual file system switch (VFS) and file system drivers."
+DESCRIPTION="Layer between virtual file system switch and file system drivers"
HOMEPAGE="http://www.redirfs.org"
SRC_URI="http://www.redirfs.org/packages/${P}.tar.gz"
diff --git a/sys-fs/redirfs/redirfs-9999.ebuild b/sys-fs/redirfs/redirfs-9999.ebuild
new file mode 100644
index 000000000000..54e12f26ce2a
--- /dev/null
+++ b/sys-fs/redirfs/redirfs-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/redirfs/redirfs-9999.ebuild,v 1.1 2012/05/28 22:11:20 bicatali Exp $
+
+EAPI=4
+
+inherit linux-mod
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-2
+ KEYWORDS=""
+ EGIT_REPO_URI="git://www.redirfs.org/git/fhrbata/redirfs.git"
+ SRCDIR="${S}/src/redirfs"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://www.redirfs.org/packages/${P}.tar.gz"
+fi
+
+DESCRIPTION="Layer between virtual file system switch and file system drivers"
+HOMEPAGE="http://www.redirfs.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ MODULE_NAMES="redirfs(misc:${SRCDIR})"
+ BUILD_PARAMS="-C ${KERNEL_DIR} M=${SRCDIR}"
+ BUILD_TARGETS="redirfs.ko"
+ linux-mod_pkg_setup
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /usr/include
+ doins ${SRCDIR}/redirfs.h
+ dodoc ${SRCDIR}/{CHANGELOG,README,TODO}
+}