summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-27 20:54:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-27 20:54:55 +0000
commit6f7a0cad2bba1d381bc1b937a3ef5259504a12f7 (patch)
treeab9a249bfcf6f0c0273ca919b432eb8805df3605 /sys-fs
parentx86 stable, bug 322791 (diff)
downloadgentoo-2-6f7a0cad2bba1d381bc1b937a3ef5259504a12f7.tar.gz
gentoo-2-6f7a0cad2bba1d381bc1b937a3ef5259504a12f7.tar.bz2
gentoo-2-6f7a0cad2bba1d381bc1b937a3ef5259504a12f7.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/encfs/ChangeLog9
-rw-r--r--sys-fs/encfs/encfs-1.6.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/sys-fs/encfs/ChangeLog b/sys-fs/encfs/ChangeLog
index bd3fe6242a98..239eb55350dc 100644
--- a/sys-fs/encfs/ChangeLog
+++ b/sys-fs/encfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/encfs
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.41 2009/08/07 10:45:25 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.42 2010/06/27 20:54:55 ssuominen Exp $
+
+*encfs-1.6 (27 Jun 2010)
+
+ 27 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> +encfs-1.6.ebuild:
+ Version bump.
07 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> encfs-1.5.ebuild,
+files/encfs-1.5-glibc-2.10.patch:
diff --git a/sys-fs/encfs/encfs-1.6.ebuild b/sys-fs/encfs/encfs-1.6.ebuild
new file mode 100644
index 000000000000..909dc1edfe64
--- /dev/null
+++ b/sys-fs/encfs/encfs-1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.6.ebuild,v 1.1 2010/06/27 20:54:55 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
+HOMEPAGE="http://www.arg0.net/encfs/"
+SRC_URI="http://encfs.googlecode.com/files/${P}-1.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/boost-1.34
+ >=dev-libs/openssl-0.9.7
+ >=dev-libs/rlog-1.4
+ >=sys-fs/fuse-2.7.0"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/pkgconfig
+ sys-apps/attr
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+ find "${D}" -name '*.la' -delete
+}