summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-09-02 13:21:02 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-09-02 13:21:02 +0000
commit5ebc16cb7e3affa83f714a97e7f4bd3c0a95428c (patch)
treeed20454781d63d5146b6703a495566cfd5cd9e51 /sys-fs
parentBumpage (diff)
downloadgentoo-2-5ebc16cb7e3affa83f714a97e7f4bd3c0a95428c.tar.gz
gentoo-2-5ebc16cb7e3affa83f714a97e7f4bd3c0a95428c.tar.bz2
gentoo-2-5ebc16cb7e3affa83f714a97e7f4bd3c0a95428c.zip
Delete file from correct lib-dir (multilib), correcting bug 191043.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog6
-rw-r--r--sys-fs/udev/udev-114.ebuild4
-rw-r--r--sys-fs/udev/udev-115.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index ba3592841a72..6d0b822412c5 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.342 2007/09/02 10:25:23 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.343 2007/09/02 13:21:02 zzam Exp $
+
+ 02 Sep 2007; Matthias Schwarzott <zzam@gentoo.org> udev-114.ebuild,
+ udev-115.ebuild:
+ Delete file from correct lib-dir (multilib), correcting bug 191043.
02 Sep 2007; Matthias Schwarzott <zzam@gentoo.org> udev-114.ebuild:
Also doing lib install cleanup for stable version.
diff --git a/sys-fs/udev/udev-114.ebuild b/sys-fs/udev/udev-114.ebuild
index 73b377eaa463..00774c6cc3f8 100644
--- a/sys-fs/udev/udev-114.ebuild
+++ b/sys-fs/udev/udev-114.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-114.ebuild,v 1.12 2007/09/02 10:25:23 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-114.ebuild,v 1.13 2007/09/02 13:21:02 zzam Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -126,7 +126,7 @@ src_install() {
# vol_id library (needed by mount and HAL)
into /
- rm ${D}/lib/libvolume_id.so* 2>/dev/null
+ rm "${D}/$(get_libdir)"/libvolume_id.so* 2>/dev/null
dolib extras/volume_id/lib/*.so* || die "Failed installing libvolume_id.so"
into /usr
dolib extras/volume_id/lib/*.a || die "Failed installing libvolume_id.a"
diff --git a/sys-fs/udev/udev-115.ebuild b/sys-fs/udev/udev-115.ebuild
index 248729d2f531..8001a65c060d 100644
--- a/sys-fs/udev/udev-115.ebuild
+++ b/sys-fs/udev/udev-115.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-115.ebuild,v 1.4 2007/09/02 09:53:03 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-115.ebuild,v 1.5 2007/09/02 13:21:02 zzam Exp $
inherit eutils flag-o-matic multilib toolchain-funcs versionator
@@ -149,7 +149,7 @@ src_install() {
# vol_id library (needed by mount and HAL)
into /
- rm ${D}/lib/libvolume_id.so* 2>/dev/null
+ rm "${D}/$(get_libdir)"/libvolume_id.so* 2>/dev/null
dolib extras/volume_id/lib/*.so* || die "Failed installing libvolume_id.so"
into /usr
dolib extras/volume_id/lib/*.a || die "Failed installing libvolume_id.a"