summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-08-11 13:27:34 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-08-11 13:27:34 +0000
commit58694c9c59955dc65cd0575ef27620c225900707 (patch)
tree0d912f2876e40569b7cd925d53016c114ed3229a /sys-fs
parentx86 stable, bug #419111 (diff)
downloadgentoo-2-58694c9c59955dc65cd0575ef27620c225900707.tar.gz
gentoo-2-58694c9c59955dc65cd0575ef27620c225900707.tar.bz2
gentoo-2-58694c9c59955dc65cd0575ef27620c225900707.zip
Stop using /etc/udev which is reserved for user defined rules. Stop using /lib/udev and read the value of udevdir from udev.pc pkg-config file instead.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/multipath-tools/ChangeLog9
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.4.9-r5.ebuild82
2 files changed, 90 insertions, 1 deletions
diff --git a/sys-fs/multipath-tools/ChangeLog b/sys-fs/multipath-tools/ChangeLog
index 3e88e0721e7d..97b36a318425 100644
--- a/sys-fs/multipath-tools/ChangeLog
+++ b/sys-fs/multipath-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/multipath-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/ChangeLog,v 1.45 2012/05/26 10:04:43 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/ChangeLog,v 1.46 2012/08/11 13:27:34 ssuominen Exp $
+
+*multipath-tools-0.4.9-r5 (11 Aug 2012)
+
+ 11 Aug 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +multipath-tools-0.4.9-r5.ebuild:
+ Stop using /etc/udev which is reserved for user defined rules. Stop using
+ /lib/udev and read the value of udevdir from udev.pc pkg-config file instead.
26 May 2012; Alexey Shvetsov <alexxy@gentoo.org>
multipath-tools-0.4.9-r4.ebuild:
diff --git a/sys-fs/multipath-tools/multipath-tools-0.4.9-r5.ebuild b/sys-fs/multipath-tools/multipath-tools-0.4.9-r5.ebuild
new file mode 100644
index 000000000000..c54595a91118
--- /dev/null
+++ b/sys-fs/multipath-tools/multipath-tools-0.4.9-r5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/multipath-tools-0.4.9-r5.ebuild,v 1.1 2012/08/11 13:27:34 ssuominen Exp $
+
+EAPI=4
+inherit base eutils toolchain-funcs
+
+DESCRIPTION="Device mapper target autoconfig"
+HOMEPAGE="http://christophe.varoqui.free.fr/"
+SRC_URI="http://christophe.varoqui.free.fr/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="|| (
+ >=sys-fs/lvm2-2.02.45
+ >=sys-fs/device-mapper-1.00.19-r1
+ )
+ >=sys-fs/udev-124
+ dev-libs/libaio
+ sys-libs/readline
+ !<sys-apps/baselayout-2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.9-build.patch
+ "${FILESDIR}"/${PN}-0.4.9-buffer-overflows.patch
+ "${FILESDIR}"/${PN}-0.4.8-kparted-ext-partitions.patch
+ "${FILESDIR}"/${PN}-0.4.9-log_enquery_overflow.patch
+)
+
+src_compile() {
+ # LIBDM_API_FLUSH involves grepping files in /usr/include,
+ # so force the test to go the way we want #411337.
+ emake LIBDM_API_FLUSH=1 CC="$(tc-getCC)"
+}
+
+src_install() {
+ local udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+
+ dodir /sbin /usr/share/man/man8
+ emake \
+ DESTDIR="${D}" \
+ libudevdir='${prefix}'/"${udevdir}" \
+ install
+
+ insinto /etc
+ newins "${S}"/multipath.conf.annotated multipath.conf
+ # drop this one it doesnt work with recent udev bug #413063
+ rm "${D}"/etc/udev/rules.d/65-multipath.rules
+ # /etc/udev is reserved for user modified rules!
+ mv -vf "${D}"/etc/udev/rules.d "${D}/${udevdir}"/
+ fperms 644 "${udevdir}"/rules.d/66-kpartx.rules
+ newinitd "${FILESDIR}"/rc-multipathd multipathd
+ newinitd "${FILESDIR}"/multipath.rc multipath
+
+ dodoc multipath.conf.* AUTHOR ChangeLog FAQ README TODO
+ docinto kpartx
+ dodoc kpartx/ChangeLog kpartx/README
+}
+
+pkg_preinst() {
+ # The dev.d script was previously wrong and is now removed (the udev rules
+ # file does the job instead), but it won't be removed from live systems due
+ # to cfgprotect.
+ # This should help out a little...
+ if [[ -e ${ROOT}/etc/dev.d/block/multipath.dev ]] ; then
+ mkdir -p "${D}"/etc/dev.d/block
+ echo "# Please delete this file. It is obsoleted by /etc/udev/rules.d/65-multipath.rules" \
+ > "${D}"/etc/dev.d/block/multipath.dev
+ fi
+}
+
+pkg_postinst() {
+ elog "If you need multipath on your system, you must"
+ elog "add 'multipath' into your boot runlevel!"
+}