summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-01-01 23:00:13 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-01-01 23:00:13 +0000
commit424d3611eb96c2e2fdb0b3d6d6be09ff74986601 (patch)
tree37aa381a3ac6941aae364afc96dd0613f19aadfc /sys-fs
parentadd in delete_ functions, make index parameters able to take a character as w... (diff)
downloadgentoo-2-424d3611eb96c2e2fdb0b3d6d6be09ff74986601.tar.gz
gentoo-2-424d3611eb96c2e2fdb0b3d6d6be09ff74986601.tar.bz2
gentoo-2-424d3611eb96c2e2fdb0b3d6d6be09ff74986601.zip
Conversion to linux-mod
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog8
-rw-r--r--sys-fs/fuse/fuse-1.4.ebuild42
-rw-r--r--sys-fs/fuse/fuse-2.1.ebuild42
3 files changed, 36 insertions, 56 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index f6ea4adfd0c6..c64cbff6c9e0 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/fuse
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.4 2004/12/26 14:56:43 lu_zero Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.5 2005/01/01 23:00:13 genstef Exp $
+
+ 01 Jan 2005; Stefan Schweizer <genstef@gentoo.org> fuse-1.4.ebuild,
+ fuse-2.1.ebuild:
+ Conversion to linux-mod
26 Dec 2004; Luca Barbato <lu_zero@gentoo.org> fuse-2.1.ebuild:
Marked ~ppc
diff --git a/sys-fs/fuse/fuse-1.4.ebuild b/sys-fs/fuse/fuse-1.4.ebuild
index 7e1a625a448c..234b9502b8d7 100644
--- a/sys-fs/fuse/fuse-1.4.ebuild
+++ b/sys-fs/fuse/fuse-1.4.ebuild
@@ -1,53 +1,41 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-1.4.ebuild,v 1.1 2004/11/16 17:21:49 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-1.4.ebuild,v 1.2 2005/01/01 23:00:13 genstef Exp $
-inherit kernel-mod
+inherit linux-mod
MY_P=${P/_/-}
DESCRIPTION="An interface for filesystems implemented in userspace."
HOMEPAGE="http://sourceforge.net/projects/fuse"
SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
LICENSE="GPL-2"
-SLOT="0"
KEYWORDS="~x86"
IUSE=""
S=${WORKDIR}/${MY_P}
+MODULE_NAMES="fuse(fs:${S}/kernel)"
+BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
+BUILD_TARGETS="all"
-DEPEND="virtual/linux-sources"
-
-pkg_setup() {
- kernel-mod_check_modules_supported
-}
src_compile() {
- econf --disable-example --with-kernel="${ROOT}/usr/src/linux" || die "econf failed"
-
- sed -i 's/.*depmod.*//' kernel/Makefile
-
- # http://marc.theaimsgroup.com/?l=gentoo-dev&m=109672618708314&w=2
- kernel-mod_getversion
- if [ ${KV_MINOR} -gt 5 ] && [ ${KV_PATCH} -gt 5 ]
- then
- sed -i 's:SUBDIRS=:M=:g' kernel/Makefile
- fi
-
- unset ARCH
+ econf --disable-kernel-module --disable-example || die "econf failed"
emake || die "emake failed"
+
+ cd kernel
+ econf --with-kernel="${ROOT}${KV_DIR}" || die "econf kernel failed"
+ sed -i 's/.*depmod.*//' Makefile
+ convert_to_m Makefile
+ linux-mod_src_compile
}
src_install() {
- unset ARCH
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS BUGS ChangeLog Filesystems README README-2.4 \
README-2.6 README.NFS NEWS doc/how-fuse-works
docinto example
dodoc example/*
-}
-pkg_postinst() {
- einfo "Checking kernel module dependencies"
- test -r "${ROOT}/usr/src/linux/System.map" && \
- depmod -ae -F "${ROOT}/usr/src/linux/System.map" -b "${ROOT}" -r ${KV}
+ linux-mod_src_install
}
diff --git a/sys-fs/fuse/fuse-2.1.ebuild b/sys-fs/fuse/fuse-2.1.ebuild
index 64862f378f43..ed2d894cd296 100644
--- a/sys-fs/fuse/fuse-2.1.ebuild
+++ b/sys-fs/fuse/fuse-2.1.ebuild
@@ -1,53 +1,41 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.1.ebuild,v 1.2 2004/12/26 14:56:43 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.1.ebuild,v 1.3 2005/01/01 23:00:13 genstef Exp $
-inherit kernel-mod
+inherit linux-mod
MY_P=${P/_/-}
DESCRIPTION="An interface for filesystems implemented in userspace."
HOMEPAGE="http://sourceforge.net/projects/fuse"
SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
LICENSE="GPL-2"
-SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
S=${WORKDIR}/${MY_P}
+MODULE_NAMES="fuse(fs:${S}/kernel)"
+BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
+BUILD_TARGETS="all"
-DEPEND="virtual/linux-sources"
-
-pkg_setup() {
- kernel-mod_check_modules_supported
-}
src_compile() {
- econf --disable-example --with-kernel="${ROOT}/usr/src/linux" || die "econf failed"
-
- sed -i 's/.*depmod.*//' kernel/Makefile
-
- # http://marc.theaimsgroup.com/?l=gentoo-dev&m=109672618708314&w=2
- kernel-mod_getversion
- if [ ${KV_MINOR} -gt 5 ] && [ ${KV_PATCH} -gt 5 ]
- then
- sed -i 's:SUBDIRS=:M=:g' kernel/Makefile
- fi
-
- unset ARCH
+ econf --disable-kernel-module --disable-example || die "econf failed"
emake || die "emake failed"
+
+ cd kernel
+ econf --with-kernel="${ROOT}${KV_DIR}" || die "econf kernel failed"
+ sed -i 's/.*depmod.*//' Makefile
+ convert_to_m Makefile
+ linux-mod_src_compile
}
src_install() {
- unset ARCH
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS BUGS ChangeLog Filesystems README README-2.4 \
README-2.6 README.NFS NEWS doc/how-fuse-works
docinto example
dodoc example/*
-}
-pkg_postinst() {
- einfo "Checking kernel module dependencies"
- test -r "${ROOT}/usr/src/linux/System.map" && \
- depmod -ae -F "${ROOT}/usr/src/linux/System.map" -b "${ROOT}" -r ${KV}
+ linux-mod_src_install
}