summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-10-16 20:08:28 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-10-16 20:08:28 +0000
commit3c31967de069d5b6c876027850504198d8acda93 (patch)
tree27eaba34c33d0cf6b208ceed5b1ed4ba46db6ea4 /sys-fs
parentfix gcc-4.x issues; thanks to Pascal Martineau on #131831 (diff)
downloadgentoo-2-3c31967de069d5b6c876027850504198d8acda93.tar.gz
gentoo-2-3c31967de069d5b6c876027850504198d8acda93.tar.bz2
gentoo-2-3c31967de069d5b6c876027850504198d8acda93.zip
Take ownership, version bump, closes bug#149562
(Portage version: 2.1.1)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dazuko/ChangeLog8
-rw-r--r--sys-fs/dazuko/dazuko-2.3.1.ebuild50
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.3.13
-rw-r--r--sys-fs/dazuko/metadata.xml4
4 files changed, 62 insertions, 3 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index e55c300abe80..c40d26c6619f 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/dazuko
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.3 2006/02/19 10:59:45 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.4 2006/10/16 20:08:28 alonbl Exp $
+
+*dazuko-2.3.1 (16 Oct 2006)
+
+ 16 Oct 2006; Alon Bar-Lev <alonbl@gentoo.org> metadata.xml,
+ +dazuko-2.3.1.ebuild:
+ Take ownership, version bump, closes bug#149562
*dazuko-2.2.0 (19 Feb 2006)
diff --git a/sys-fs/dazuko/dazuko-2.3.1.ebuild b/sys-fs/dazuko/dazuko-2.3.1.ebuild
new file mode 100644
index 000000000000..0b8ba9b9e799
--- /dev/null
+++ b/sys-fs/dazuko/dazuko-2.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.1.ebuild,v 1.1 2006/10/16 20:08:28 alonbl Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Linux kernel module and interface providing file access control"
+MY_P="${P/_/-}" # for -preN versions
+SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.dazuko.org"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND=">=virtual/linux-sources-2.2"
+S="${WORKDIR}/${MY_P}"
+
+# kernel settings
+CONFIG_CHECK="SECURITY_CAPABILITIES"
+MODULE_NAMES="dazuko(misc:)"
+BUILD_TARGETS="dummy_rule"
+
+src_compile() {
+ cd "${S}"
+
+ ./configure \
+ --without-dep \
+ --kernelsrcdir="${KERNEL_DIR}" \
+ || die "configure failed"
+ convert_to_m Makefile
+ linux-mod_src_compile
+
+ cd library
+ emake || die
+ cd ..
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dolib.a library/libdazuko.a
+ insinto /usr/include
+ doins dazukoio.h
+
+ dodoc COPYING
+ dodoc README
+ dodoc README.linux26
+ dodoc README.trusted
+}
+
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.3.1 b/sys-fs/dazuko/files/digest-dazuko-2.3.1
new file mode 100644
index 000000000000..4478b3fc29d0
--- /dev/null
+++ b/sys-fs/dazuko/files/digest-dazuko-2.3.1
@@ -0,0 +1,3 @@
+MD5 7f8373d4b429a9e454aa556a8f2e40fb dazuko-2.3.1.tar.gz 176944
+RMD160 cc527bf0f251cfa96ec79ddbcc8e6ad49247dbef dazuko-2.3.1.tar.gz 176944
+SHA256 9481875699e6fefd80f40b945159df55815408f76f9fd511656c55a52499fc8e dazuko-2.3.1.tar.gz 176944
diff --git a/sys-fs/dazuko/metadata.xml b/sys-fs/dazuko/metadata.xml
index 2712cdb26b8a..45ac65e07ff8 100644
--- a/sys-fs/dazuko/metadata.xml
+++ b/sys-fs/dazuko/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>wschlich@gentoo.org</email>
- <name>Wolfram Schlich</name>
+ <email>alonbl@gentoo.org</email>
+ <name>Alon Bar-Lev</name>
<description>Primary maintainer</description>
</maintainer>
<longdescription>