summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2012-12-23 05:44:24 +0000
committerRichard Yao <ryao@gentoo.org>2012-12-23 05:44:24 +0000
commit3c0f949591c9e75343e9f883bb8d1952c5785e96 (patch)
tree19ab085d5b3f7379077ce236bb5b0bda85c1367e /sys-fs
parentBump sys-fs/zfs-kmod to 0.6.0_rc13 (diff)
downloadgentoo-2-3c0f949591c9e75343e9f883bb8d1952c5785e96.tar.gz
gentoo-2-3c0f949591c9e75343e9f883bb8d1952c5785e96.tar.bz2
gentoo-2-3c0f949591c9e75343e9f883bb8d1952c5785e96.zip
Bump sys-fs/zfs to 0.6.0_rc13
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs/ChangeLog7
-rw-r--r--sys-fs/zfs/zfs-0.6.0_rc13.ebuild108
2 files changed, 114 insertions, 1 deletions
diff --git a/sys-fs/zfs/ChangeLog b/sys-fs/zfs/ChangeLog
index e10607d0b793..7f4ebbbda2c5 100644
--- a/sys-fs/zfs/ChangeLog
+++ b/sys-fs/zfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/zfs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.52 2012/12/03 02:03:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.53 2012/12/23 05:44:24 ryao Exp $
+
+*zfs-0.6.0_rc13 (23 Dec 2012)
+
+ 23 Dec 2012; Richard Yao <ryao@gentoo.org> +zfs-0.6.0_rc13.ebuild:
+ Bump sys-fs/zfs to 0.6.0_rc13
03 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> zfs-0.6.0_rc10-r2.ebuild,
zfs-0.6.0_rc11-r1.ebuild, zfs-0.6.0_rc12-r1.ebuild, zfs-9999.ebuild:
diff --git a/sys-fs/zfs/zfs-0.6.0_rc13.ebuild b/sys-fs/zfs/zfs-0.6.0_rc13.ebuild
new file mode 100644
index 000000000000..49bb81348a5f
--- /dev/null
+++ b/sys-fs/zfs/zfs-0.6.0_rc13.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-0.6.0_rc13.ebuild,v 1.1 2012/12/23 05:44:24 ryao Exp $
+
+EAPI="4"
+
+AT_M4DIR="config"
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+inherit bash-completion-r1 flag-o-matic toolchain-funcs autotools-utils udev
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/zfsonlinux/${PN}.git"
+else
+ inherit eutils versionator
+ MY_PV=$(replace_version_separator 3 '-')
+ SRC_URI="https://github.com/zfsonlinux/${PN}/archive/${PN}-${MY_PV}.tar.gz"
+ S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Userland utilities for ZFS Linux kernel module"
+HOMEPAGE="http://zfsonlinux.org/"
+
+LICENSE="BSD-2 CDDL MIT"
+SLOT="0"
+IUSE="custom-cflags kernel-builtin +rootfs test-suite static-libs"
+RESTRICT="test"
+
+COMMON_DEPEND="
+ sys-apps/util-linux[static-libs?]
+ sys-libs/zlib[static-libs(+)?]
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+RDEPEND="${COMMON_DEPEND}
+ !=sys-apps/grep-2.13*
+ !kernel-builtin? ( =sys-fs/zfs-kmod-${PV}* )
+ !sys-fs/zfs-fuse
+ !prefix? ( virtual/udev )
+ test-suite? (
+ sys-apps/gawk
+ sys-apps/util-linux
+ sys-devel/bc
+ sys-block/parted
+ sys-fs/lsscsi
+ sys-fs/mdadm
+ sys-process/procps
+ virtual/modutils
+ )
+ rootfs? (
+ app-arch/cpio
+ app-misc/pax-utils
+ )
+"
+
+src_prepare() {
+ # Workaround for hard coded path
+ sed -i "s|/sbin/lsmod|/bin/lsmod|" scripts/common.sh.in || die
+ # Workaround rename
+ sed -i "s|/usr/bin/scsi-rescan|/usr/sbin/rescan-scsi-bus|" scripts/common.sh.in || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --sbindir="${EPREFIX}/sbin"
+ --with-config=user
+ --with-linux="${KV_DIR}"
+ --with-linux-obj="${KV_OUT_DIR}"
+ --with-udevdir="$(udev_get_udevdir)"
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ gen_usr_ldscript -a uutil nvpair zpool zfs
+ rm -rf "${ED}usr/share/dracut"
+ use test-suite || rm -rf "${ED}usr/libexec"
+
+ if use rootfs
+ then
+ doinitd "${FILESDIR}/zfs-shutdown"
+ exeinto /usr/share/zfs
+ doexe "${FILESDIR}/linuxrc"
+ fi
+
+ newbashcomp "${FILESDIR}/bash-completion" zfs
+
+}
+
+pkg_postinst() {
+
+ [ -e "${EROOT}/etc/runlevels/boot/zfs" ] \
+ || ewarn 'You should add zfs to the boot runlevel.'
+
+ use rootfs && ([ -e "${EROOT}/etc/runlevels/shutdown/zfs-shutdown" ] \
+ || ewarn 'You should add zfs-shutdown to the shutdown runlevel.')
+
+}