summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-06-18 04:17:14 +0000
committerTim Harder <radhermit@gentoo.org>2015-06-18 04:17:14 +0000
commit3990d97aa443013a819a713aa0356833086c5f7b (patch)
treec35cb32872e51742338cefc6deb1c5a2b7607153 /sys-fs
parentBump (diff)
downloadgentoo-2-3990d97aa443013a819a713aa0356833086c5f7b.tar.gz
gentoo-2-3990d97aa443013a819a713aa0356833086c5f7b.tar.bz2
gentoo-2-3990d97aa443013a819a713aa0356833086c5f7b.zip
Security bump (bug #550152).
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog7
-rw-r--r--sys-fs/fuse/fuse-2.9.4.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 93c50c2282b0..d5294ecb1301 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.201 2015/03/07 21:34:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.202 2015/06/18 04:17:14 radhermit Exp $
+
+*fuse-2.9.4 (18 Jun 2015)
+
+ 18 Jun 2015; Tim Harder <radhermit@gentoo.org> +fuse-2.9.4.ebuild:
+ Security bump (bug #550152).
07 Mar 2015; Mike Frysinger <vapier@gentoo.org>
+files/fuse-2.9.3-kernel-types.patch, fuse-2.9.3.ebuild:
diff --git a/sys-fs/fuse/fuse-2.9.4.ebuild b/sys-fs/fuse/fuse-2.9.4.ebuild
new file mode 100644
index 000000000000..a73e8a636885
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.9.4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.9.4.ebuild,v 1.1 2015/06/18 04:17:14 radhermit Exp $
+
+EAPI=5
+inherit eutils libtool linux-info udev toolchain-funcs
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace"
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="examples kernel_linux kernel_FreeBSD static-libs"
+
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+DEPEND="virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use kernel_linux ; then
+ if kernel_is lt 2 6 9 ; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use user-mode utils"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.9.3-kernel-types.patch
+ # sandbox violation with mtab writability wrt #438250
+ # don't sed configure.in without eautoreconf because of maintainer mode
+ sed -i 's:umount --fake:true --fake:' configure || die
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ INIT_D_PATH="${EPREFIX}/etc/init.d" \
+ MOUNT_FUSE_PATH="${EPREFIX}/sbin" \
+ UDEV_RULES_PATH="${EPREFIX}/$(get_udevdir)/rules.d" \
+ $(use_enable static-libs static) \
+ --disable-example
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog Filesystems README \
+ README.NFS NEWS doc/how-fuse-works \
+ doc/kernel.txt FAQ
+
+ if use examples ; then
+ docinto examples
+ dodoc example/*
+ fi
+
+ if use kernel_linux ; then
+ newinitd "${FILESDIR}"/fuse.init fuse
+ elif use kernel_FreeBSD ; then
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ newinitd "${FILESDIR}"/fuse-fbsd.init fuse
+ else
+ die "We don't know what init code install for your kernel, please file a bug."
+ fi
+
+ prune_libtool_files
+ rm -rf "${D}"/dev
+
+ dodir /etc
+ cat > "${ED}"/etc/fuse.conf <<-EOF
+ # Set the maximum number of FUSE mounts allowed to non-root users.
+ # The default is 1000.
+ #
+ #mount_max = 1000
+
+ # Allow non-root users to specify the 'allow_other' or 'allow_root'
+ # mount options.
+ #
+ #user_allow_other
+ EOF
+}