summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-12-01 13:04:21 +0000
committerJustin Lecher <jlec@gentoo.org>2011-12-01 13:04:21 +0000
commit32849d029ed0609af20a270f4f233a45636f2508 (patch)
treeb58ea61897c3aa399de79432b606c2237ef02d97 /sys-fs
parentdrop old plugincache wiping code that is now invalidly causing issues; >0.7.6... (diff)
downloadgentoo-2-32849d029ed0609af20a270f4f233a45636f2508.tar.gz
gentoo-2-32849d029ed0609af20a270f4f233a45636f2508.tar.bz2
gentoo-2-32849d029ed0609af20a270f4f233a45636f2508.zip
Version Bump
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cachefilesd/ChangeLog10
-rw-r--r--sys-fs/cachefilesd/cachefilesd-0.10.4.ebuild50
-rw-r--r--sys-fs/cachefilesd/files/0.10.4-makefile.patch24
-rw-r--r--sys-fs/cachefilesd/metadata.xml6
4 files changed, 85 insertions, 5 deletions
diff --git a/sys-fs/cachefilesd/ChangeLog b/sys-fs/cachefilesd/ChangeLog
index 512197754109..8d3512690fbe 100644
--- a/sys-fs/cachefilesd/ChangeLog
+++ b/sys-fs/cachefilesd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/cachefilesd
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/ChangeLog,v 1.3 2010/09/20 08:45:22 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/ChangeLog,v 1.4 2011/12/01 13:04:21 jlec Exp $
+
+*cachefilesd-0.10.4 (01 Dec 2011)
+
+ 01 Dec 2011; Justin Lecher <jlec@gentoo.org> +files/0.10.4-makefile.patch,
+ +cachefilesd-0.10.4.ebuild, metadata.xml:
+ Version Bump
20 Sep 2010; Justin Lecher <jlec@gentoo.org> files/cachefilesd.init:
Corrected typo in init script, 338124
diff --git a/sys-fs/cachefilesd/cachefilesd-0.10.4.ebuild b/sys-fs/cachefilesd/cachefilesd-0.10.4.ebuild
new file mode 100644
index 000000000000..c89eeaede2b8
--- /dev/null
+++ b/sys-fs/cachefilesd/cachefilesd-0.10.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/cachefilesd-0.10.4.ebuild,v 1.1 2011/12/01 13:04:21 jlec Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Provides a caching directory on an already mounted filesystem"
+HOMEPAGE="http://people.redhat.com/~dhowells/fscache/"
+SRC_URI="http://people.redhat.com/~dhowells/fscache/${P}.tar.bz2 -> ${P}.tar"
+
+IUSE="doc selinux"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-makefile.patch
+ tc-export CC
+ if ! use selinux; then
+ sed -e '/^secctx/s:^:#:g' -i cachefilesd.conf || die
+ fi
+}
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ if use selinux; then
+ insinto /usr/share/doc/${P}
+ doins -r selinux || die
+ fi
+
+ dodoc README howto.txt || die
+
+ newconfd "${FILESDIR}"/cachefilesd.conf cachefilesd || die
+ newinitd "${FILESDIR}"/cachefilesd.init cachefilesd || die
+
+ keepdir /var/cache/fscache
+}
+
+pkg_postinst() {
+ [[ -d /var/cache/fscache ]] && return
+ elog "Before CacheFiles can be used, a directory for local storage"
+ elog "must be created. The default configuration of /etc/cachefilesd.conf"
+ elog "uses /var/cache/fscache. The filesystem mounted there must support"
+ elog "extended attributes (mount -o user_xattr)."
+ elog ""
+ elog "Once that is taken care of, start the daemon, add -o ...,fsc"
+ elog "to the mount options of your network mounts, and let it fly!"
+}
diff --git a/sys-fs/cachefilesd/files/0.10.4-makefile.patch b/sys-fs/cachefilesd/files/0.10.4-makefile.patch
new file mode 100644
index 000000000000..5cbb24001c95
--- /dev/null
+++ b/sys-fs/cachefilesd/files/0.10.4-makefile.patch
@@ -0,0 +1,24 @@
+ Makefile | 6 ++++--
+ 1 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d5d352e..9a98bf5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,3 @@
+-CFLAGS := -g -O2 -Wall
+ INSTALL := install
+ DESTDIR :=
+ ETCDIR := /etc
+@@ -38,7 +37,10 @@ endif
+ ###############################################################################
+ all: cachefilesd
+
+-cachefilesd: cachefilesd.c Makefile
++cachefilesd.o: cachefilesd.c
++ $(CC) $(CFLAGS) -c $<
++
++cachefilesd: cachefilesd.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
+
+ ###############################################################################
diff --git a/sys-fs/cachefilesd/metadata.xml b/sys-fs/cachefilesd/metadata.xml
index dc06c49f3397..c845479d513e 100644
--- a/sys-fs/cachefilesd/metadata.xml
+++ b/sys-fs/cachefilesd/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>