summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-09-30 18:03:10 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-09-30 18:03:10 +0000
commit29d952c50359054dc0ef9c7b79fbffabe8a8d212 (patch)
tree6b6603fd5f0c755ef4c0fae189604e29ccafe14c /sys-fs
parentStable on alpha, bug #284574 (diff)
downloadgentoo-2-29d952c50359054dc0ef9c7b79fbffabe8a8d212.tar.gz
gentoo-2-29d952c50359054dc0ef9c7b79fbffabe8a8d212.tar.bz2
gentoo-2-29d952c50359054dc0ef9c7b79fbffabe8a8d212.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fatsort/ChangeLog8
-rw-r--r--sys-fs/fatsort/fatsort-0.9.12.199.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-fs/fatsort/ChangeLog b/sys-fs/fatsort/ChangeLog
index c043ac3a163b..3ac3d35e6c41 100644
--- a/sys-fs/fatsort/ChangeLog
+++ b/sys-fs/fatsort/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/fatsort
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fatsort/ChangeLog,v 1.4 2009/09/28 16:59:52 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fatsort/ChangeLog,v 1.5 2009/09/30 18:03:10 billie Exp $
+
+*fatsort-0.9.12.199 (30 Sep 2009)
+
+ 30 Sep 2009; Pielmeier Daniel <billie@gentoo.org>
+ +fatsort-0.9.12.199.ebuild:
+ Version bump.
*fatsort-0.9.11.196 (28 Sep 2009)
diff --git a/sys-fs/fatsort/fatsort-0.9.12.199.ebuild b/sys-fs/fatsort/fatsort-0.9.12.199.ebuild
new file mode 100644
index 000000000000..fc49ccae2f97
--- /dev/null
+++ b/sys-fs/fatsort/fatsort-0.9.12.199.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fatsort/fatsort-0.9.12.199.ebuild,v 1.1 2009/09/30 18:03:10 billie Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs versionator
+
+MY_PV=$(replace_version_separator 3 '-')
+
+DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players."
+HOMEPAGE="http://fatsort.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ sed -i -e 's:/usr/local/sbin:/usr/sbin:g' src/Makefile || die "sed failed!"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ DESTDIR="${D}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doman man/fatsort.8 || die "doman failed"
+ dodoc CHANGES README TODO || die "dodoc failed"
+}