summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-01-10 02:40:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-01-10 02:40:42 +0000
commit1d1c4f5bf467c119cae286cf1f8f9c3d6a87bdde (patch)
tree62701e52749b5b8f2f91ba97f0532342fffec03e /sys-fs
parentInitial import. Closes #46896. (Manifest recommit) (diff)
downloadgentoo-2-1d1c4f5bf467c119cae286cf1f8f9c3d6a87bdde.tar.gz
gentoo-2-1d1c4f5bf467c119cae286cf1f8f9c3d6a87bdde.tar.bz2
gentoo-2-1d1c4f5bf467c119cae286cf1f8f9c3d6a87bdde.zip
Force new build to unstable instead of stable free, and add warnings in it.
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/progsreiserfs/ChangeLog6
-rw-r--r--sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild20
2 files changed, 22 insertions, 4 deletions
diff --git a/sys-fs/progsreiserfs/ChangeLog b/sys-fs/progsreiserfs/ChangeLog
index aa9cce43dc40..d13125bf584a 100644
--- a/sys-fs/progsreiserfs/ChangeLog
+++ b/sys-fs/progsreiserfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/progsreiserfs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/progsreiserfs/ChangeLog,v 1.10 2005/01/10 02:10:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/progsreiserfs/ChangeLog,v 1.11 2005/01/10 02:40:42 robbat2 Exp $
+
+ 09 Jan 2005; Robin H. Johnson <robbat2@gentoo.org>
+ progsreiserfs-0.3.1_rc8.ebuild:
+ Force new build to unstable instead of stable free, and add warnings in it.
*progsreiserfs-0.3.1_rc8 (09 Jan 2005)
diff --git a/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild b/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild
index 8002501ebe0c..95d3b4d806fa 100644
--- a/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild
+++ b/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild,v 1.1 2005/01/10 02:10:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild,v 1.2 2005/01/10 02:40:42 robbat2 Exp $
inherit libtool flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="http://reiserfs.linux.kiev.ua/snapshots/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc hppa amd64 alpha ia64 mips ppc64"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa ~amd64 ~alpha ~ia64 ~mips ~ppc64"
IUSE="nls debug"
RDEPEND=""
@@ -19,6 +19,11 @@ DEPEND="nls? ( sys-devel/gettext )"
S="${WORKDIR}/${MY_P}"
+progsreiserfs_warning() {
+ ewarn "progsreiserfs has been proven dangerous in the past, generating bad"
+ ewarn "partitions and destroying data on resize/cpfs operations."
+}
+
src_compile() {
elibtoolize
filter-lfs-flags
@@ -28,14 +33,23 @@ src_compile() {
$(use_enable debug) \
|| die "Configure failed"
emake || die "Make failed"
+ progsreiserfs_warning
}
src_install() {
make install DESTDIR="${D}" || die "Install failed"
# Make sure users only use the official namesys binaries
- rm -r "${D}"/usr/{sbin,share}
+ rm -r "${D}"/usr/{sbin,share/man}
dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
docinto demos
dodoc demos/*.c
+ progsreiserfs_warning
+}
+
+pkg_postinst() {
+ progsreiserfs_warning
+}
+pkg_preinst() {
+ progsreiserfs_warning
}