summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-25 01:12:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-25 01:12:36 +0000
commit1cd250fe93139b23d1d18ce89114377b4bce27b6 (patch)
treec2746021d5197429eca87f90dda3b924dea1558a /sys-fs
parentFixes and x86 keyword (Manifest recommit) (diff)
downloadgentoo-2-1cd250fe93139b23d1d18ce89114377b4bce27b6.tar.gz
gentoo-2-1cd250fe93139b23d1d18ce89114377b4bce27b6.tar.bz2
gentoo-2-1cd250fe93139b23d1d18ce89114377b4bce27b6.zip
IUSE; don't rdepend on sed; use character class in sed; error check disk io; compress docs
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsprogs/ChangeLog6
-rw-r--r--sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild15
2 files changed, 15 insertions, 6 deletions
diff --git a/sys-fs/xfsprogs/ChangeLog b/sys-fs/xfsprogs/ChangeLog
index 1afc7915708d..a8cd8d59bdbd 100644
--- a/sys-fs/xfsprogs/ChangeLog
+++ b/sys-fs/xfsprogs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/xfsprogs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.11 2004/04/25 08:15:13 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.12 2004/05/25 01:12:36 mr_bones_ Exp $
+
+ 24 May 2004; Michael Sterrett <mr_bones_@gentoo.org> xfsprogs-2.6.3.ebuild:
+ IUSE; don't rdepend on sed; use character class in sed; error check disk io;
+ compress docs
25 Apr 2004; Joshua Kinard <kumba@gentoo.org> xfsprogs-2.6.3.ebuild:
Tweaked the arch check to see if PLATFORM needed to be unset and added mips to
diff --git a/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild b/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild
index 5aabead82b98..63242d9a55b0 100644
--- a/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild,v 1.4 2004/04/27 03:21:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild,v 1.5 2004/05/25 01:12:36 mr_bones_ Exp $
inherit flag-o-matic
@@ -11,8 +11,11 @@ SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ia64"
+IUSE=""
-DEPEND="sys-fs/e2fsprogs
+RDEPEND="virtual/glibc
+ sys-fs/e2fsprogs"
+DEPEND="${RDEPEND}
>=sys-apps/sed-4"
src_unpack() {
@@ -21,7 +24,7 @@ src_unpack() {
sed -i \
-e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
-e '/^GCFLAGS/s:-O1::' \
- -e '/^PKG_[A-Z]*_DIR/s:= := $(DESTDIR):' \
+ -e '/^PKG_[[:upper:]]*_DIR/s:= := $(DESTDIR):' \
include/builddefs.in \
|| die "sed include/builddefs.in failed"
}
@@ -57,6 +60,8 @@ src_install() {
sed \
-e 's:installed=no:installed=yes:g' \
${S}/libhandle/.libs/libhandle.la \
- > ${D}/usr/lib/libhandle.la
- mv ${D}/lib/*.a ${D}/usr/lib/
+ > ${D}/usr/lib/libhandle.la \
+ || die "sed failed"
+ mv ${D}/lib/*.a ${D}/usr/lib/ || die "mv failed"
+ prepalldocs
}