summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-11 08:33:01 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-11 08:33:01 +0000
commit1971ffcc23618dcab410a84a11a1416a3059ec35 (patch)
tree25497e6df23b0bd7011f72157070ef732d20ec13 /sys-fs
parentmove dev-vcs/cola dev-vcs/git-cola (diff)
downloadgentoo-2-1971ffcc23618dcab410a84a11a1416a3059ec35.tar.gz
gentoo-2-1971ffcc23618dcab410a84a11a1416a3059ec35.tar.bz2
gentoo-2-1971ffcc23618dcab410a84a11a1416a3059ec35.zip
Version bump #412795 by Manuel Rüger (mrueg). Replace `read -t` with stty hacks by Martin Väth #255528.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup/ChangeLog9
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.4.2.ebuild101
-rwxr-xr-xsys-fs/cryptsetup/files/dmcrypt.rc19
3 files changed, 123 insertions, 6 deletions
diff --git a/sys-fs/cryptsetup/ChangeLog b/sys-fs/cryptsetup/ChangeLog
index 6901e8bbf829..f42237c4370c 100644
--- a/sys-fs/cryptsetup/ChangeLog
+++ b/sys-fs/cryptsetup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/cryptsetup
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.133 2012/05/11 08:31:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.134 2012/05/11 08:33:01 vapier Exp $
+
+*cryptsetup-1.4.2 (11 May 2012)
+
+ 11 May 2012; Mike Frysinger <vapier@gentoo.org> +cryptsetup-1.4.2.ebuild,
+ files/dmcrypt.rc:
+ Version bump #412795 by Manuel Rüger (mrueg). Replace `read -t` with stty
+ hacks by Martin Väth #255528.
11 May 2012; Mike Frysinger <vapier@gentoo.org> +files/1.4.1-dmcrypt.rc,
cryptsetup-1.4.1.ebuild, cryptsetup-1.4.1-r1.ebuild:
diff --git a/sys-fs/cryptsetup/cryptsetup-1.4.2.ebuild b/sys-fs/cryptsetup/cryptsetup-1.4.2.ebuild
new file mode 100644
index 000000000000..3c4f0c02a36d
--- /dev/null
+++ b/sys-fs/cryptsetup/cryptsetup-1.4.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.4.2.ebuild,v 1.1 2012/05/11 08:33:01 vapier Exp $
+
+EAPI="4"
+
+inherit linux-info libtool
+
+MY_P=${P/_rc/-rc}
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="http://code.google.com/p/cryptsetup/"
+SRC_URI="http://cryptsetup.googlecode.com/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls selinux static static-libs"
+
+S=${WORKDIR}/${MY_P}
+
+LIB_DEPEND="dev-libs/libgpg-error[static-libs(+)]
+ >=dev-libs/popt-1.7[static-libs(+)]
+ >=sys-apps/util-linux-2.17.2[static-libs(+)]
+ >=dev-libs/libgcrypt-1.1.42[static-libs(+)]
+ >=sys-fs/lvm2-2.02.64[static-libs(+)]
+ >=sys-fs/udev-124[static-libs(+)]
+ >=sys-libs/e2fsprogs-libs-1.41[static-libs(+)]"
+RDEPEND="static-libs? ( ${LIB_DEPEND} )
+ !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ !<sys-apps/baselayout-2
+ !sys-fs/cryptsetup-luks
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+pkg_setup() {
+ local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC"
+ local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
+ local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
+ local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
+ check_extra_config
+}
+
+src_prepare() {
+ sed -i '/^LOOPDEV=/s:$: || exit 0:' tests/{compat,mode}-test
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --sbindir=/sbin \
+ --enable-shared \
+ $(use_enable static static-cryptsetup) \
+ $(use_enable static-libs static) \
+ $(use_enable nls) \
+ $(use_enable selinux)
+}
+
+src_test() {
+ if [[ ! -e /dev/mapper/control ]] ; then
+ ewarn "No /dev/mapper/control found -- skipping tests"
+ return 0
+ fi
+ local p
+ for p in /dev/mapper /dev/loop* ; do
+ addwrite ${p}
+ done
+ default
+}
+
+src_install() {
+ default
+ use static && { mv "${ED}"/sbin/cryptsetup{.static,} || die ; }
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+
+ newconfd "${FILESDIR}"/1.0.6-dmcrypt.confd dmcrypt
+ newinitd "${FILESDIR}"/dmcrypt.rc dmcrypt
+}
+
+pkg_postinst() {
+ ewarn "This ebuild introduces a new set of scripts and configuration"
+ ewarn "than the last version. If you are currently using /etc/conf.d/cryptfs"
+ ewarn "then you *MUST* copy your old file to:"
+ ewarn "/etc/conf.d/dmcrypt"
+ ewarn "Or your encrypted partitions will *NOT* work."
+ elog "Please see the example for configuring a LUKS mountpoint"
+ elog "in /etc/conf.d/dmcrypt"
+ elog
+ elog "If you are using baselayout-2 then please do:"
+ elog "rc-update add dmcrypt boot"
+ elog "This version introduces a command line arguement 'key_timeout'."
+ elog "If you want the search for the removable key device to timeout"
+ elog "after 10 seconds add the following to your bootloader config:"
+ elog "key_timeout=10"
+ elog "A timeout of 0 will mean it will wait indefinitely."
+ elog
+ elog "Users using cryptsetup-1.0.x (dm-crypt plain) volumes must use"
+ elog "a compatibility mode when using cryptsetup-1.1.x. This can be"
+ elog "done by specifying the cipher (-c), key size (-s) and hash (-h)."
+ elog "For more info, see http://code.google.com/p/cryptsetup/wiki/FrequentlyAskedQuestions#6._Issues_with_Specific_Versions_of_cryptsetup"
+}
diff --git a/sys-fs/cryptsetup/files/dmcrypt.rc b/sys-fs/cryptsetup/files/dmcrypt.rc
index 7be9a9a3fdf9..130036b9202f 100755
--- a/sys-fs/cryptsetup/files/dmcrypt.rc
+++ b/sys-fs/cryptsetup/files/dmcrypt.rc
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/files/dmcrypt.rc,v 1.3 2012/05/11 08:18:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/files/dmcrypt.rc,v 1.4 2012/05/11 08:33:01 vapier Exp $
depend() {
before checkfs fsck
@@ -71,17 +71,26 @@ dm_crypt_execute_dmcrypt() {
if [ -n "${key}" ] ; then
read_abort() {
# some colors
- local ans
- shift
+ local ans savetty resettty
[ -z "${NORMAL}" ] && eval $(eval_ecolors)
einfon " $1? (${WARN}yes${NORMAL}/${GOOD}No${NORMAL}) "
- if ! read -n 1 $* ans ; then
+ shift
+ # This is ugly as s**t. But POSIX doesn't provide `read -t`, so
+ # we end up having to implement our own crap with stty/etc...
+ savetty=$(stty -g)
+ resettty='stty ${savetty}; trap - EXIT HUP INT TERM'
+ trap 'eval "${resettty}"' EXIT HUP INT TERM
+ stty -icanon
+ [ "${1}" = -t ] && stty min 0 time "$(( $2 * 10 ))"
+ ans=$(dd count=1 bs=1 2>/dev/null) || ans=''
+ eval "${resettty}"
+ if [ -z "${ans}" ] ; then
printf '\r'
else
echo
fi
case ${ans} in
- [yY]|[yY][eE][sS]) return 0;;
+ [yY]) return 0;;
*) return 1;;
esac
}