summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-08-13 17:05:39 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-08-13 17:05:39 +0000
commit1578d0acc457a858080a404e2cd3cce598de8980 (patch)
treeaf74ff9d5fea48a2a117e03d85acc023c666af6c /sys-fs
parentfix for bug 480502 (diff)
downloadgentoo-2-1578d0acc457a858080a404e2cd3cce598de8980.tar.gz
gentoo-2-1578d0acc457a858080a404e2cd3cce598de8980.tar.bz2
gentoo-2-1578d0acc457a858080a404e2cd3cce598de8980.zip
dropped DOCS='' as it is not PMS-legal (bug 480892), reload hwdb if rebuilding or revbump only
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/eudev/ChangeLog7
-rw-r--r--sys-fs/eudev/eudev-1.2-r1.ebuild11
-rw-r--r--sys-fs/eudev/eudev-1.2.ebuild10
-rw-r--r--sys-fs/eudev/eudev-9999.ebuild15
4 files changed, 36 insertions, 7 deletions
diff --git a/sys-fs/eudev/ChangeLog b/sys-fs/eudev/ChangeLog
index d9cf3e9f46ef..5e05dd9c9af1 100644
--- a/sys-fs/eudev/ChangeLog
+++ b/sys-fs/eudev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/eudev
# Copyright 1999- Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.64 2013/08/12 13:26:20 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.65 2013/08/13 17:05:39 axs Exp $
+
+ 13 Aug 2013; Ian Stakenvicius <axs@gentoo.org> eudev-1.2-r1.ebuild,
+ eudev-1.2.ebuild, eudev-9999.ebuild:
+ dropped DOCS='' as it is not PMS-legal (bug 480892), reload hwdb if rebuilding
+ or revbump only
12 Aug 2013; Anthony G. Basile <blueness@gentoo.org> eudev-1.1.ebuild:
Stable ppc ppc64, bug #463910
diff --git a/sys-fs/eudev/eudev-1.2-r1.ebuild b/sys-fs/eudev/eudev-1.2-r1.ebuild
index b776187b3376..9187986a7fc1 100644
--- a/sys-fs/eudev/eudev-1.2-r1.ebuild
+++ b/sys-fs/eudev/eudev-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.2-r1.ebuild,v 1.4 2013/08/08 19:47:52 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.2-r1.ebuild,v 1.5 2013/08/13 17:05:39 axs Exp $
EAPI="5"
@@ -60,7 +60,6 @@ PDEPEND=">=virtual/udev-180
openrc? ( >=sys-fs/udev-init-scripts-18 )"
REQUIRED_USE="keymap? ( hwdb )"
-DOCS=""
pkg_pretend()
{
@@ -244,6 +243,14 @@ pkg_postinst()
if use hwdb && has_version 'sys-apps/hwids[udev]'; then
udevadm hwdb --update --root="${ROOT%/}"
+
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ # reload database after it has be rebuilt, but only if we are not upgrading
+ # also pass if we are -9999 since who knows what hwdb related changes there might be
+ if [[ ${REPLACING_VERSIONS%-r*} == ${PV} || -z ${REPLACING_VERSIONS} ]] && \
+ [[ ${ROOT%/} == "" ]] && [[ ${PV} != "9999" ]]; then
+ udevadm control --reload
+ fi
fi
ewarn
diff --git a/sys-fs/eudev/eudev-1.2.ebuild b/sys-fs/eudev/eudev-1.2.ebuild
index 83040ca8e747..4579dc20e022 100644
--- a/sys-fs/eudev/eudev-1.2.ebuild
+++ b/sys-fs/eudev/eudev-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.2.ebuild,v 1.3 2013/08/08 15:19:47 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.2.ebuild,v 1.4 2013/08/13 17:05:39 axs Exp $
EAPI="5"
@@ -207,6 +207,14 @@ pkg_postinst()
if use hwdb && has_version 'sys-apps/hwids[udev]'; then
udevadm hwdb --update --root="${ROOT%/}"
+
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ # reload database after it has be rebuilt, but only if we are not upgrading
+ # also pass if we are -9999 since who knows what hwdb related changes there might be
+ if [[ ${REPLACING_VERSIONS%-r*} == ${PV} || -z ${REPLACING_VERSIONS} ]] && \
+ [[ ${ROOT%/} == "" ]] && [[ ${PV} != "9999" ]]; then
+ udevadm control --reload
+ fi
fi
ewarn
diff --git a/sys-fs/eudev/eudev-9999.ebuild b/sys-fs/eudev/eudev-9999.ebuild
index c35ca9350661..bbc50eb304a0 100644
--- a/sys-fs/eudev/eudev-9999.ebuild
+++ b/sys-fs/eudev/eudev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-9999.ebuild,v 1.37 2013/08/08 19:47:52 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-9999.ebuild,v 1.38 2013/08/13 17:05:39 axs Exp $
EAPI="5"
@@ -60,7 +60,6 @@ PDEPEND=">=virtual/udev-180
openrc? ( >=sys-fs/udev-init-scripts-18 )"
REQUIRED_USE="keymap? ( hwdb )"
-DOCS=""
pkg_pretend()
{
@@ -244,7 +243,17 @@ pkg_postinst()
einfo "Removed unneeded file 64-device-mapper.rules"
fi
- use hwdb && udevadm hwdb --update --root="${ROOT%/}"
+ if use hwdb && has_version 'sys-apps/hwids[udev]'; then
+ udevadm hwdb --update --root="${ROOT%/}"
+
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ # reload database after it has be rebuilt, but only if we are not upgrading
+ # also pass if we are -9999 since who knows what hwdb related changes there might be
+ if [[ ${REPLACING_VERSIONS%-r*} == ${PV} || -z ${REPLACING_VERSIONS} ]] && \
+ [[ ${ROOT%/} == "" ]] && [[ ${PV} != "9999" ]]; then
+ udevadm control --reload
+ fi
+ fi
ewarn
ewarn "You need to restart eudev as soon as possible to make the"