summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-04-26 19:40:36 +0000
committerPeter Volkov <pva@gentoo.org>2010-04-26 19:40:36 +0000
commit1356d39e05c5aafab8e44e0244d217e3a71cdfee (patch)
treeddd179648e2760320756f583b3db564014bf9bb1 /sys-fs
parentAdd EAPI-3/Prefix support, bug #312531 (diff)
downloadgentoo-2-1356d39e05c5aafab8e44e0244d217e3a71cdfee.tar.gz
gentoo-2-1356d39e05c5aafab8e44e0244d217e3a71cdfee.tar.bz2
gentoo-2-1356d39e05c5aafab8e44e0244d217e3a71cdfee.zip
Fixed build issue with 2.6.34 kernels, bug #317119, thank Rion for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/vhba/ChangeLog6
-rw-r--r--sys-fs/vhba/files/vhba-1.2.1-kernel-2.6.34.patch15
-rw-r--r--sys-fs/vhba/vhba-1.2.1.ebuild5
3 files changed, 23 insertions, 3 deletions
diff --git a/sys-fs/vhba/ChangeLog b/sys-fs/vhba/ChangeLog
index ff9e01d85311..29f7388acb57 100644
--- a/sys-fs/vhba/ChangeLog
+++ b/sys-fs/vhba/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/vhba
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.16 2010/03/05 14:19:34 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.17 2010/04/26 19:40:36 pva Exp $
+
+ 26 Apr 2010; Peter Volkov <pva@gentoo.org>
+ +files/vhba-1.2.1-kernel-2.6.34.patch:
+ Fixed build issue with 2.6.34 kernels, bug #317119, thank Rion for report.
05 Mar 2010; Peter Volkov <pva@gentoo.org> vhba-1.2.1.ebuild,
+files/vhba-1.2.1-kernel-2.6.33.patch:
diff --git a/sys-fs/vhba/files/vhba-1.2.1-kernel-2.6.34.patch b/sys-fs/vhba/files/vhba-1.2.1-kernel-2.6.34.patch
new file mode 100644
index 000000000000..1ec5112777c9
--- /dev/null
+++ b/sys-fs/vhba/files/vhba-1.2.1-kernel-2.6.34.patch
@@ -0,0 +1,15 @@
+http://cdemu.svn.sourceforge.net/viewvc/cdemu/trunk/vhba-module/vhba.c?r1=678&r2=677&pathrev=678
+https://sourceforge.net/tracker/?func=detail&atid=603423&aid=2992162&group_id=93175
+http://bugs.gentoo.org/show_bug.cgi?id=317119
+
+--- vhba.c 2010-04-26 19:35:04 +0000
++++ vhba.c 2010-04-26 19:35:20 +0000
+@@ -26,6 +26,7 @@
+ #include <linux/platform_device.h>
+ #include <linux/miscdevice.h>
+ #include <linux/poll.h>
++#include <linux/slab.h>
+ #include <asm/uaccess.h>
+ #include <scsi/scsi.h>
+ #include <scsi/scsi_host.h>
+
diff --git a/sys-fs/vhba/vhba-1.2.1.ebuild b/sys-fs/vhba/vhba-1.2.1.ebuild
index 7c6dea58b592..23bd65bcd376 100644
--- a/sys-fs/vhba/vhba-1.2.1.ebuild
+++ b/sys-fs/vhba/vhba-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-1.2.1.ebuild,v 1.6 2010/03/05 14:19:34 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-1.2.1.ebuild,v 1.7 2010/04/26 19:40:36 pva Exp $
EAPI="2"
@@ -33,7 +33,8 @@ src_prepare() {
epatch \
"${FILESDIR}/${PV}-parallel_build.patch" \
"${FILESDIR}/${PV}-kerneldir.patch" \
- "${FILESDIR}/${P}-kernel-2.6.33.patch"
+ "${FILESDIR}/${P}-kernel-2.6.33.patch" \
+ "${FILESDIR}/${P}-kernel-2.6.34.patch"
}
src_install() {