summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-21 14:30:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-21 14:30:19 +0000
commit1008b79dad1a16f2c0aa4416905fb85634b157c5 (patch)
tree3e1e634b1033be6f85bb69e8a2ab0e0bf57a2733 /sys-fs
parentalpha/arm/ia64/s390/sh/sparc/x86 stable wrt #296686 (diff)
downloadgentoo-2-1008b79dad1a16f2c0aa4416905fb85634b157c5.tar.gz
gentoo-2-1008b79dad1a16f2c0aa4416905fb85634b157c5.tar.bz2
gentoo-2-1008b79dad1a16f2c0aa4416905fb85634b157c5.zip
Fix building with -Wl,--as-needed wrt #277675 by Kacper Kowalik.
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/chironfs/ChangeLog6
-rw-r--r--sys-fs/chironfs/chironfs-1.1.1.ebuild19
-rw-r--r--sys-fs/chironfs/files/chironfs-1.1.1-asneeded.patch24
3 files changed, 43 insertions, 6 deletions
diff --git a/sys-fs/chironfs/ChangeLog b/sys-fs/chironfs/ChangeLog
index 626db618a93f..5de3f7a4c2e7 100644
--- a/sys-fs/chironfs/ChangeLog
+++ b/sys-fs/chironfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/chironfs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/chironfs/ChangeLog,v 1.2 2009/06/24 07:42:53 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/chironfs/ChangeLog,v 1.3 2009/12/21 14:30:19 ssuominen Exp $
+
+ 21 Dec 2009; Samuli Suominen <ssuominen@gentoo.org> chironfs-1.1.1.ebuild,
+ +files/chironfs-1.1.1-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #277675 by Kacper Kowalik.
24 Jun 2009; Daniel Black <dragonheart@gentoo.org> chironfs-1.0.0.ebuild,
chironfs-1.1.1.ebuild:
diff --git a/sys-fs/chironfs/chironfs-1.1.1.ebuild b/sys-fs/chironfs/chironfs-1.1.1.ebuild
index 78992e30caba..89b681d33ef4 100644
--- a/sys-fs/chironfs/chironfs-1.1.1.ebuild
+++ b/sys-fs/chironfs/chironfs-1.1.1.ebuild
@@ -1,18 +1,27 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/chironfs/chironfs-1.1.1.ebuild,v 1.2 2009/06/24 07:42:53 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/chironfs/chironfs-1.1.1.ebuild,v 1.3 2009/12/21 14:30:19 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
DESCRIPTION="Chiron FS - A FUSE based replication filesystem"
-SRC_URI="http://chironfs.googlecode.com/files/${P}.tar.gz"
HOMEPAGE="http://www.furquim.org/chironfs/"
+SRC_URI="http://chironfs.googlecode.com/files/${P}.tar.gz"
+
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64"
SLOT="0"
-RDEPEND=""
+KEYWORDS="~amd64 ~x86"
IUSE=""
+
DEPEND="sys-fs/fuse"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
src_install() {
- emake DESTDIR="${D}" install || die 'install failure'
+ emake DESTDIR="${D}" install || die
mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${P}
}
diff --git a/sys-fs/chironfs/files/chironfs-1.1.1-asneeded.patch b/sys-fs/chironfs/files/chironfs-1.1.1-asneeded.patch
new file mode 100644
index 000000000000..5e4788952c90
--- /dev/null
+++ b/sys-fs/chironfs/files/chironfs-1.1.1-asneeded.patch
@@ -0,0 +1,24 @@
+--- chironfs-1.1.1.orig/src/Makefile.am 2008-06-21 07:39:46.000000000 +0200
++++ chironfs-1.1.1/src/Makefile.am 2009-10-23 21:42:55.511789469 +0200
+@@ -4,7 +4,9 @@
+ chironfs_SOURCES = chironfs.c chiron-conf.c chirondbg.c chironfs.h chiron-types.h chironfn.c chironfn.h chironoper.h
+ chirctl_SOURCES = chirctl.c chirondbg.c chirctl.h chironfs.h chiron-types.h chironfn.c chironfn.h
+ if FREEBSD
+-OSLD=-pthread -liconv -lfuse -L/usr/local/lib
++OSLD=-liconv -lfuse -L/usr/local/lib
++chironfs_LDFLAGS = -pthread
++chirctl_LDFLAGS = -pthread
+ else
+ if NETBSD
+ OSLD=-lrefuse
+@@ -12,7 +14,8 @@
+ OSLD=-lfuse
+ endif
+ endif
+-chironfs_LDFLAGS = -lm ${OSLD}
++chironfs_LDADD = -lm ${OSLD}
+ chironfs_OBJSS = chironfs.o chiron-conf.o chirondbg.o chironfn.o
+-chirctl_LDFLAGS = -lm ${OSLD}
++chirctl_LDADD = -lm ${OSLD}
+ chirctl_OBJSS = chirctl.o chirondbg.o chironfn.o
++