summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-01-31 22:51:44 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-01-31 22:51:44 +0000
commit0fe560e2f18fff83d00bfbfc69e3ba69bb4ed0de (patch)
treec97cf1297c84cc7775320cb1fb86c772b81a0cc8 /sys-fs
parentadded missing ~ in SRC_URI (diff)
downloadgentoo-2-0fe560e2f18fff83d00bfbfc69e3ba69bb4ed0de.tar.gz
gentoo-2-0fe560e2f18fff83d00bfbfc69e3ba69bb4ed0de.tar.bz2
gentoo-2-0fe560e2f18fff83d00bfbfc69e3ba69bb4ed0de.zip
Added kernel 2.4 support, bug#164754, thanks to f.mensik
(Portage version: 2.1.2-r5)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dazuko/ChangeLog5
-rw-r--r--sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index f1bf0e698c34..e4e2b95e6905 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/dazuko
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.19 2007/01/24 06:47:30 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.20 2007/01/31 22:51:44 alonbl Exp $
+
+ 31 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org> dazuko-2.3.3_pre1.ebuild:
+ Added kernel 2.4 support, bug#164754, thanks to f.mensik
24 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org> -dazuko-2.1.0.ebuild,
-dazuko-2.1.1.ebuild, -dazuko-2.2.0.ebuild, -dazuko-2.3.1.ebuild,
diff --git a/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild b/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild
index c75ed07ed55a..df3dc0e651b9 100644
--- a/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild
+++ b/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild,v 1.1 2007/01/19 19:31:09 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild,v 1.2 2007/01/31 22:51:44 alonbl Exp $
inherit linux-mod toolchain-funcs flag-o-matic
@@ -17,9 +17,13 @@ RDEPEND=${DEPEND}
S="${WORKDIR}/${MY_P}"
# kernel settings
-CONFIG_CHECK="SECURITY_CAPABILITIES"
+if [ "${KERNEL}" = "linux" ] && kernel_is le 2 4; then
+ BUILD_TARGETS="all"
+else
+ CONFIG_CHECK="SECURITY_CAPABILITIES"
+ BUILD_TARGETS="dummy_rule"
+fi
MODULE_NAMES="dazuko(misc:)"
-BUILD_TARGETS="dummy_rule"
pkg_setup() {
[ "${KERNEL}" = "linux" ] && linux-mod_pkg_setup