summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-07-24 06:29:22 +0000
committerMike Frysinger <vapier@gentoo.org>2010-07-24 06:29:22 +0000
commit0ef4a25691e36989eb00543301ffb565f50c0b90 (patch)
treebf03aa6e2d905307acfd8050eacb6d80f4144fa3 /sys-fs
parentold (diff)
downloadgentoo-2-0ef4a25691e36989eb00543301ffb565f50c0b90.tar.gz
gentoo-2-0ef4a25691e36989eb00543301ffb565f50c0b90.tar.bz2
gentoo-2-0ef4a25691e36989eb00543301ffb565f50c0b90.zip
Add fix from upstream for running utils on an ntfs mount #329445 by Victor Gaydov.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfsprogs/ChangeLog11
-rw-r--r--sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-erange.patch33
-rw-r--r--sys-fs/ntfsprogs/ntfsprogs-2.0.0-r2.ebuild63
3 files changed, 105 insertions, 2 deletions
diff --git a/sys-fs/ntfsprogs/ChangeLog b/sys-fs/ntfsprogs/ChangeLog
index b9cdd3feee9c..d7e087f9aba2 100644
--- a/sys-fs/ntfsprogs/ChangeLog
+++ b/sys-fs/ntfsprogs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/ntfsprogs
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ChangeLog,v 1.70 2009/10/18 11:35:26 volkmar Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ChangeLog,v 1.71 2010/07/24 06:29:22 vapier Exp $
+
+*ntfsprogs-2.0.0-r2 (24 Jul 2010)
+
+ 24 Jul 2010; Mike Frysinger <vapier@gentoo.org>
+ +ntfsprogs-2.0.0-r2.ebuild, +files/ntfsprogs-2.0.0-erange.patch:
+ Add fix from upstream for running utils on an ntfs mount #329445 by Victor
+ Gaydov.
18 Oct 2009; Mounir Lamouri <volkmar@gentoo.org>
ntfsprogs-2.0.0-r1.ebuild:
diff --git a/sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-erange.patch b/sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-erange.patch
new file mode 100644
index 000000000000..457c86b32539
--- /dev/null
+++ b/sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-erange.patch
@@ -0,0 +1,33 @@
+http://thread.gmane.org/gmane.linux.file-systems.ntfs.devel/3678
+https://bugs.gentoo.org/329445
+
+diff --git a/libntfs/attrib.c b/libntfs/attrib.c
+index a1fe954..c628d9d 100644
+--- a/libntfs/attrib.c
++++ b/libntfs/attrib.c
+@@ -550,8 +550,10 @@ int ntfs_attr_map_runlist_range(ntfs_attr *na, VCN from_vcn, VCN to_vcn)
+ (long long)from_vcn, (long long)to_vcn);
+
+ /* Map extent with @from_vcn. */
+- if (ntfs_attr_map_runlist(na, from_vcn))
+- goto err_out;
++ if (ntfs_attr_map_runlist(na, from_vcn)) {
++ if (errno != ERANGE)
++ goto err_out;
++ }
+
+ for (rl = na->rl; rl->vcn <= to_vcn;) {
+ /* Skip not interesting to us runs. */
+@@ -4924,8 +4926,10 @@ static int ntfs_non_resident_attr_expand(ntfs_attr *na, const s64 newsize,
+ /* Map required part of runlist. */
+ if (ntfs_attr_map_runlist(na, na->allocated_size >>
+ vol->cluster_size_bits)) {
+- ntfs_log_error("Failed to map runlist.\n");
+- return -1;
++ if (errno != ERANGE) {
++ ntfs_log_error("Failed to map runlist.\n");
++ return -1;
++ }
+ }
+
+ /*
diff --git a/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r2.ebuild b/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r2.ebuild
new file mode 100644
index 000000000000..9a3a6fc89e1a
--- /dev/null
+++ b/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r2.ebuild,v 1.1 2010/07/24 06:29:22 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="User tools for NTFS filesystems"
+HOMEPAGE="http://www.linux-ntfs.org/"
+SRC_URI="mirror://sourceforge/linux-ntfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt debug fuse gnome minimal"
+
+RDEPEND="dev-libs/libconfig
+ fuse? ( >=sys-fs/fuse-2.7.0 )
+ crypt? ( >=dev-libs/libgcrypt-1.2.0 >=net-libs/gnutls-1.2.8 )
+ gnome? (
+ >=dev-libs/glib-2.0
+ >=gnome-base/gnome-vfs-2.0
+ )"
+DEPEND="${RDEPEND}
+ !=sys-fs/ntfs3g-0.1_beta20070714
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}"/${P}-extras.patch #218601
+ epatch "${FILESDIR}"/${P}-gnutls-2.8.patch
+ epatch "${FILESDIR}"/${P}-erange.patch #329445
+ use minimal || sed -i 's:^EXTRA_PROGRAMS =:bin_PROGRAMS +=:' ntfsprogs/Makefile.in #218601
+ sed -i \
+ -e '/CFLAGS/s:-ggdb3\>::' \
+ -e '/CFLAGS/s:-O0\>::' \
+ configure || die
+}
+
+src_compile() {
+ econf \
+ $(use_enable crypt crypto) \
+ $(use_enable debug) \
+ $(use_enable fuse ntfsmount) \
+ $(use_enable gnome gnome-vfs) \
+ || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ mv "${D}"/sbin/mkfs.ntfs "${D}"/usr/sbin/ || die
+ if ! use minimal ; then
+ mv "${D}"/usr/bin/ntfsck "${D}"/sbin/ || die
+ dosym ntfsck /sbin/fsck.ntfs
+ fi
+ if use fuse ; then
+ mv "${D}"/sbin/mount.{fuse.ntfs,ntfs-fuse} "${D}"/usr/bin/ || die
+ fi
+
+ dodoc AUTHORS CREDITS ChangeLog NEWS README TODO.* \
+ doc/attribute_definitions doc/*.txt doc/tunable_settings
+}