summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-09-10 16:42:57 +0000
committerThomas Sachau <tommy@gentoo.org>2009-09-10 16:42:57 +0000
commit0ee263bcacfdd4f2c7e6a2be498369efd81d3bfd (patch)
tree91ca33a81a9b0ae51147d5b2f8cc3edd6d90e0e9 /sys-fs
parentFix xz-utils vs. lzma-utils deps. (diff)
downloadgentoo-2-0ee263bcacfdd4f2c7e6a2be498369efd81d3bfd.tar.gz
gentoo-2-0ee263bcacfdd4f2c7e6a2be498369efd81d3bfd.tar.bz2
gentoo-2-0ee263bcacfdd4f2c7e6a2be498369efd81d3bfd.zip
Add missing patches
(Portage version: 2.2_rc40-r1/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dmraid/ChangeLog9
-rw-r--r--sys-fs/dmraid/files/dmraid-1.0.0_rc15-devsk-isw.patch24
-rw-r--r--sys-fs/dmraid/files/dmraid-1.0.0_rc15-undo-p-rename.patch13
3 files changed, 43 insertions, 3 deletions
diff --git a/sys-fs/dmraid/ChangeLog b/sys-fs/dmraid/ChangeLog
index 1e4fc393fe26..0f308b6e0042 100644
--- a/sys-fs/dmraid/ChangeLog
+++ b/sys-fs/dmraid/ChangeLog
@@ -1,11 +1,14 @@
# ChangeLog for sys-fs/dmraid
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.19 2009/09/09 21:02:11 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.20 2009/09/10 16:42:57 tommy Exp $
- 08 Sep 2009; Ian Stakenvicius <ian@aerobiology.ca>
- dmraid-1.0.0_rc14.ebuild, +dmraid-1.0.0_rc15-r1.ebuild,
+ 10 Sep 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+files/dmraid-1.0.0_rc15-devsk-isw.patch,
+files/dmraid-1.0.0_rc15-undo-p-rename.patch:
+ Add missing patches
+
+ 08 Sep 2009; Ian Stakenvicius <ian@aerobiology.ca>
+ dmraid-1.0.0_rc14.ebuild, +dmraid-1.0.0_rc15-r1.ebuild:
Updated SRC_URI for rc14, bumped rc15 to -r1 (for ~ppc) to apply patches to
fix bug #275566 and bug #275451
diff --git a/sys-fs/dmraid/files/dmraid-1.0.0_rc15-devsk-isw.patch b/sys-fs/dmraid/files/dmraid-1.0.0_rc15-devsk-isw.patch
new file mode 100644
index 000000000000..1ce8834ebadd
--- /dev/null
+++ b/sys-fs/dmraid/files/dmraid-1.0.0_rc15-devsk-isw.patch
@@ -0,0 +1,24 @@
+--- ./lib/device/scsi.c.org 2009-06-25 15:22:26.605895909 -0700
++++ ./lib/device/scsi.c 2009-06-25 15:56:39.784749181 -0700
+@@ -110,7 +110,9 @@
+ }
+
+ ret = ret &&
+- (di->serial = dbg_strdup((char *) &response[p->start + 1]));
++ (di->serial = dbg_strdup(remove_white_space
++ (lc, (char *)&response[p->start + 1],
++ MAX_RESPONSE_LEN)));
+ }
+
+ dbg_free(response);
+--- ./lib/metadata/metadata.c.org 2009-06-25 17:32:19.856309659 -0700
++++ ./lib/metadata/metadata.c 2009-06-25 17:32:35.502920755 -0700
+@@ -839,7 +839,7 @@
+ */
+ if (T_GROUP(rs)) {
+ _discover_partitions(lc, &rs->sets);
+- return;
++ continue;
+ }
+
+ /*
diff --git a/sys-fs/dmraid/files/dmraid-1.0.0_rc15-undo-p-rename.patch b/sys-fs/dmraid/files/dmraid-1.0.0_rc15-undo-p-rename.patch
new file mode 100644
index 000000000000..6636b0563086
--- /dev/null
+++ b/sys-fs/dmraid/files/dmraid-1.0.0_rc15-undo-p-rename.patch
@@ -0,0 +1,13 @@
+Author: Giuseppe Iuculano <giuseppe@iuculano.it>
+Description: Removed "p" from device name. A proper upgrade script is needed before using it.
+--- a/1.0.0.rc15/lib/format/partition/dos.c
++++ b/1.0.0.rc15/lib/format/partition/dos.c
+@@ -31,7 +31,7 @@ _name(struct lib_context *lc, struct rai
+ {
+ const char *base = get_basename(lc, rd->di->path);
+
+- return type ? snprintf(str, len, "%s%s%u", base, OPT_STR_PARTCHAR(lc),
++ return type ? snprintf(str, len, "%s%u", base,
+ partition) : snprintf(str, len, "%s", base);
+ }
+