summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-21 08:39:21 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-21 08:39:21 +0000
commit0d1f4fee982f6739b7018eb28e6b5900cbdb9e9e (patch)
treeddb31b834e5df7a6e3fd4791be039a0e7ca1d5fe /sys-fs
parentAdd more linker flags #461976 (diff)
downloadgentoo-2-0d1f4fee982f6739b7018eb28e6b5900cbdb9e9e.tar.gz
gentoo-2-0d1f4fee982f6739b7018eb28e6b5900cbdb9e9e.tar.bz2
gentoo-2-0d1f4fee982f6739b7018eb28e6b5900cbdb9e9e.zip
sys-fs/aufs3: Fix kernel patching, thanks likewhoa for the patch
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs3/ChangeLog5
-rw-r--r--sys-fs/aufs3/aufs3-3_p20130318.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/sys-fs/aufs3/ChangeLog b/sys-fs/aufs3/ChangeLog
index ebf464d7d3fc..7a5623e8e6e3 100644
--- a/sys-fs/aufs3/ChangeLog
+++ b/sys-fs/aufs3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/aufs3
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.52 2013/03/15 09:36:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.53 2013/03/21 08:39:21 jlec Exp $
+
+ 21 Mar 2013; Justin Lecher <jlec@gentoo.org> aufs3-3_p20130318.ebuild:
+ Fix kernel patching, thanks likewhoa for the patch
*aufs3-3_p20130318 (15 Mar 2013)
diff --git a/sys-fs/aufs3/aufs3-3_p20130318.ebuild b/sys-fs/aufs3/aufs3-3_p20130318.ebuild
index 3c11856f8731..6725ae028579 100644
--- a/sys-fs/aufs3/aufs3-3_p20130318.ebuild
+++ b/sys-fs/aufs3/aufs3-3_p20130318.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20130318.ebuild,v 1.1 2013/03/15 09:36:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20130318.ebuild,v 1.2 2013/03/21 08:39:21 jlec Exp $
EAPI=5
@@ -76,8 +76,8 @@ pkg_setup() {
if use kernel-patch; then
cd ${KV_DIR}
ewarn "Patching your kernel..."
- patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${T}"/${P}/${PN}-standalone/${PN}-standalone-base-combined.patch >/dev/null
- epatch "${T}"/${P}/${PN}-standalone/${PN}-standalone-base-combined.patch
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${T}"/${PN}-standalone/${PN}-standalone-base-combined.patch >/dev/null
+ epatch "${T}"/${PN}-standalone/${PN}-standalone-base-combined.patch
ewarn "You need to compile your kernel with the applied patch"
ewarn "to be able to load and use the aufs kernel module"
else
@@ -142,7 +142,7 @@ src_install() {
use doc && doins -r Documentation
- use kernel-patch || doins "${T}"/${P}/${PN}-standalone/${PN}-standalone-base-combined.patch
+ use kernel-patch || doins "${T}"/${PN}-standalone/${PN}-standalone-base-combined.patch
dodoc Documentation/filesystems/aufs/README
}