summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-06-03 21:25:56 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-06-03 21:25:56 +0000
commitd6c44d969f1016fa78c8f9988239e792c2cb488f (patch)
tree664ced89531f324de02b963e5a4894bbc9ba1610 /sys-fs/xfsprogs
parentVersion bumps, removed old, added myself as maintainer. (diff)
downloadgentoo-2-d6c44d969f1016fa78c8f9988239e792c2cb488f.tar.gz
gentoo-2-d6c44d969f1016fa78c8f9988239e792c2cb488f.tar.bz2
gentoo-2-d6c44d969f1016fa78c8f9988239e792c2cb488f.zip
Version bump (bug #311109), added deps for readline/libedit, added static-libs use flag, changed dependency from e2fsprogs to util-linux, thanks to Hendrik Leppkes for the updated patch.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/xfsprogs')
-rw-r--r--sys-fs/xfsprogs/ChangeLog10
-rw-r--r--sys-fs/xfsprogs/files/xfsprogs-3.1.1-sharedlibs.patch112
-rw-r--r--sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild115
3 files changed, 236 insertions, 1 deletions
diff --git a/sys-fs/xfsprogs/ChangeLog b/sys-fs/xfsprogs/ChangeLog
index e0106b378f88..a159016241a0 100644
--- a/sys-fs/xfsprogs/ChangeLog
+++ b/sys-fs/xfsprogs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/xfsprogs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.123 2010/05/11 20:50:42 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.124 2010/06/03 21:25:55 dev-zero Exp $
+
+*xfsprogs-3.1.2 (03 Jun 2010)
+
+ 03 Jun 2010; Tiziano Müller <dev-zero@gentoo.org>
+ +files/xfsprogs-3.1.1-sharedlibs.patch, +xfsprogs-3.1.2.ebuild:
+ Version bump (bug #311109), added deps for readline/libedit, added
+ static-libs use flag, changed dependency from e2fsprogs to util-linux,
+ thanks to Hendrik Leppkes for the updated patch.
11 May 2010; Joseph Jezak <josejx@gentoo.org> xfsprogs-3.0.3.ebuild:
Marked ppc/ppc64 stable for bug #311381.
diff --git a/sys-fs/xfsprogs/files/xfsprogs-3.1.1-sharedlibs.patch b/sys-fs/xfsprogs/files/xfsprogs-3.1.1-sharedlibs.patch
new file mode 100644
index 000000000000..4e16dd9f477a
--- /dev/null
+++ b/sys-fs/xfsprogs/files/xfsprogs-3.1.1-sharedlibs.patch
@@ -0,0 +1,112 @@
+diff --git a/Makefile b/Makefile
+index 83d1b0a..3e4217d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -66,6 +66,7 @@ io: libxcmd libhandle
+ mkfs: libxfs
+ quota: libxcmd
+ repair: libxfs libxlog
++libxlog: libxfs
+
+ ifneq ($(ENABLE_BLKID), yes)
+ mkfs: libdisk
+diff --git a/include/buildmacros b/include/buildmacros
+index 62babca..0a3c5ba 100644
+--- a/include/buildmacros
++++ b/include/buildmacros
+@@ -71,17 +71,9 @@ endif
+ # /usr/lib.
+ ifeq ($(ENABLE_SHARED),yes)
+ INSTALL_LTLIB_DEV = \
+- cd $(TOPDIR)/$(LIBNAME)/.libs; \
+- ../$(INSTALL) -m 755 -d $(PKG_LIB_DIR); \
+- ../$(INSTALL) -m 644 -T old_lib $(LIBNAME).lai $(PKG_LIB_DIR); \
+- ../$(INSTALL) -m 644 $(LIBNAME).lai $(PKG_LIB_DIR)/$(LIBNAME).la ; \
+- ../$(INSTALL) -m 755 -d $(PKG_ROOT_LIB_DIR); \
+- ../$(INSTALL) -T so_base $(LIBNAME).lai $(PKG_ROOT_LIB_DIR); \
+- if test "x$(PKG_LIB_DIR)" != "x$(PKG_ROOT_LIB_DIR)" ; then \
+- ../$(INSTALL) -S $(PKG_LIB_DIR)/$(LIBNAME).a $(PKG_ROOT_LIB_DIR)/$(LIBNAME).a; \
+- ../$(INSTALL) -S $(PKG_LIB_DIR)/$(LIBNAME).la $(PKG_ROOT_LIB_DIR)/$(LIBNAME).la; \
+- ../$(INSTALL) -S $(PKG_ROOT_LIB_DIR)/$(LIBNAME).so $(PKG_LIB_DIR)/$(LIBNAME).so; \
+- fi
++ cd $(TOPDIR)/$(LIBNAME); \
++ $(INSTALL) -m 755 -d $(PKG_LIB_DIR); \
++ env -uDIST_ROOT $(LTINSTALL) $(TOPDIR)/$(LIBNAME)/$(LIBNAME).la $(DIST_ROOT)$(PKG_LIB_DIR)/$(LIBNAME).la
+ else
+ INSTALL_LTLIB_DEV = $(INSTALL_LTLIB_STATIC)
+ endif
+diff --git a/libdisk/Makefile b/libdisk/Makefile
+index 32416a5..7a144c0 100644
+--- a/libdisk/Makefile
++++ b/libdisk/Makefile
+@@ -25,8 +25,10 @@ default: ltdepend $(LTLIBRARY)
+ include $(BUILDRULES)
+
+ install: default
++ $(INSTALL_LTLIB)
+
+ install-dev: default
++ $(INSTALL_LTLIB_DEV)
+
+ install-qa: install-dev
+
+diff --git a/libxcmd/Makefile b/libxcmd/Makefile
+index 60b6f9e..38e53a6 100644
+--- a/libxcmd/Makefile
++++ b/libxcmd/Makefile
+@@ -32,6 +32,12 @@ default: ltdepend $(LTLIBRARY)
+
+ include $(BUILDRULES)
+
+-install install-dev install-qa: default
++install: default
++ $(INSTALL_LTLIB)
++
++install-dev: default
++ $(INSTALL_LTLIB_DEV)
++
++install-qa: default
+
+ -include .dep
+diff --git a/libxfs/Makefile b/libxfs/Makefile
+index 8f80cdc..fcba668 100644
+--- a/libxfs/Makefile
++++ b/libxfs/Makefile
+@@ -41,8 +41,10 @@ default: ltdepend $(LTLIBRARY)
+ include $(BUILDRULES)
+
+ install: default
++ $(INSTALL_LTLIB)
+
+ install-dev: default
++ $(INSTALL_LTLIB_DEV)
+
+ install-qa: default
+
+diff --git a/libxlog/Makefile b/libxlog/Makefile
+index 7358fb1..666ea77 100644
+--- a/libxlog/Makefile
++++ b/libxlog/Makefile
+@@ -12,6 +12,8 @@ LT_AGE = 0
+
+ CFILES = xfs_log_recover.c util.c
+
++LTLIBS = $(LIBUUID) $(LIBXFS)
++
+ # don't want to link xfs_repair with a debug libxlog.
+ DEBUG = -DNDEBUG
+
+@@ -19,6 +21,12 @@ default: ltdepend $(LTLIBRARY)
+
+ include $(BUILDRULES)
+
+-install install-dev install-qa: default
++install: default
++ $(INSTALL_LTLIB)
++
++install-dev: default
++ $(INSTALL_LTLIB_DEV)
++
++install-qa: default
+
+ -include .dep
diff --git a/sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild b/sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild
new file mode 100644
index 000000000000..d824d7f74a89
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild,v 1.1 2010/06/03 21:25:55 dev-zero Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="libedit nls readline static static-libs"
+
+RDEPEND=">=sys-apps/util-linux-2.17.2
+ !<sys-fs/xfsdump-3
+ readline? (
+ !libedit? ( sys-libs/readline
+ static? ( sys-libs/ncurses )
+ )
+ )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ if use readline && use libedit ; then
+ ewarn "You enabled both readline and libedit support but only one can be supported"
+ ewarn "Using libedit. Please disable the libedit USE flag if you want readline."
+ fi
+
+ if use static && use !static-libs ; then
+ ewarn "Can't build a static variant of the executables without static-libs."
+ ewarn "Static libs will also be built."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.1.1-sharedlibs.patch"
+
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die "sed include/builddefs.in failed"
+ sed -i \
+ -e '1iLLDFLAGS = -static' \
+ {estimate,fsr}/Makefile || die "sed failed"
+
+ sed -i \
+ -e "/LLDFLAGS/s:-static:$(use static && echo -all-static):" \
+ $(find -name Makefile) || die "sed failed"
+
+ # TODO: write a patch for configure.in to use pkg-config for the uuid-part
+ if use static && use readline ; then
+ sed -i \
+ -e 's|-lreadline|\0 -lncurses|' \
+ -e 's|-lblkid|\0 -luuid|' \
+ configure || die "sed failed"
+ fi
+}
+
+src_configure() {
+ export DEBUG="-DNDEBUG"
+ export OPTIMIZER="${CFLAGS}"
+ unset PLATFORM # if set in user env, this breaks configure
+
+ local myconf=""
+
+ if use libedit ; then
+ myconf="--disable-readline --enable-editline"
+ elif use readline ; then
+ myconf="--enable-readline --disable-editline"
+ else
+ myconf="--disable-readline --disable-editline"
+ fi
+
+ if use static || use static-libs ; then
+ myconf="${myconf} --enable-static"
+ else
+ myconf="${myconf} --disable-static"
+ fi
+
+ econf \
+ --bindir=/usr/bin \
+ --libexecdir=/usr/$(get_libdir) \
+ $(use_enable static-libs static) \
+ $(use_enable nls gettext) \
+ ${myconf}
+
+ MAKEOPTS="${MAKEOPTS} V=1"
+}
+
+src_install() {
+ # TODO: there is a seldomly triggered parallel install problem where
+ # libxfs.so doesn't get installed before rdeps causing the relink to fail
+ emake -j1 DIST_ROOT="${D}" install install-dev || die "emake install failed"
+
+ dosym libxfs.so.0 /$(get_libdir)/libxfs.so
+ dosym libxlog.so.0 /$(get_libdir)/libxlog.so
+
+ # removing duplicated libraries
+ rm "${D}"/lib*/lib{handle,xcmd}.* "${D}"/usr/lib*/lib{xfs,xlog}.so*
+
+ # removing unnecessary .la files if not needed
+ ( use static || use static-libs ) || rm -rf "${D}"/usr/lib*/*.la
+
+ # handle is for xfsdump, the rest for xfsprogs
+ gen_usr_ldscript libxfs.so libxlog.so
+ prepalldocs
+}
+