summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-08 00:36:02 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-08 00:36:02 +0000
commit1c615d0e99a60ef0cf616e46b13ab76dbe91ef4c (patch)
tree62eb48e8a5834843fa12c61b6c2a4687fef3b288 /sys-fs/xfsprogs
parentStable on x86 wrt security bug #66357 (Manifest recommit) (diff)
downloadgentoo-2-1c615d0e99a60ef0cf616e46b13ab76dbe91ef4c.tar.gz
gentoo-2-1c615d0e99a60ef0cf616e46b13ab76dbe91ef4c.tar.bz2
gentoo-2-1c615d0e99a60ef0cf616e46b13ab76dbe91ef4c.zip
some uclibc loving and a configure fix #65735
Diffstat (limited to 'sys-fs/xfsprogs')
-rw-r--r--sys-fs/xfsprogs/ChangeLog11
-rw-r--r--sys-fs/xfsprogs/files/2.6.13-configure.patch10
-rw-r--r--sys-fs/xfsprogs/files/2.6.13-uclibc-mincore.patch52
-rw-r--r--sys-fs/xfsprogs/xfsprogs-2.6.13.ebuild14
4 files changed, 83 insertions, 4 deletions
diff --git a/sys-fs/xfsprogs/ChangeLog b/sys-fs/xfsprogs/ChangeLog
index bda6fab6dff7..22664647b1d9 100644
--- a/sys-fs/xfsprogs/ChangeLog
+++ b/sys-fs/xfsprogs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-fs/xfsprogs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.23 2004/09/22 03:36:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.24 2004/10/08 00:36:02 vapier Exp $
+
+ 07 Oct 2004; <solar@gentoo.org> +files/2.6.13-uclibc-mincore.patch,
+ xfsprogs-2.6.13.ebuild:
+ mincore() does not appear to be part of POSIX or the Single Unix
+ Specification. So we patch it out for uclibc builds.
+
+ 07 Oct 2004; Mike Frysinger <vapier@gentoo.org> xfsprogs-2.6.13.ebuild,
+ +files/2.6.13-configure.patch:
+ Add patch to fix configure mis-detection #65735 by Marc Bevand.
21 Sep 2004; Mike Frysinger <vapier@gentoo.org> xfsprogs-2.6.13.ebuild:
Make nls support optional #64862 by Aaron GIpson.
diff --git a/sys-fs/xfsprogs/files/2.6.13-configure.patch b/sys-fs/xfsprogs/files/2.6.13-configure.patch
new file mode 100644
index 000000000000..d05fea227dd0
--- /dev/null
+++ b/sys-fs/xfsprogs/files/2.6.13-configure.patch
@@ -0,0 +1,10 @@
+--- configure.in.orig 2004-09-29 00:20:24.361474856 +0200
++++ configure.in 2004-09-29 00:20:37.668451888 +0200
+@@ -1,4 +1,7 @@
+ AC_INIT(include/libxfs.h)
++
++AC_PROG_CC
++
+ AC_CONFIG_HEADER(include/platform_defs.h)
+
+ AC_ARG_ENABLE(shared,
diff --git a/sys-fs/xfsprogs/files/2.6.13-uclibc-mincore.patch b/sys-fs/xfsprogs/files/2.6.13-uclibc-mincore.patch
new file mode 100644
index 000000000000..e299870c40e7
--- /dev/null
+++ b/sys-fs/xfsprogs/files/2.6.13-uclibc-mincore.patch
@@ -0,0 +1,52 @@
+--- xfsprogs-orig/io/mmap.c Fri Apr 30 20:34:08 2004
++++ xfsprogs-2.6.13/io/mmap.c Sat Sep 11 15:34:43 2004
+@@ -44,7 +44,9 @@
+ static cmdinfo_t munmap_cmd;
+ static cmdinfo_t mwrite_cmd;
+ static cmdinfo_t madvise_cmd;
++#ifndef __UCLIBC__
+ static cmdinfo_t mincore_cmd;
++#endif
+
+ mmap_region_t *maptable;
+ int mapcount;
+@@ -679,6 +681,7 @@
+ return 0;
+ }
+
++#ifndef __UCLIBC__
+ int
+ mincore_f(
+ int argc,
+@@ -757,6 +760,7 @@
+ free(vec);
+ return 0;
+ }
++#endif
+
+ void
+ mmap_init(void)
+@@ -822,6 +826,7 @@
+ madvise_cmd.oneline = _("give advice about use of memory");
+ madvise_cmd.help = madvise_help;
+
++#ifndef __UCLIBC__
+ mincore_cmd.name = _("mincore");
+ mincore_cmd.altname = _("mi");
+ mincore_cmd.cfunc = mincore_f;
+@@ -830,6 +835,7 @@
+ mincore_cmd.flags = CMD_NOFILE_OK | CMD_FOREIGN_OK;
+ mincore_cmd.args = _("[off len]");
+ mincore_cmd.oneline = _("find mapping pages that are memory resident");
++#endif
+
+ add_command(&mmap_cmd);
+ add_command(&mread_cmd);
+@@ -837,5 +843,7 @@
+ add_command(&munmap_cmd);
+ add_command(&mwrite_cmd);
+ add_command(&madvise_cmd);
++#ifndef __UCLIBC__
+ add_command(&mincore_cmd);
++#endif
+ }
diff --git a/sys-fs/xfsprogs/xfsprogs-2.6.13.ebuild b/sys-fs/xfsprogs/xfsprogs-2.6.13.ebuild
index 1886dc273361..0c07e12b9dd7 100644
--- a/sys-fs/xfsprogs/xfsprogs-2.6.13.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-2.6.13.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.6.13.ebuild,v 1.5 2004/09/22 03:36:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.6.13.ebuild,v 1.6 2004/10/08 00:36:02 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
DESCRIPTION="xfs filesystem utilities"
HOMEPAGE="http://oss.sgi.com/projects/xfs/"
@@ -11,7 +11,7 @@ SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 mips ppc ~sparc x86"
-IUSE="nls"
+IUSE="nls uclibc"
RDEPEND="virtual/libc
sys-fs/e2fsprogs"
@@ -28,6 +28,14 @@ src_unpack() {
-e '/^PKG_[[:upper:]]*_DIR/s:= := $(DESTDIR):' \
include/builddefs.in \
|| die "sed include/builddefs.in failed"
+
+ # mincore does not appear to be part of POSIX or the Single Unix
+ # Specification. So we patch it out for uclibc builds.
+ epatch ${FILESDIR}/${PV}-uclibc-mincore.patch
+ use uclibc && append-flags -D__UCLIBC__
+
+ epatch ${FILESDIR}/${PV}-configure.patch #65735
+ autoreconf -i || die "autoreconf"
}
src_compile() {