summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-22 19:05:10 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-22 19:05:10 +0000
commitb57fc9aa943c5e1fbe8eef7b09c2999915e58cc1 (patch)
tree7943d996544b835bad4110fa4213aade3573cf9d /sys-fs/xfsdump
parentold (diff)
downloadgentoo-2-b57fc9aa943c5e1fbe8eef7b09c2999915e58cc1.tar.gz
gentoo-2-b57fc9aa943c5e1fbe8eef7b09c2999915e58cc1.tar.bz2
gentoo-2-b57fc9aa943c5e1fbe8eef7b09c2999915e58cc1.zip
Version bump #259894 by Lars (Polynomial-C).
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/xfsdump')
-rw-r--r--sys-fs/xfsdump/ChangeLog7
-rw-r--r--sys-fs/xfsdump/xfsdump-3.0.0.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index 33c0c72e1ca0..cf1801fb3f14 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/xfsdump
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.68 2009/01/31 01:28:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.69 2009/02/22 19:05:10 vapier Exp $
+
+*xfsdump-3.0.0 (22 Feb 2009)
+
+ 22 Feb 2009; Mike Frysinger <vapier@gentoo.org> +xfsdump-3.0.0.ebuild:
+ Version bump #259894 by Lars (Polynomial-C).
31 Jan 2009; Jeroen Roovers <jer@gentoo.org> xfsdump-2.2.48.ebuild:
Stable for HPPA (bug #235017).
diff --git a/sys-fs/xfsdump/xfsdump-3.0.0.ebuild b/sys-fs/xfsdump/xfsdump-3.0.0.ebuild
new file mode 100644
index 000000000000..7dcb04c4ebd8
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-3.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-3.0.0.ebuild,v 1.1 2009/02/22 19:05:10 vapier Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/^GCFLAGS/s:-O1::' \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${PN}-2.2.42-Makefile-deps.patch
+ eautoconf
+}
+
+src_compile() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install || die
+ prepalldocs
+}