summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-29 22:21:49 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-29 22:21:49 +0000
commit5a569d1546a235b340ade8bdb1725f70917fb58e (patch)
tree461f2c1972cd2ac873d328cc437048051e117649 /sys-fs/xfsdump
parentVersion bump for bug #301196, thanks to Geert Vanhaute for reporting. Remove ... (diff)
downloadgentoo-2-5a569d1546a235b340ade8bdb1725f70917fb58e.tar.gz
gentoo-2-5a569d1546a235b340ade8bdb1725f70917fb58e.tar.bz2
gentoo-2-5a569d1546a235b340ade8bdb1725f70917fb58e.zip
Fix building with glibc-2.12.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/xfsdump')
-rw-r--r--sys-fs/xfsdump/ChangeLog6
-rw-r--r--sys-fs/xfsdump/files/xfsdump-3.0.4-headers.patch33
-rw-r--r--sys-fs/xfsdump/xfsdump-3.0.4-r1.ebuild5
3 files changed, 41 insertions, 3 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index bb8c355265b9..4026987836e8 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/xfsdump
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.77 2010/07/11 21:22:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.78 2010/08/29 22:21:49 vapier Exp $
+
+ 29 Aug 2010; Mike Frysinger <vapier@gentoo.org> xfsdump-3.0.4-r1.ebuild,
+ +files/xfsdump-3.0.4-headers.patch:
+ Fix building with glibc-2.12.
*xfsdump-3.0.4-r1 (11 Jul 2010)
diff --git a/sys-fs/xfsdump/files/xfsdump-3.0.4-headers.patch b/sys-fs/xfsdump/files/xfsdump-3.0.4-headers.patch
new file mode 100644
index 000000000000..b451ac41ea9d
--- /dev/null
+++ b/sys-fs/xfsdump/files/xfsdump-3.0.4-headers.patch
@@ -0,0 +1,33 @@
+newer glibc requires explicit sys/stat.h inclusion when you use things
+from that header
+
+--- xfsdump-3.0.4/invutil/cmenu.c
++++ xfsdump-3.0.4/invutil/cmenu.c
+@@ -21,6 +21,7 @@
+
+ #include <ncurses.h>
+ #include <signal.h>
++#include <sys/stat.h>
+
+ #include "types.h"
+ #include "mlog.h"
+--- xfsdump-3.0.4/invutil/invidx.c
++++ xfsdump-3.0.4/invutil/invidx.c
+@@ -21,6 +21,7 @@
+
+ #include <ncurses.h>
+ #include <sys/mman.h>
++#include <sys/stat.h>
+
+ #include "types.h"
+ #include "mlog.h"
+--- xfsdump-3.0.4/invutil/stobj.c
++++ xfsdump-3.0.4/invutil/stobj.c
+@@ -20,6 +20,7 @@
+ #include <xfs/jdm.h>
+ #include <ncurses.h>
+ #include <sys/mman.h>
++#include <sys/stat.h>
+
+ #include "types.h"
+ #include "mlog.h"
diff --git a/sys-fs/xfsdump/xfsdump-3.0.4-r1.ebuild b/sys-fs/xfsdump/xfsdump-3.0.4-r1.ebuild
index 1991f3e176c1..5ba25654b070 100644
--- a/sys-fs/xfsdump/xfsdump-3.0.4-r1.ebuild
+++ b/sys-fs/xfsdump/xfsdump-3.0.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-3.0.4-r1.ebuild,v 1.1 2010/07/11 21:22:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-3.0.4-r1.ebuild,v 1.2 2010/08/29 22:21:49 vapier Exp $
inherit multilib eutils
@@ -28,7 +28,8 @@ src_unpack() {
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
include/builddefs.in \
|| die
- epatch "${FILESDIR}/${P}-no-symlink.patch"
+ epatch "${FILESDIR}"/${PN}-3.0.4-headers.patch
+ epatch "${FILESDIR}"/${P}-no-symlink.patch
}
src_compile() {