summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-06 23:23:06 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-06 23:23:06 +0000
commitafe1a7f24afa57f699b532593a385b0957739fc1 (patch)
treeaf8444c701e850271db7e899146fded66923679e /sys-fs/xfsdump/xfsdump-3.1.2.ebuild
parentRemove the g-pypi header, fix the description. (diff)
downloadgentoo-2-afe1a7f24afa57f699b532593a385b0957739fc1.tar.gz
gentoo-2-afe1a7f24afa57f699b532593a385b0957739fc1.tar.bz2
gentoo-2-afe1a7f24afa57f699b532593a385b0957739fc1.zip
Version bump #450586 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-fs/xfsdump/xfsdump-3.1.2.ebuild')
-rw-r--r--sys-fs/xfsdump/xfsdump-3.1.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-fs/xfsdump/xfsdump-3.1.2.ebuild b/sys-fs/xfsdump/xfsdump-3.1.2.ebuild
new file mode 100644
index 000000000000..0ae9b099ae3a
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-3.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-3.1.2.ebuild,v 1.1 2013/01/06 23:23:06 vapier Exp $
+
+EAPI="4"
+
+inherit multilib eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/e2fsprogs
+ !<sys-fs/xfsprogs-3
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${PN}-3.0.5-prompt-overflow.patch #335115
+ epatch "${FILESDIR}"/${PN}-3.0.4-no-symlink.patch #311881
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin
+}