summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-15 17:46:26 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-15 17:46:26 +0000
commitac473605b2a5b4138218869a7f6140686c664e1c (patch)
treeaeabad1544e1c315445e0d3361afa57a8e40b715 /sys-fs/xfsdump/xfsdump-1.1.7.ebuild
parentadded filesystem related apps to sys-fs from sys-apps (diff)
downloadgentoo-2-ac473605b2a5b4138218869a7f6140686c664e1c.tar.gz
gentoo-2-ac473605b2a5b4138218869a7f6140686c664e1c.tar.bz2
gentoo-2-ac473605b2a5b4138218869a7f6140686c664e1c.zip
added filesystem related apps to sys-fs from sys-apps
Diffstat (limited to 'sys-fs/xfsdump/xfsdump-1.1.7.ebuild')
-rw-r--r--sys-fs/xfsdump/xfsdump-1.1.7.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-fs/xfsdump/xfsdump-1.1.7.ebuild b/sys-fs/xfsdump/xfsdump-1.1.7.ebuild
new file mode 100644
index 000000000000..a28bdd96f688
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-1.1.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-1.1.7.ebuild,v 1.1 2003/09/15 17:46:25 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/latest/cmd_tars/${P}.src.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64"
+
+DEPEND="virtual/glibc
+ sys-devel/autoconf
+ sys-devel/make
+ sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ sys-apps/attr"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" -e 's:-O1::' -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' include/builddefs.orig > include/builddefs || die
+ # 5) We now fix some absolute path symlinks in various makefiles
+ local x
+ for x in dump restore
+ do
+ cp ${x}/Makefile ${x}/Makefile.orig
+ sed -e 's:$(INSTALL) -S $(PKG_.*_DIR)/\(.*\) \(.*/.*\):$(INSTALL) -S ../../sbin/\1 \2:' ${x}/Makefile.orig > ${x}/Makefile
+ done
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}