summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2006-04-17 16:25:39 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2006-04-17 16:25:39 +0000
commitab764235e8056ec4d70e041c6519bb2a463aef4f (patch)
tree65410d84674ee44a1c51ec4f022f5102ea6a1714 /sys-fs/udev
parentUpdated dependencies on apr and apr-util to prevent upgrade/downgrade cycles (diff)
downloadgentoo-2-ab764235e8056ec4d70e041c6519bb2a463aef4f.tar.gz
gentoo-2-ab764235e8056ec4d70e041c6519bb2a463aef4f.tar.bz2
gentoo-2-ab764235e8056ec4d70e041c6519bb2a463aef4f.zip
090 release
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sys-fs/udev')
-rw-r--r--sys-fs/udev/ChangeLog16
-rw-r--r--sys-fs/udev/files/digest-udev-0903
-rw-r--r--sys-fs/udev/files/udev-start-090.sh148
-rw-r--r--sys-fs/udev/files/udev.rules-08925
-rw-r--r--sys-fs/udev/udev-090.ebuild275
5 files changed, 466 insertions, 1 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index fe1cb8b0fe25..a2f6fd80cbf3 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.192 2006/04/16 22:30:49 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.193 2006/04/17 16:25:39 gregkh Exp $
+
+*udev-090 (17 Apr 2006)
+
+ 17 Apr 2006; Greg Kroah-Hartman <gregkh@gentoo.org> files/udev.rules-089,
+ +files/udev-start-090.sh, +udev-090.ebuild:
+ 090 udev release.
+ Lots of little bug fixes from 089.
+ pnp modules should now be autoloaded (if not, please read comments
+ in the 050-udev.rules file in the /etc/udev/rules/ directory on what
+ you need to add to the modules.conf file).
+ "safer" ebuild now, we do error checking and warn about coldplug
+ still being present on the box.
+ We also create device nodes directly on the root fs, not in /var
+ to help those who mount /var -nodev.
16 Apr 2006; Michael Hanselmann <hansmi@gentoo.org> udev-087.ebuild:
Stable on ppc.
diff --git a/sys-fs/udev/files/digest-udev-090 b/sys-fs/udev/files/digest-udev-090
new file mode 100644
index 000000000000..8e7eae04b7fe
--- /dev/null
+++ b/sys-fs/udev/files/digest-udev-090
@@ -0,0 +1,3 @@
+MD5 44acf418a23b0be826aa55828ada07db udev-090.tar.bz2 192213
+RMD160 77c1cd3cd71d781daf420824723cc520c75f41c8 udev-090.tar.bz2 192213
+SHA256 fd938b4144093261ed0437a6a7ce167526113ead596059ebae779b3fe219b4b3 udev-090.tar.bz2 192213
diff --git a/sys-fs/udev/files/udev-start-090.sh b/sys-fs/udev/files/udev-start-090.sh
new file mode 100644
index 000000000000..edc918b1980f
--- /dev/null
+++ b/sys-fs/udev/files/udev-start-090.sh
@@ -0,0 +1,148 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+udev_version() {
+ local version=0
+
+ if [[ -x /sbin/udev ]] ; then
+ version=$(/sbin/udev -V)
+ # We need it without a leading '0', else bash do the wrong thing
+ version=${version##0}
+ # Older udev's will print nothing
+ [[ -z ${version} ]] && version=0
+ fi
+
+ echo "${version}"
+}
+
+
+populate_udev() {
+ # populate /dev with devices already found by the kernel
+ if [ "$(get_KV)" -gt "$(KV_to_int '2.6.14')" ] ; then
+ ebegin "Populating /dev with existing devices through uevents"
+ udevtrigger
+ eend 0
+ else
+ ebegin "Populating /dev with existing devices with udevstart"
+ /sbin/udevstart
+ eend 0
+ fi
+
+ # loop until everything is finished
+ # there's gotta be a better way...
+ ebegin "Letting udev process events"
+ udevsettle
+# loop=0
+# while test -d /dev/.udev/queue; do
+# sleep 0.1;
+# test "$loop" -gt 300 && break
+# loop=$(($loop + 1))
+# done
+ #einfo "loop = $loop"
+ eend 0
+
+ return 0
+}
+
+seed_dev() {
+ # Seed /dev with some things that we know we need
+ ebegin "Seeding /dev with needed nodes"
+
+ # copy over any persistant things
+ if [[ -d /lib/udev/devices ]] ; then
+ cp --preserve=all --recursive --update /lib/udev/devices/* /dev
+ fi
+
+ # Not provided by sysfs but needed
+ ln -snf /proc/self/fd /dev/fd
+ ln -snf fd/0 /dev/stdin
+ ln -snf fd/1 /dev/stdout
+ ln -snf fd/2 /dev/stderr
+ [[ -e /proc/kcore ]] && ln -snf /proc/kcore /dev/core
+
+ # Create problematic directories
+ mkdir -p /dev/{pts,shm}
+ eend 0
+}
+
+
+main() {
+ # Setup temporary storage for /dev
+ ebegin "Mounting /dev for udev"
+ if [[ ${RC_USE_FSTAB} == "yes" ]] ; then
+ mntcmd=$(get_mount_fstab /dev)
+ else
+ unset mntcmd
+ fi
+ if [[ -n ${mntcmd} ]] ; then
+ try mount -n ${mntcmd}
+ else
+ if egrep -qs tmpfs /proc/filesystems ; then
+ mntcmd="tmpfs"
+ else
+ mntcmd="ramfs"
+ fi
+ # many video drivers require exec access in /dev #92921
+ try mount -n -t ${mntcmd} udev /dev -o exec,nosuid,mode=0755
+ fi
+ eend $?
+
+ # Create a file so that our rc system knows it's still in sysinit.
+ # Existance means init scripts will not directly run.
+ # rc will remove the file when done with sysinit.
+ touch /dev/.rcsysinit
+
+ # Selinux lovin; /selinux should be mounted by selinux-patched init
+ if [[ -x /sbin/restorecon && -c /selinux/null ]] ; then
+ restorecon /dev &> /selinux/null
+ fi
+
+ # Actually get udev rolling
+ if [[ ${RC_DEVICE_TARBALL} == "yes" && \
+ -s /lib/udev-state/devices.tar.bz2 ]] ; then
+ ebegin "Populating /dev with saved device nodes"
+ try tar -jxpf /lib/udev-state/devices.tar.bz2 -C /dev
+ eend $?
+ fi
+
+ seed_dev
+
+ # Setup hotplugging (if possible)
+ ebegin "Setting up proper hotplug agent"
+ if [[ -e /proc/sys/kernel/hotplug ]] ; then
+ if [ "$(get_KV)" -gt "$(KV_to_int '2.6.14')" ] ; then
+ einfo " Using netlink for hotplug events..."
+ echo "" > /proc/sys/kernel/hotplug
+ elif [[ $(udev_version) -ge "48" ]] ; then
+ einfo " Setting /sbin/udevsend as hotplug agent ..."
+ echo "/sbin/udevsend" > /proc/sys/kernel/hotplug
+ elif [[ -x /sbin/hotplug ]] ; then
+ einfo " Using /sbin/hotplug as hotplug agent ..."
+ else
+ einfo " Setting /sbin/udev as hotplug agent ..."
+ echo "/sbin/udev" > /proc/sys/kernel/hotplug
+ fi
+ fi
+ eend 0
+
+ ebegin "Starting udevd"
+ /sbin/udevd --daemon
+ eend $?
+
+ populate_udev
+
+ # Create nodes that udev can't
+ ebegin "Finializing udev configuration"
+ [[ -x /sbin/dmsetup ]] && /sbin/dmsetup mknodes &>/dev/null
+ [[ -x /sbin/lvm ]] && \
+ /sbin/lvm vgscan -P --mknodes --ignorelockingfailure &>/dev/null
+ # Running evms_activate on a LiveCD causes lots of headaches
+ [[ -z ${CDBOOT} ]] && [[ -x /sbin/evms_activate ]] && \
+ /sbin/evms_activate -q &>/dev/null
+ eend 0
+}
+
+main
+
+
+# vim:ts=4
diff --git a/sys-fs/udev/files/udev.rules-089 b/sys-fs/udev/files/udev.rules-089
index 4a1fc770ccd8..a464ed8e90cf 100644
--- a/sys-fs/udev/files/udev.rules-089
+++ b/sys-fs/udev/files/udev.rules-089
@@ -298,6 +298,31 @@ LABEL="persistent_end"
SUBSYSTEM=="usb_device", PROGRAM="/bin/sh -c 'K=%k; K=$${K#usbdev}; printf bus/usb/%%03i/%%03i $${K%%%%.*} $${K#*.}'", NAME="%c", MODE="0644"
+# Module autoloading
+
+# Autoload modules that lack aliases but have them defined inutoload modules
+SYSFS{modalias}=="?*", ACTION=="add", RUN+="/sbin/modprobe $env{MODALIAS}"
+
+# /etc/modprobe.conf.
+SUBSYSTEM=="pnp", ENV{MODALIAS}!="?*", RUN+="/bin/sh -c 'while read id; do /sbin/modprobe pnp:d$$id; done < /sys$devpath/id'"
+# If you have problems with some pnp modules being loaded, please enter the
+# following aliases into the modprobe configuration files. These are needed by
+# udev to autoload some modules
+# alias pnp:dPNP0510 irtty-sir
+# alias pnp:dPNP0511 irtty-sir
+# alias pnp:dPNP0700 floppy
+# alias pnp:dPNP0800 pcspkr
+# alias pnp:dPNP0b00 rtc
+# alias pnp:dPNP0303 atkbd
+# alias pnp:dPNP0f13 psmouse
+# alias pnp:dPNPb02f analog
+
+
+
+# Load firmware (not quite yet...)
+# SUBSYSTEM=="firmware", ACTION=="add", RUN+="/lib/udev/firmware_helper"
+
+
# be backward compatible for a while with the /etc/dev.d and /etc/hotplug.d/ systems
# run /etc/hotplug.d/ stuff only if we came from a hotplug event, not for udevstart
ENV{UDEVD_EVENT}=="1", RUN+="/sbin/udev_run_hotplugd $env{SUBSYSTEM}"
diff --git a/sys-fs/udev/udev-090.ebuild b/sys-fs/udev/udev-090.ebuild
new file mode 100644
index 000000000000..1260bad0ca4a
--- /dev/null
+++ b/sys-fs/udev/udev-090.ebuild
@@ -0,0 +1,275 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-090.ebuild,v 1.1 2006/04/17 16:25:39 gregkh Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+# still rely on hotplug (need to fix that), but now we implement coldplug
+
+DEPEND="sys-apps/hotplug-base"
+RDEPEND="!sys-apps/coldplug"
+RDEPEND="${DEPEND} ${RDEPEND}
+ >=sys-apps/baselayout-1.11.14"
+# We need the lib/rcscripts/addon support
+PROVIDE="virtual/dev-manager"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # patches go here...
+ #epatch ${FILESDIR}/${P}-udev_volume_id.patch
+
+ # No need to clutter the logs ...
+ sed -ie '/^DEBUG/ c\DEBUG = false' Makefile
+ # Do not use optimization flags from the package
+ sed -ie 's|$(OPTIMIZATION)||g' Makefile
+
+ # Make sure there is no sudden changes to udev.rules.gentoo
+ # (more for my own needs than anything else ...)
+ MD5=`md5sum < "${S}/etc/udev/gentoo/udev.rules"`
+ MD5=${MD5/ -/}
+ if [ "${MD5}" != "590d3e6346938e3b608237973f4f1805" ]
+ then
+ echo
+ eerror "gentoo/udev.rules has been updated, please validate!"
+ die "gentoo/udev.rules has been updated, please validate!"
+ fi
+}
+
+src_compile() {
+ filter-flags -fprefetch-loop-arrays
+ local myconf=
+ local extras="extras/scsi_id extras/volume_id extras/ata_id extras/run_directory extras/usb_id extras/floppy extras/cdrom_id extras/firmware"
+
+ use selinux && myconf="${myconf} USE_SELINUX=true"
+
+ # Not everyone has full $CHOST-{ld,ar,etc...} yet
+ local mycross=""
+ type -p ${CHOST}-ar && mycross=${CHOST}-
+
+ echo "get_libdir = $(get_libdir)"
+ # Do not work with emake
+ make \
+ EXTRAS="${extras}" \
+ udevdir="/dev/" \
+ CROSS=${mycross} \
+ ${myconf} || die
+}
+
+src_install() {
+ # we install everything by "hand" and don't rely on the udev Makefile to do
+ # it for us (why? it's easier that way...)
+ dobin udevinfo || die "Required binary not installed properly"
+ dobin udevtest || die "Required binary not installed properly"
+ dobin udevmonitor || die "Required binary not installed properly"
+ into /
+ dosbin udev || die "Required binary not installed properly"
+ dosbin udevd || die "Required binary not installed properly"
+ dosbin udevsend || die "Required binary not installed properly"
+ dosbin udevstart || die "Required binary not installed properly"
+ dosbin udevtrigger || die "Required binary not installed properly"
+ dosbin udevcontrol || die "Required binary not installed properly"
+ dosbin udevsettle || die "Required binary not installed properly"
+ dosbin extras/run_directory/udev_run_devd || die "Required helper not installed properly"
+ dosbin extras/run_directory/udev_run_hotplugd || die "Required helper not installed properly"
+ dosbin extras/ata_id/ata_id || die "Required helper not installed properly"
+ dosbin extras/volume_id/vol_id || die "Required helper not installed properly"
+ dosbin extras/scsi_id/scsi_id || die "Required helper not installed properly"
+ dosbin extras/usb_id/usb_id || die "Required helper not installed properly"
+ dosbin extras/path_id/path_id || die "Required helper not installed properly"
+ dosbin extras/cdrom_id/cdrom_id || die "Required helper not installed properly"
+
+ # vol_id library (needed by mount and HAL)
+ dolib extras/volume_id/lib/*.a extras/volume_id/lib/*.so*
+ # move the .a files to /usr/lib
+ dodir /usr/$(get_libdir)
+ mv -f "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/
+
+ # handle static linking bug #4411
+ gen_usr_ldscript libvolume_id.so
+
+ # save pkgconfig info
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins extras/volume_id/lib/*.pc
+
+ #exeinto /etc/udev/scripts
+ exeinto /lib/udev
+ #doexe extras/ide-devfs.sh
+ #doexe extras/scsi-devfs.sh
+ #doexe extras/raid-devfs.sh
+ doexe extras/floppy/create_floppy_devices || die "Required binary not installed properly"
+ doexe extras/firmware/firmware_helper || die "Required binary not installed properly"
+
+ # Our udev config file
+ insinto /etc/udev
+ newins ${FILESDIR}/udev.conf.post_081 udev.conf
+
+ # Our rules files
+ insinto /etc/udev/rules.d/
+ newins etc/udev/gentoo/udev.rules 50-udev.rules
+ newins ${FILESDIR}/udev.rules-089 50-udev.rules
+ newins ${FILESDIR}/05-udev-early.rules-079 05-udev-early.rules
+
+ # scsi_id configuration
+ insinto /etc
+ doins extras/scsi_id/scsi_id.config
+
+ # set up symlinks in /etc/hotplug.d/default
+ dodir /etc/hotplug.d/default
+ dosym ../../../sbin/udevsend /etc/hotplug.d/default/10-udev.hotplug
+
+ # set up the /etc/dev.d directory tree
+ dodir /etc/dev.d/default
+ dodir /etc/dev.d/net
+ exeinto /etc/dev.d/net
+ doexe extras/run_directory/dev.d/net/hotplug.dev
+
+ # all of the man pages
+ doman *.7
+ doman *.8
+ doman extras/ata_id/ata_id.8
+ doman extras/edd_id/edd_id.8
+ doman extras/scsi_id/scsi_id.8
+ doman extras/volume_id/vol_id.8
+ doman extras/dasd_id/dasd_id.8
+ doman extras/cdrom_id/cdrom_id.8
+
+ # our udev hooks into the rc system
+ insinto /lib/rcscripts/addons
+ newins "${FILESDIR}"/udev-start-089.sh udev-start.sh
+ doins "${FILESDIR}"/udev-stop.sh
+
+ dodoc ChangeLog FAQ README TODO RELEASE-NOTES
+ dodoc docs/{overview,udev_vs_devfs}
+ dodoc docs/writing_udev_rules/*
+
+ newdoc extras/volume_id/README README_volume_id
+
+}
+
+pkg_preinst() {
+ if [ -f "${ROOT}/etc/udev/udev.config" -a \
+ ! -f "${ROOT}/etc/udev/udev.rules" ]
+ then
+ mv -f ${ROOT}/etc/udev/udev.config ${ROOT}/etc/udev/udev.rules
+ fi
+
+ # delete the old udev.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/udev.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug
+ fi
+
+ # is there a stale coldplug initscript? (CONFIG_PROTECT leaves it behind)
+ coldplug_stale=""
+ if [ -f "${ROOT}/etc/init.d/coldplug" ]
+ then
+ coldplug_stale="1"
+ fi
+
+ # Create some nodes that we know we need.
+ # set the time/date so we can see in /dev which ones we copied over
+ # in the udev-start.sh script
+ mkdir -p ${ROOT}/lib/udev/devices
+
+ if [ ! -e ${ROOT}/lib/udev/devices/null ] ; then
+ mknod ${ROOT}/lib/udev/devices/null c 1 3
+ fi
+ chmod 666 ${ROOT}/lib/udev/devices/null
+ touch -t 200010220101 ${ROOT}/lib/udev/devices/null
+
+ if [ ! -e ${ROOT}/lib/udev/devices/zero ] ; then
+ mknod ${ROOT}/lib/udev/devices/zero c 1 5
+ fi
+ chmod 666 ${ROOT}/lib/udev/devices/zero
+ touch -t 200010220101 ${ROOT}/lib/udev/devices/zero
+
+ if [ ! -e ${ROOT}/lib/udev/devices/console ] ; then
+ mknod ${ROOT}/lib/udev/devices/console c 5 1
+ fi
+ chmod 600 ${ROOT}/lib/udev/devices/console
+ chown root:tty ${ROOT}/lib/udev/devices/console
+ touch -t 200010220101 ${ROOT}/lib/udev/devices/console
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" -a -n "`pidof udevd`" ]
+ then
+ killall -15 udevd &>/dev/null
+ sleep 1
+ killall -9 udevd &>/dev/null
+ fi
+ /sbin/udevd --daemon
+
+ # people want reminders, I'll give them reminders. Odds are they will
+ # just ignore them anyway...
+ if has_version '<sys-fs/udev-046' ; then
+ ewarn "Note: If you rely on the output of udevinfo for anything, please"
+ ewarn " either run 'udevstart' now, or reboot, in order to get a"
+ ewarn " up-to-date udev database."
+ ewarn
+ fi
+ if has_version '<sys-fs/udev-050' ; then
+ ewarn "Note: If you had written some custom permissions rules, please"
+ ewarn " realize that the permission rules are now part of the main"
+ ewarn " udev rules files and are not stand-alone anymore. This means"
+ ewarn " you need to rewrite them."
+ ewarn
+ fi
+ if has_version '<sys-fs/udev-059' ; then
+ ewarn "Note: If you are upgrading from a version of udev prior to 059"
+ ewarn " and you have written custom rules, and rely on the etc/dev.d/"
+ ewarn " functionality, or the etc/hotplug.d functionality, or just"
+ ewarn " want to write some very cool and power udev rules, please "
+ ewarn " read the RELEASE-NOTES file for details on what has changed"
+ ewarn " with this feature, and how to change your rules to work properly."
+ ewarn
+ elif has_version '<sys-fs/udev-057' ; then
+ ewarn "Note: If you have written custom rules, and rely on the etc/dev.d/"
+ ewarn " functionality, please read the RELEASE-NOTES file for details"
+ ewarn " on what has changed with this feature, and how to change your"
+ ewarn " rules to work properly."
+ ewarn
+ fi
+ if has_version '<sys-fs/udev-063' ; then
+ ewarn "Note: If you use the devfs-style names for your block devices"
+ ewarn " or use devfs-style names in /etc/inittab or /etc/securetty or"
+ ewarn " your GRUB or LILO kernel boot command line, you need to"
+ ewarn " change them back to LSB compliant names, as the devfs names are"
+ ewarn " now gone. If you wish to use some persistent names for your"
+ ewarn " block devices, look at the symlinks in /dev/disk/ for the names"
+ ewarn " you can use."
+ ewarn
+ fi
+
+ if [[ ${coldplug_stale} == "1" ]] ; then
+ ewarn "A stale coldplug init script found. You should run:"
+ ewarn
+ ewarn " rc-update del coldplug"
+ ewarn " rm -f /etc/init.d/coldplug"
+ ewarn
+ ewarn "udev now provides its own coldplug functionality."
+ fi
+
+ einfo
+ einfo "For more information on udev on Gentoo, writing udev rules, and"
+ einfo " fixing known issues visit:"
+ einfo " http://www.gentoo.org/doc/en/udev-guide.xml"
+}