summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-02-01 14:52:44 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-02-01 14:52:44 +0000
commit8bc15f77173446f7b1ae10b8be4936c0bc5543aa (patch)
treeb71ea854e67a177600748536566445041f90b191 /sys-fs/udev
parentsparc stable wrt #198566 (diff)
downloadgentoo-2-8bc15f77173446f7b1ae10b8be4936c0bc5543aa.tar.gz
gentoo-2-8bc15f77173446f7b1ae10b8be4936c0bc5543aa.tar.bz2
gentoo-2-8bc15f77173446f7b1ae10b8be4936c0bc5543aa.zip
Do not start net-init-scripts if coldplug=no, Bug #206518. Do not log missing init-script message, Bug #205687.
(Portage version: 2.1.4.1)
Diffstat (limited to 'sys-fs/udev')
-rw-r--r--sys-fs/udev/ChangeLog11
-rwxr-xr-xsys-fs/udev/files/net-118-r1.sh34
-rw-r--r--sys-fs/udev/files/udev-start-118-r1.sh200
-rw-r--r--sys-fs/udev/udev-118-r1.ebuild342
4 files changed, 585 insertions, 2 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index c2ddc61bcaf2..78be2d297dd7 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/udev
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.368 2007/12/19 10:05:13 zzam Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.369 2008/02/01 14:52:43 zzam Exp $
+
+*udev-118-r1 (01 Feb 2008)
+
+ 01 Feb 2008; Matthias Schwarzott <zzam@gentoo.org> +files/net-118-r1.sh,
+ +files/udev-start-118-r1.sh, +udev-118-r1.ebuild:
+ Do not start net-init-scripts if coldplug=no, Bug #206518. Do not log
+ missing init-script message, Bug #205687.
*udev-118 (19 Dec 2007)
diff --git a/sys-fs/udev/files/net-118-r1.sh b/sys-fs/udev/files/net-118-r1.sh
new file mode 100755
index 000000000000..bb8b2d64fec4
--- /dev/null
+++ b/sys-fs/udev/files/net-118-r1.sh
@@ -0,0 +1,34 @@
+#!/bin/sh
+#
+# net.sh: udev external RUN script
+#
+# Copyright 2007 Roy Marples <uberlord@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+
+IFACE=$1
+ACTION=$2
+
+SCRIPT=/etc/init.d/net.$IFACE
+
+# ignore interfaces that are registered after being "up" (?)
+case ${IFACE} in
+ ppp*|ippp*|isdn*|plip*|lo*|irda*|dummy*|ipsec*|tun*|tap*)
+ exit 0 ;;
+esac
+
+# stop here if coldplug is disabled, Bug #206518
+if [ "${do_not_run_plug_service}" = 1 ]; then
+ exit 0
+fi
+
+if [ ! -x "${SCRIPT}" ] ; then
+ #do not flood log with messages, bug #205687
+ #logger -t udev-net.sh "${SCRIPT}: does not exist or is not executable"
+ exit 1
+fi
+
+# If we're stopping then sleep for a bit in-case a daemon is monitoring
+# the interface. This to try and ensure we stop after they do.
+[ "${ACTION}" == "stop" ] && sleep 2
+
+IN_HOTPLUG=1 "${SCRIPT}" --quiet "${ACTION}"
diff --git a/sys-fs/udev/files/udev-start-118-r1.sh b/sys-fs/udev/files/udev-start-118-r1.sh
new file mode 100644
index 000000000000..3a69ec27ba81
--- /dev/null
+++ b/sys-fs/udev/files/udev-start-118-r1.sh
@@ -0,0 +1,200 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+tmpfs_size="10M"
+
+[ -e /etc/udev/udev.conf ] && . /etc/udev/udev.conf
+
+mount_dev_directory() {
+ # Setup temporary storage for /dev
+ ebegin "Mounting /dev for udev"
+ if [ "${RC_USE_FSTAB}" = "yes" ] ; then
+ mntcmd=$(get_mount_fstab /dev)
+ else
+ unset mntcmd
+ fi
+ if [ -n "${mntcmd}" ] ; then
+ try mount -n ${mntcmd}
+ else
+ # many video drivers require exec access in /dev #92921
+ mntopts="exec,nosuid,mode=0755,size=${tmpfs_size}"
+ [ -n "${tmpfs_inodes}" ] && mntopts="${mntopts},nr_inodes=${tmpfs_inodes}"
+ if grep -Eq "[[:space:]]+tmpfs$" /proc/filesystems ; then
+ mntcmd="tmpfs"
+ else
+ mntcmd="ramfs"
+ fi
+ try mount -n -t "${mntcmd}" -o "${mntopts}" udev /dev
+ fi
+ eend $?
+}
+
+# populate /dev with devices already found by the kernel
+populate_udev() {
+ if get_bootparam "nocoldplug" ; then
+ RC_COLDPLUG="no"
+ ewarn "Skipping udev coldplug as requested in kernel cmdline"
+ fi
+
+ # at this point we are already sure to use kernel 2.6.15 or newer
+ ebegin "Populating /dev with existing devices through uevents"
+ if [ "${RC_COLDPLUG}" = "yes" ]; then
+ /sbin/udevtrigger
+ else
+ # Do not run any init-scripts, Bug #206518
+ udevadm control --env do_not_run_plug_service=1
+
+ # only create device nodes
+ /sbin/udevtrigger --attr-match=dev
+
+ # run persistent-net stuff, bug 191466
+ /sbin/udevtrigger --subsystem-match=net
+ fi
+ eend $?
+
+ # loop until everything is finished
+ # there's gotta be a better way...
+ ebegin "Letting udev process events"
+ /sbin/udevsettle --timeout=60
+ eend $?
+
+ udevadm control --env do_not_run_plug_service=
+ return 0
+}
+
+seed_dev() {
+ # Seed /dev with some things that we know we need
+ ebegin "Seeding /dev with needed nodes"
+
+ # creating /dev/console and /dev/tty1 to be able to write
+ # to $CONSOLE with/without bootsplash before udevd creates it
+ [ ! -c /dev/console ] && mknod /dev/console c 5 1
+ [ ! -c /dev/tty1 ] && mknod /dev/tty1 c 4 1
+
+ # udevd will dup its stdin/stdout/stderr to /dev/null
+ # and we do not want a file which gets buffered in ram
+ [ ! -c /dev/null ] && mknod /dev/null c 1 3
+
+ # copy over any persistant things
+ if [ -d /lib/udev/devices ] ; then
+ cp --preserve=all --recursive --update /lib/udev/devices/* /dev 2>/dev/null
+ fi
+
+ # Not provided by sysfs but needed
+ ln -snf /proc/self/fd /dev/fd
+ ln -snf fd/0 /dev/stdin
+ ln -snf fd/1 /dev/stdout
+ ln -snf fd/2 /dev/stderr
+ [ -e /proc/kcore ] && ln -snf /proc/kcore /dev/core
+
+ # Create problematic directories
+ mkdir -p /dev/pts /dev/shm
+ eend 0
+}
+
+unpack_device_tarball() {
+ # Actually get udev rolling
+ if [ "${RC_DEVICE_TARBALL}" = "yes" ] && \
+ [ -s /lib/udev/state/devices.tar.bz2 ] ; then
+ ebegin "Populating /dev with saved device nodes"
+ try tar -jxpf /lib/udev/state/devices.tar.bz2 -C /dev
+ eend $?
+ fi
+}
+
+check_persistent_net() {
+ # check if there are problems with persistent-net
+ local syspath=
+ local devs=
+ local problem_found=0
+ for syspath in /sys/class/net/*_rename*; do
+ if [ -d "${syspath}" ]; then
+ devs="${devs} ${syspath##*/}"
+ problem_found=1
+ fi
+ done
+
+ [ "${problem_found}" = 0 ] && return 0
+
+ eerror "UDEV: Your system has a problem assigning persistent names"
+ eerror "to these network interfaces: ${devs}"
+
+ einfo "Checking persistent-net rules:"
+ # the sed-expression lists all duplicate lines
+ # from the input, like "uniq -d" does, but uniq
+ # is installed into /usr/bin and not available at boot.
+ dups=$(
+ RULES_FILE='/etc/udev/rules.d/70-persistent-net.rules'
+ . /lib/udev/rule_generator.functions
+ find_all_rules 'NAME=' '.*'|tr ' ' '\n'|sort|sed '$!N; s/^\(.*\)\n\1$/\1/; t; D'
+ )
+ if [ -n "${dups}" ]; then
+ ewarn "The rules create multiple entries assigning these names:"
+ eindent
+ ewarn "${dups}"
+ eoutdent
+ else
+ ewarn "Found no duplicate names in persistent-net rules,"
+ ewarn "there must be some other problem!"
+ fi
+ return 1
+}
+
+main() {
+ if [ $(get_KV) -le $(KV_to_int '2.6.14') ] ; then
+ eerror "Your kernel is too old to work with this version of udev."
+ eerror "Current udev only supports Linux kernel 2.6.15 and newer."
+ return 1
+ fi
+
+ mount_dev_directory
+
+ # Create a file so that our rc system knows it's still in sysinit.
+ # Existance means init scripts will not directly run.
+ # rc will remove the file when done with sysinit.
+ touch /dev/.rcsysinit
+
+ # Selinux lovin; /selinux should be mounted by selinux-patched init
+ if [ -x /sbin/restorecon -a -c /selinux/null ] ; then
+ restorecon /dev > /selinux/null
+ fi
+
+ unpack_device_tarball
+ seed_dev
+
+ if [ -e /proc/sys/kernel/hotplug ] ; then
+ echo "" > /proc/sys/kernel/hotplug
+ fi
+
+ ebegin "Starting udevd"
+ /sbin/udevd --daemon
+ eend $?
+
+ /lib/udev/write_root_link_rule
+ populate_udev
+
+ # Only do this for baselayout-1*
+ if [ ! -e /lib/librc.so ]; then
+
+ # Create nodes that udev can't
+ ebegin "Finalizing udev configuration"
+ [ -x /sbin/lvm ] && \
+ /sbin/lvm vgscan -P --mknodes --ignorelockingfailure &>/dev/null
+ # Running evms_activate on a LiveCD causes lots of headaches
+ [ -z "${CDBOOT}" -a -x /sbin/evms_activate ] && \
+ /sbin/evms_activate -q &>/dev/null
+ eend 0
+ fi
+
+ check_persistent_net
+
+ # trigger executing initscript when /etc is writable
+ IN_HOTPLUG=1 /etc/init.d/udev-postmount start >/dev/null 2>/dev/null
+
+ # udev started successfully
+ return 0
+}
+
+main
+
+# vim:ts=4
diff --git a/sys-fs/udev/udev-118-r1.ebuild b/sys-fs/udev/udev-118-r1.ebuild
new file mode 100644
index 000000000000..34e0faa3b76e
--- /dev/null
+++ b/sys-fs/udev/udev-118-r1.ebuild
@@ -0,0 +1,342 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-118-r1.ebuild,v 1.1 2008/02/01 14:52:43 zzam Exp $
+
+inherit eutils flag-o-matic multilib toolchain-funcs versionator
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+RDEPEND="!sys-apps/coldplug
+ !<sys-fs/device-mapper-1.02.19-r1"
+RDEPEND="${DEPEND} ${RDEPEND}
+ >=sys-apps/baselayout-1.12.5"
+# We need the lib/rcscripts/addon support
+PROVIDE="virtual/dev-manager"
+
+pkg_setup() {
+ udev_helper_dir="/$(get_libdir)/udev"
+
+ myconf=
+ extras="extras/ata_id \
+ extras/cdrom_id \
+ extras/edd_id \
+ extras/firmware \
+ extras/floppy \
+ extras/path_id \
+ extras/scsi_id \
+ extras/usb_id \
+ extras/volume_id \
+ extras/collect \
+ extras/rule_generator"
+
+ use selinux && myconf="${myconf} USE_SELINUX=true"
+
+ # comparing kernel version without linux-info.eclass to not pull
+ # virtual/linux-sources
+
+ local KV=$(uname -r)
+ local KV_MAJOR=$(get_major_version ${KV})
+ local KV_MINOR=$(get_version_component_range 2 ${KV})
+ local KV_MICRO=$(get_version_component_range 3 ${KV})
+
+ local ok=0
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 && ${KV_MICRO} -ge 15 ]]
+ then
+ ok=1
+ fi
+
+ if [[ ${ok} == 0 ]]
+ then
+ ewarn
+ ewarn "${P} does not support Linux kernel before version 2.6.15!"
+ ewarn "If you want to use udev you need to update"
+ ewarn "to kernel >=2.6.15!"
+ ewarn
+ ebeep
+ fi
+}
+
+sed_helper_dir() {
+ sed -e "s#/lib/udev#${udev_helper_dir}#" -i "$@"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # patches go here...
+
+ # No need to clutter the logs ...
+ sed -ie '/^DEBUG/ c\DEBUG = false' Makefile
+ # Do not use optimization flags from the package
+ sed -ie 's|$(OPTIMIZATION)||g' Makefile
+ # Do not require xmlto to refresh manpages
+ sed -ie 's|$(MAN_PAGES)||g' Makefile
+
+ # Make sure there is no sudden changes to upstream rules file
+ # (more for my own needs than anything else ...)
+ MD5=$(md5sum < "${S}/etc/udev/rules.d/50-udev-default.rules")
+ MD5=${MD5/ -/}
+ if [[ ${MD5} != a71a3459f46eb61b209a73fc0c6a299f ]]
+ then
+ echo
+ eerror "50-udev-default.rules has been updated, please validate!"
+ die "50-udev-default.rules has been updated, please validate!"
+ fi
+
+ sed_helper_dir \
+ etc/udev/rules.d/50-udev-default.rules \
+ extras/rule_generator/write_*_rules \
+ udev_rules_parse.c \
+ udev_rules.c
+
+ # Use correct multilib dir
+ sed -i extras/volume_id/lib/Makefile \
+ -e "/ =/s-/lib-/$(get_libdir)-"
+}
+
+src_compile() {
+ filter-flags -fprefetch-loop-arrays
+
+ if [[ -z ${extras} ]]; then
+ eerror "Variable extras is unset!"
+ eerror "It seems you suffer from Bug #190994"
+ die "Variable extras is unset!"
+ fi
+
+ # Not everyone has full $CHOST-{ld,ar,etc...} yet
+ local mycross=""
+ type -p ${CHOST}-ar && mycross=${CHOST}-
+
+ emake \
+ EXTRAS="${extras}" \
+ libudevdir=${udev_helper_dir} \
+ CROSS_COMPILE=${mycross} \
+ OPTFLAGS="" \
+ ${myconf} || die "compiling udev failed"
+}
+
+src_install() {
+ into /
+ emake \
+ DESTDIR="${D}" \
+ libudevdir=${udev_helper_dir} \
+ EXTRAS="${extras}" \
+ ${myconf} \
+ install || die "make install failed"
+
+ exeinto "${udev_helper_dir}"
+ newexe "${FILESDIR}"/net-118-r1.sh net.sh || die "net.sh not installed properly"
+ newexe "${FILESDIR}"/move_tmp_persistent_rules-112-r1.sh move_tmp_persistent_rules.sh \
+ || die "move_tmp_persistent_rules.sh not installed properly"
+ doexe "${FILESDIR}"/write_root_link_rule \
+ || die "write_root_link_rule not installed properly"
+
+ keepdir "${udev_helper_dir}"/state
+ keepdir "${udev_helper_dir}"/devices
+
+ # create symlinks for these utilities to /sbin
+ # where multipath-tools expect them to be (Bug #168588)
+ dosym "..${udev_helper_dir}/vol_id" /sbin/vol_id
+ dosym "..${udev_helper_dir}/scsi_id" /sbin/scsi_id
+
+ # vol_id library (needed by mount and HAL)
+ into /
+ rm "${D}/$(get_libdir)"/libvolume_id.so* 2>/dev/null
+ dolib extras/volume_id/lib/*.so* || die "Failed installing libvolume_id.so"
+ into /usr
+ dolib extras/volume_id/lib/*.a || die "Failed installing libvolume_id.a"
+
+ # handle static linking bug #4411
+ rm -f "${D}/usr/$(get_libdir)/libvolume_id.so"
+ gen_usr_ldscript libvolume_id.so
+
+ # Add gentoo stuff to udev.conf
+ cat "${FILESDIR}"/udev.conf.115-r6 >> "${D}"/etc/udev/udev.conf
+
+ # Now installing rules
+ cd etc/udev
+ insinto /etc/udev/rules.d/
+
+ # Our rules files
+ doins gentoo/??-*.rules
+ doins packages/40-alsa.rules
+
+ # Adding arch specific rules
+ if [[ -f packages/40-${ARCH}.rules ]]
+ then
+ doins "packages/40-${ARCH}.rules"
+ fi
+ cd "${S}"
+
+ # our udev hooks into the rc system
+ insinto /$(get_libdir)/rcscripts/addons
+ newins "${FILESDIR}"/udev-start-118-r1.sh udev-start.sh
+ newins "${FILESDIR}"/udev-stop-111-r2.sh udev-stop.sh
+
+ # The udev-post init-script
+ newinitd "${FILESDIR}"/udev-postmount-initd-111-r2 udev-postmount
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/blacklist-110 blacklist
+ doins "${FILESDIR}"/pnp-aliases
+
+ # convert /lib/udev to real used dir
+ sed_helper_dir \
+ "${D}/$(get_libdir)"/rcscripts/addons/*.sh \
+ "${D}"/etc/init.d/udev* \
+ "${D}"/etc/modprobe.d/*
+
+ # documentation
+ dodoc ChangeLog FAQ README TODO RELEASE-NOTES
+ dodoc docs/{overview,udev_vs_devfs}
+
+ cd docs/writing_udev_rules
+ mv index.html writing_udev_rules.html
+ dohtml *.html
+
+ cd "${S}"
+
+ newdoc extras/volume_id/README README_volume_id
+
+ echo "CONFIG_PROTECT_MASK=\"/etc/udev/rules.d\"" > 20udev
+ doenvd 20udev
+}
+
+pkg_preinst() {
+ if [[ -d ${ROOT}/lib/udev-state ]]
+ then
+ mv -f "${ROOT}"/lib/udev-state/* "${D}"/lib/udev/state/
+ rm -r "${ROOT}"/lib/udev-state
+ fi
+
+ if [[ -f ${ROOT}/etc/udev/udev.config &&
+ ! -f ${ROOT}/etc/udev/udev.rules ]]
+ then
+ mv -f "${ROOT}"/etc/udev/udev.config "${ROOT}"/etc/udev/udev.rules
+ fi
+
+ # delete the old udev.hotplug symlink if it is present
+ if [[ -h ${ROOT}/etc/hotplug.d/default/udev.hotplug ]]
+ then
+ rm -f "${ROOT}"/etc/hotplug.d/default/udev.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [[ -h ${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug ]]
+ then
+ rm -f "${ROOT}"/etc/hotplug.d/default/05-wait_for_sysfs.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [[ -h ${ROOT}/etc/hotplug.d/default/10-udev.hotplug ]]
+ then
+ rm -f "${ROOT}"/etc/hotplug.d/default/10-udev.hotplug
+ fi
+
+ # is there a stale coldplug initscript? (CONFIG_PROTECT leaves it behind)
+ coldplug_stale=""
+ if [[ -f ${ROOT}/etc/init.d/coldplug ]]
+ then
+ coldplug_stale="1"
+ fi
+}
+
+pkg_postinst() {
+ # people want reminders, I'll give them reminders. Odds are they will
+ # just ignore them anyway...
+
+ if [[ ${coldplug_stale} == 1 ]]
+ then
+ ewarn "A stale coldplug init script found. You should run:"
+ ewarn
+ ewarn " rc-update del coldplug"
+ ewarn " rm -f /etc/init.d/coldplug"
+ ewarn
+ ewarn "udev now provides its own coldplug functionality."
+ fi
+
+ # delete 40-scsi-hotplug.rules - all integrated in 50-udev.rules
+ if has_version "=sys-fs/udev-103-r3" &&
+ [[ -e ${ROOT}/etc/udev/rules.d/40-scsi-hotplug.rules ]]
+ then
+ ewarn "Deleting stray 40-scsi-hotplug.rules"
+ ewarn "installed by sys-fs/udev-103-r3"
+ rm -f "${ROOT}"/etc/udev/rules.d/40-scsi-hotplug.rules
+ fi
+
+ # Removing some device-nodes we thought we need some time ago
+ if [[ -d ${ROOT}/lib/udev/devices ]]
+ then
+ rm -f "${ROOT}"/lib/udev/devices/{null,zero,console,urandom}
+ fi
+
+ # Removing some old file
+ if has_version "<sys-fs/udev-104-r5"
+ then
+ rm -f "${ROOT}"/etc/dev.d/net/hotplug.dev
+ rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/net 2>/dev/null
+ fi
+
+ if has_version "<sys-fs/udev-106-r5" &&
+ [[ -e ${ROOT}/etc/udev/rules.d/95-net.rules ]]
+ then
+ rm -f "${ROOT}"/etc/udev/rules.d/95-net.rules
+ fi
+
+ # Try to remove /etc/dev.d as that is obsolete
+ if [[ -d ${ROOT}/etc/dev.d ]]
+ then
+ rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/default "${ROOT}"/etc/dev.d 2>/dev/null
+ if [[ -d ${ROOT}/etc/dev.d ]]
+ then
+ ewarn "You still have the directory /etc/dev.d on your system."
+ ewarn "This is no longer used by udev and can be removed."
+ fi
+ fi
+
+ # 64-device-mapper.rules now gets installed by sys-fs/device-mapper
+ # remove it if user don't has sys-fs/device-mapper installed
+ if has_version "<sys-fs/udev-113" &&
+ [[ -f ${ROOT}/etc/udev/rules.d/64-device-mapper.rules ]] &&
+ ! has_version sys-fs/device-mapper
+ then
+ rm -f "${ROOT}"/etc/udev/rules.d/64-device-mapper.rules
+ einfo "Removed unneeded file 64-device-mapper.rules"
+ fi
+
+ if [[ ${ROOT} == / ]]
+ then
+ # check if root of init-process is identical to ours
+ if [[ -r /proc/1/root && /proc/1/root/ -ef /proc/self/root/ ]]
+ then
+ einfo "restarting udevd now."
+ if [[ -n $(pidof udevd) ]]
+ then
+ killall -15 udevd &>/dev/null
+ sleep 1
+ killall -9 udevd &>/dev/null
+ fi
+ /sbin/udevd --daemon
+ fi
+ fi
+
+ ewarn "If you build an initramfs including udev, then please"
+ ewarn "make sure that the /sbin/udevadm binary gets included,"
+ ewarn "as the helper apps udevinfo, udevtrigger, ... are now"
+ ewarn "only symlinks to udevadm."
+
+ einfo
+ einfo "For more information on udev on Gentoo, writing udev rules, and"
+ einfo " fixing known issues visit:"
+ einfo " http://www.gentoo.org/doc/en/udev-guide.xml"
+}