summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-05-01 18:31:06 +0000
committerMike Gilbert <floppym@gentoo.org>2015-05-01 18:31:06 +0000
commit3668fc8c4ca841a1974f4d4e6061177f04c7a255 (patch)
treefad81d6543b62e1370a4da68d99b45153236b2c4 /sys-fs/udev
parentStable for PPC64 (bug #520864). (diff)
downloadgentoo-2-3668fc8c4ca841a1974f4d4e6061177f04c7a255.tar.gz
gentoo-2-3668fc8c4ca841a1974f4d4e6061177f04c7a255.tar.bz2
gentoo-2-3668fc8c4ca841a1974f4d4e6061177f04c7a255.zip
Fix build failure when libmount is not built for all multilib abis, bug 533724. Thanks to theprogrammernerd for the patch.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-fs/udev')
-rw-r--r--sys-fs/udev/ChangeLog7
-rw-r--r--sys-fs/udev/udev-218.ebuild10
-rw-r--r--sys-fs/udev/udev-219.ebuild8
-rw-r--r--sys-fs/udev/udev-9999.ebuild8
4 files changed, 28 insertions, 5 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 1a3d297db9bb..fdadf03fe129 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.1106 2015/04/25 17:56:15 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.1107 2015/05/01 18:31:06 floppym Exp $
+
+ 01 May 2015; Mike Gilbert <floppym@gentoo.org> udev-218.ebuild,
+ udev-219.ebuild, udev-9999.ebuild:
+ Fix build failure when libmount is not built for all multilib abis, bug
+ 533724. Thanks to theprogrammernerd for the patch.
25 Apr 2015; William Hubbs <williamh@gentoo.org> udev-219.ebuild,
udev-9999.ebuild:
diff --git a/sys-fs/udev/udev-218.ebuild b/sys-fs/udev/udev-218.ebuild
index 9a8506fb99ab..29f75d0eb420 100644
--- a/sys-fs/udev/udev-218.ebuild
+++ b/sys-fs/udev/udev-218.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-218.ebuild,v 1.1 2014/12/17 17:17:42 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-218.ebuild,v 1.2 2015/05/01 18:31:06 floppym Exp $
EAPI=5
@@ -205,6 +205,12 @@ multilib_src_configure() {
$(multilib_is_native_abi && echo "--with-rootlibdir=/$(get_libdir)")
)
+ if ! multilib_is_native_abi; then
+ econf_args+=(
+ MOUNT_{CFLAGS,LIBS}=' '
+ )
+ fi
+
# Use pregenerated copies when possible wrt #480924
[[ ${PV} = 9999* ]] || econf_args+=( --disable-manpages )
diff --git a/sys-fs/udev/udev-219.ebuild b/sys-fs/udev/udev-219.ebuild
index 7dc9627c975f..a32185916774 100644
--- a/sys-fs/udev/udev-219.ebuild
+++ b/sys-fs/udev/udev-219.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-219.ebuild,v 1.2 2015/04/25 17:56:15 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-219.ebuild,v 1.3 2015/05/01 18:31:06 floppym Exp $
EAPI=5
@@ -205,6 +205,12 @@ multilib_src_configure() {
$(multilib_is_native_abi && echo "--with-rootlibdir=/$(get_libdir)")
)
+ if ! multilib_is_native_abi; then
+ econf_args+=(
+ MOUNT_{CFLAGS,LIBS}=' '
+ )
+ fi
+
# Use pregenerated copies when possible wrt #480924
[[ ${PV} = 9999* ]] || econf_args+=( --disable-manpages )
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 948a532919b5..0e6d2291cb11 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.325 2015/04/25 17:56:15 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.326 2015/05/01 18:31:06 floppym Exp $
EAPI=5
@@ -205,6 +205,12 @@ multilib_src_configure() {
$(multilib_is_native_abi && echo "--with-rootlibdir=/$(get_libdir)")
)
+ if ! multilib_is_native_abi; then
+ econf_args+=(
+ MOUNT_{CFLAGS,LIBS}=' '
+ )
+ fi
+
# Use pregenerated copies when possible wrt #480924
[[ ${PV} = 9999* ]] || econf_args+=( --disable-manpages )