summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-28 17:54:55 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-28 17:54:55 +0000
commitc03831fd17fc74e1f7d602e5d466166a4ddd1c64 (patch)
tree95b8f98879a966b7a21e320a89bb3653ee43e9ac /sys-fs/udev/udev-9999.ebuild
parentReplace multilib_build_binaries with multilib_is_native_abi, in order to put ... (diff)
downloadgentoo-2-c03831fd17fc74e1f7d602e5d466166a4ddd1c64.tar.gz
gentoo-2-c03831fd17fc74e1f7d602e5d466166a4ddd1c64.tar.bz2
gentoo-2-c03831fd17fc74e1f7d602e5d466166a4ddd1c64.zip
Replace multilib_build_binaries with multilib_is_native_abi, in order to put an end to the confusion introduced by having two functions, the proper one suggesting it is just for binaries.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-fs/udev/udev-9999.ebuild')
-rw-r--r--sys-fs/udev/udev-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 1b91c32b002b..72287c4630d6 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.294 2014/04/08 21:01:41 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.295 2014/04/28 17:54:55 mgorny Exp $
EAPI=5
@@ -210,7 +210,7 @@ multilib_src_configure() {
--disable-manpages
)
fi
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
econf_args+=(
$(use_enable static-libs static)
$(use_enable doc gtk-doc)
@@ -245,7 +245,7 @@ multilib_src_compile() {
# but not everything -- separate building of the binaries as a workaround,
# which will force internal libraries required for the helpers to be built
# early enough, like eg. libsystemd-shared.la
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
local lib_targets=( libudev.la )
use gudev && lib_targets+=( libgudev-1.0.la )
emake "${lib_targets[@]}"
@@ -289,7 +289,7 @@ multilib_src_compile() {
}
multilib_src_install() {
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
local lib_LTLIBRARIES="libudev.la" \
pkgconfiglib_DATA="src/libudev/libudev.pc"