summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-30 23:36:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-30 23:36:56 +0000
commit9f7e5f5c2d5b841630c95aa138ce97fae8d048d0 (patch)
tree26e8d31470e283f3922e454110ed7fbc274e17cd /sys-fs/traydevice
parentamd64/x86 stable (diff)
downloadgentoo-2-9f7e5f5c2d5b841630c95aa138ce97fae8d048d0.tar.gz
gentoo-2-9f7e5f5c2d5b841630c95aa138ce97fae8d048d0.tar.bz2
gentoo-2-9f7e5f5c2d5b841630c95aa138ce97fae8d048d0.zip
Version bump.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/traydevice')
-rw-r--r--sys-fs/traydevice/ChangeLog8
-rw-r--r--sys-fs/traydevice/traydevice-1.5.2.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-fs/traydevice/ChangeLog b/sys-fs/traydevice/ChangeLog
index fe16435078f8..f1a8905cf37b 100644
--- a/sys-fs/traydevice/ChangeLog
+++ b/sys-fs/traydevice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/traydevice
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/ChangeLog,v 1.2 2010/09/30 23:34:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/ChangeLog,v 1.3 2010/09/30 23:36:56 ssuominen Exp $
+
+*traydevice-1.5.2 (30 Sep 2010)
+
+ 30 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +traydevice-1.5.2.ebuild:
+ Version bump.
30 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> traydevice-1.5.ebuild:
amd64/x86 stable
diff --git a/sys-fs/traydevice/traydevice-1.5.2.ebuild b/sys-fs/traydevice/traydevice-1.5.2.ebuild
new file mode 100644
index 000000000000..bf57fa2a4822
--- /dev/null
+++ b/sys-fs/traydevice/traydevice-1.5.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/traydevice-1.5.2.ebuild,v 1.1 2010/09/30 23:36:56 ssuominen Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="A little desktop application displaying systray icon for UDisks"
+HOMEPAGE="http://savannah.nongnu.org/projects/traydevice/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python
+ dev-python/lxml
+ dev-python/pyxdg
+ sys-fs/udisks"
+DEPEND="app-text/docbook2X"
+
+src_prepare() {
+ sed -i \
+ -e 's:docbook2man:docbook2man.pl:' \
+ setup.py || die
+
+ distutils_src_prepare
+}
+
+src_compile() { :; }
+
+src_install() {
+ distutils_src_install \
+ --root="${D}" \
+ --prefix=/usr \
+ --install-data=/usr/share/${PN} \
+ --install-man=/usr/share/man
+
+ rm -f "${D}"/usr/share/${PN}/*.txt
+}