summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-05-11 18:37:21 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-05-11 18:37:21 +0000
commit5218f6d3025d608f2125e12ac5107908f113ef4e (patch)
tree6f175b47b890045585cdf4c4ddded8f324a25e01 /sys-fs/traydevice
parentDisable automagic app-text/xmlto usage to prevent manpages from getting rebui... (diff)
downloadgentoo-2-5218f6d3025d608f2125e12ac5107908f113ef4e.tar.gz
gentoo-2-5218f6d3025d608f2125e12ac5107908f113ef4e.tar.bz2
gentoo-2-5218f6d3025d608f2125e12ac5107908f113ef4e.zip
Version bump
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'sys-fs/traydevice')
-rw-r--r--sys-fs/traydevice/ChangeLog10
-rw-r--r--sys-fs/traydevice/traydevice-1.6.2.ebuild38
2 files changed, 45 insertions, 3 deletions
diff --git a/sys-fs/traydevice/ChangeLog b/sys-fs/traydevice/ChangeLog
index c939427f6a54..e9f4ef47b4cb 100644
--- a/sys-fs/traydevice/ChangeLog
+++ b/sys-fs/traydevice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/traydevice
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/ChangeLog,v 1.6 2012/03/27 18:41:32 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/ChangeLog,v 1.7 2013/05/11 18:37:21 hwoarang Exp $
+
+*traydevice-1.6.2 (11 May 2013)
+
+ 11 May 2013; Markos Chandras <hwoarang@gentoo.org> +traydevice-1.6.2.ebuild:
+ Version bump
27 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> traydevice-1.5.ebuild,
traydevice-1.5.2.ebuild:
@@ -27,4 +32,3 @@
21 Aug 2010; Samuli Suominen <ssuominen@gentoo.org>
+traydevice-1.5.ebuild:
Initial commit.
-
diff --git a/sys-fs/traydevice/traydevice-1.6.2.ebuild b/sys-fs/traydevice/traydevice-1.6.2.ebuild
new file mode 100644
index 000000000000..6b6381ce14ca
--- /dev/null
+++ b/sys-fs/traydevice/traydevice-1.6.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/traydevice-1.6.2.ebuild,v 1.1 2013/05/11 18:37:21 hwoarang Exp $
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="A little desktop application displaying systray icon for UDisks"
+HOMEPAGE="http://savannah.nongnu.org/projects/traydevice/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python
+ dev-python/lxml
+ dev-python/pyxdg
+ sys-fs/udisks:0"
+DEPEND="app-text/docbook2X"
+
+src_compile() { :; }
+
+src_install() {
+ distutils_src_install \
+ --prefix=/usr \
+ --install-data=/usr/share/${PN} \
+ --install-man=/usr/share/man \
+ --docbook2man=$(type -p docbook2man.pl)
+
+ rm -f "${D}"/usr/share/${PN}/*.txt
+}