summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-12-29 17:16:47 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-12-29 17:16:47 +0000
commitd693b87f993916a6e13c5cc9f2cdda8cf23c13a9 (patch)
tree0b706cee51c661199a41d7339c3f37a310a509e6 /sys-fs/simple-mtpfs
parentadd ~arm, bug #490374 (diff)
downloadgentoo-2-d693b87f993916a6e13c5cc9f2cdda8cf23c13a9.tar.gz
gentoo-2-d693b87f993916a6e13c5cc9f2cdda8cf23c13a9.tar.bz2
gentoo-2-d693b87f993916a6e13c5cc9f2cdda8cf23c13a9.zip
Version bump to 0.2 and use git-r3 eclass.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'sys-fs/simple-mtpfs')
-rw-r--r--sys-fs/simple-mtpfs/ChangeLog8
-rw-r--r--sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild30
-rw-r--r--sys-fs/simple-mtpfs/simple-mtpfs-9999.ebuild9
3 files changed, 43 insertions, 4 deletions
diff --git a/sys-fs/simple-mtpfs/ChangeLog b/sys-fs/simple-mtpfs/ChangeLog
index 1b3bf6235404..7448da43dfb7 100644
--- a/sys-fs/simple-mtpfs/ChangeLog
+++ b/sys-fs/simple-mtpfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/simple-mtpfs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/simple-mtpfs/ChangeLog,v 1.5 2013/04/06 07:28:50 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/simple-mtpfs/ChangeLog,v 1.6 2013/12/29 17:16:47 scarabeus Exp $
+
+*simple-mtpfs-0.2 (29 Dec 2013)
+
+ 29 Dec 2013; Tomáš Chvátal <scarabeus@gentoo.org> +simple-mtpfs-0.2.ebuild,
+ simple-mtpfs-9999.ebuild:
+ Version bump to 0.2 and use git-r3 eclass.
*simple-mtpfs-9999 (06 Apr 2013)
diff --git a/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild b/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild
new file mode 100644
index 000000000000..28edfdac401d
--- /dev/null
+++ b/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild,v 1.1 2013/12/29 17:16:47 scarabeus Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://github.com/phatina/${PN}.git"
+inherit autotools-utils eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
+
+DESCRIPTION="Simple MTP fuse filesystem driver"
+HOMEPAGE="https://github.com/phatina/simple-mtpfs"
+[[ ${PV} == 9999 ]] || SRC_URI="https://github.com/phatina/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libmtp
+ >=sys-fs/fuse-2.8
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+[[ ${PV} == 9999 ]] || S="${WORKDIR}/${PN}-${P}"
+
+AUTOTOOLS_AUTORECONF=1
diff --git a/sys-fs/simple-mtpfs/simple-mtpfs-9999.ebuild b/sys-fs/simple-mtpfs/simple-mtpfs-9999.ebuild
index ba7d6b920959..c0605d65abe9 100644
--- a/sys-fs/simple-mtpfs/simple-mtpfs-9999.ebuild
+++ b/sys-fs/simple-mtpfs/simple-mtpfs-9999.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/simple-mtpfs/simple-mtpfs-9999.ebuild,v 1.1 2013/04/06 07:28:50 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/simple-mtpfs/simple-mtpfs-9999.ebuild,v 1.2 2013/12/29 17:16:47 scarabeus Exp $
EAPI=5
EGIT_REPO_URI="git://github.com/phatina/${PN}.git"
-inherit autotools-utils eutils git-2
+inherit autotools-utils eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
DESCRIPTION="Simple MTP fuse filesystem driver"
HOMEPAGE="https://github.com/phatina/simple-mtpfs"
-[[ ${PV} == 9999 ]] || SRC_URI="mirror://github/phatina/${PN}/${P}.tar.gz"
+[[ ${PV} == 9999 ]] || SRC_URI="https://github.com/phatina/${PN}/archive/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
@@ -24,4 +25,6 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+[[ ${PV} == 9999 ]] || S="${WORKDIR}/${PN}-${P}"
+
AUTOTOOLS_AUTORECONF=1