summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-07-29 22:44:56 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-07-29 22:44:56 +0000
commit2141c3f313fa071ae86833c3b92cc5560d246b4f (patch)
treec57469a1f2305e3a7639dd15d482a24cd3df0a2f /sys-fs/safecopy/safecopy-1.5.ebuild
parentRespecting CC variable, closes bug #243934 (diff)
downloadgentoo-2-2141c3f313fa071ae86833c3b92cc5560d246b4f.tar.gz
gentoo-2-2141c3f313fa071ae86833c3b92cc5560d246b4f.tar.bz2
gentoo-2-2141c3f313fa071ae86833c3b92cc5560d246b4f.zip
Version bump. Remove old.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'sys-fs/safecopy/safecopy-1.5.ebuild')
-rw-r--r--sys-fs/safecopy/safecopy-1.5.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-fs/safecopy/safecopy-1.5.ebuild b/sys-fs/safecopy/safecopy-1.5.ebuild
new file mode 100644
index 000000000000..06f9e35a0f59
--- /dev/null
+++ b/sys-fs/safecopy/safecopy-1.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/safecopy/safecopy-1.5.ebuild,v 1.1 2009/07/29 22:44:56 scarabeus Exp $
+
+EAPI=2
+inherit base
+
+DESCRIPTION="Data recovery tool to fault-tolerantly extract data from damaged (io-errors) devices or files."
+HOMEPAGE="http://safecopy.sourceforge.net"
+SRC_URI="mirror://sourceforge/safecopy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ sed -e 's:bin/sh:bin/bash:' \
+ -i "${S}"/test/test.sh || die "sed failed"
+}
+
+src_configure() {
+ base_src_configure
+ if use test; then
+ cd "${S}"/simulator
+ econf
+ fi
+}
+
+src_compile() {
+ base_src_compile
+ if use test; then
+ cd "${S}"/simulator
+ emake || die "Simulator compilation failed -- needed for testing"
+ fi
+}
+
+src_install() {
+ base_src_install
+ dodoc README || die "copying documentation failed"
+}
+
+src_test() {
+ cd "${S}"/test
+ ./test.sh || die "./tesh.sh failed"
+}