summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-18 01:47:46 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-18 01:47:46 +0000
commitd1312f1d0af7a80ac54b982b3ea90e839483cb26 (patch)
tree586c7b4cd581b1f02b82e3ff2b8a786cabcf6b29 /sys-fs/s3fs
parentVersion bump. Respect LDFLAGS (bug #335415), CC. Fix some compiler warnings. ... (diff)
downloadgentoo-2-d1312f1d0af7a80ac54b982b3ea90e839483cb26.tar.gz
gentoo-2-d1312f1d0af7a80ac54b982b3ea90e839483cb26.tar.bz2
gentoo-2-d1312f1d0af7a80ac54b982b3ea90e839483cb26.zip
Version bump. Fix patch to respect LDFLAGS (bug #335416).
(Portage version: 2.2_rc83/cvs/Linux i686)
Diffstat (limited to 'sys-fs/s3fs')
-rw-r--r--sys-fs/s3fs/ChangeLog8
-rw-r--r--sys-fs/s3fs/files/s3fs-177-asneeded.patch6
-rw-r--r--sys-fs/s3fs/s3fs-191.ebuild41
3 files changed, 51 insertions, 4 deletions
diff --git a/sys-fs/s3fs/ChangeLog b/sys-fs/s3fs/ChangeLog
index 8dfd2d3240ca..1088fcb0d585 100644
--- a/sys-fs/s3fs/ChangeLog
+++ b/sys-fs/s3fs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/s3fs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/ChangeLog,v 1.5 2010/06/02 07:06:51 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/ChangeLog,v 1.6 2010/09/18 01:47:45 jer Exp $
+
+*s3fs-191 (18 Sep 2010)
+
+ 18 Sep 2010; Jeroen Roovers <jer@gentoo.org>
+ files/s3fs-177-asneeded.patch, +s3fs-191.ebuild:
+ Version bump. Fix patch to respect LDFLAGS (bug #335416).
02 Jun 2010; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove caleb from metadata.xml (#317071)
diff --git a/sys-fs/s3fs/files/s3fs-177-asneeded.patch b/sys-fs/s3fs/files/s3fs-177-asneeded.patch
index 63e5446009ae..b39fb83ad904 100644
--- a/sys-fs/s3fs/files/s3fs-177-asneeded.patch
+++ b/sys-fs/s3fs/files/s3fs-177-asneeded.patch
@@ -1,9 +1,9 @@
---- s3fs.orig/Makefile 2008-05-19 19:34:38.000000000 +0200
-+++ s3fs/Makefile 2009-10-19 22:10:55.810129401 +0200
+--- a/Makefile 2008-05-19 19:34:38.000000000 +0200
++++ b/Makefile 2009-10-19 22:10:55.810129401 +0200
@@ -1,5 +1,5 @@
all:
- g++ -ggdb -Wall $(shell pkg-config fuse --cflags --libs) $(shell pkg-config libcurl --cflags --libs) $(shell xml2-config --cflags --libs) -lcrypto s3fs.cpp -o s3fs
-+ $(CXX) $(CXXFLAGS) s3fs.cpp -o s3fs $(shell pkg-config fuse --cflags --libs) $(shell pkg-config libcurl --cflags --libs) $(shell xml2-config --cflags --libs) -lcrypto
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) s3fs.cpp -o s3fs $(shell pkg-config fuse --cflags --libs) $(shell pkg-config libcurl --cflags --libs) $(shell xml2-config --cflags --libs) -lcrypto
@echo ok!
install: all
diff --git a/sys-fs/s3fs/s3fs-191.ebuild b/sys-fs/s3fs/s3fs-191.ebuild
new file mode 100644
index 000000000000..7e513aa0b51f
--- /dev/null
+++ b/sys-fs/s3fs/s3fs-191.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/s3fs-191.ebuild,v 1.1 2010/09/18 01:47:45 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_PV="r${PV}-source"
+
+DESCRIPTION="Amazon mounting S3 via fuse"
+HOMEPAGE="http://s3fs.googlecode.com/"
+SRC_URI="http://s3fs.googlecode.com/files/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+DEPEND=">=net-misc/curl-7.17.1
+ >=sys-fs/fuse-2.6.0
+ dev-libs/libxml2
+ dev-libs/openssl"
+
+RDEPEND="${DEPEND}
+ app-misc/mime-types"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-177-asneeded.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die
+
+}
+
+src_install() {
+ dobin s3fs || die
+}